aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2018-04-20 15:44:18 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2018-04-20 15:44:18 +0000
commita56f4262afd4110acdd93b4c3e1d9ea31cf9526a (patch)
treeccaf11e21e052292ce29f16d012dfb97ff17bc5d /net-mgmt
parent1e448a34b737719065be68b6b83c9323a03b69d1 (diff)
downloadports-a56f4262afd4110acdd93b4c3e1d9ea31cf9526a.tar.gz
ports-a56f4262afd4110acdd93b4c3e1d9ea31cf9526a.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-prometheus-client/Makefile27
-rw-r--r--net-mgmt/py-prometheus-client/distinfo3
-rw-r--r--net-mgmt/py-prometheus-client/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 75b5f9aea1fe..15f989a4f6be 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -316,6 +316,7 @@
SUBDIR += py-ncclient
SUBDIR += py-pdagent
SUBDIR += py-pyIOSXR
+ SUBDIR += py-prometheus-client
SUBDIR += py-pyang
SUBDIR += py-pyeapi
SUBDIR += py-pynsca
diff --git a/net-mgmt/py-prometheus-client/Makefile b/net-mgmt/py-prometheus-client/Makefile
new file mode 100644
index 000000000000..7e1fa9c3050b
--- /dev/null
+++ b/net-mgmt/py-prometheus-client/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= prometheus-client
+PORTVERSION= 0.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net-mgmt python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= pizzamig@FreeBSD.org
+COMMENT= Official Python client for Prometheus
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=17.9.0:devel/py-twisted@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>=17.9.0:devel/py-twisted@${FLAVOR}
+
+USES= python
+
+USE_PYTHON= autoplist distutils
+
+USE_GITHUB= yes
+GH_ACCOUNT= prometheus
+GH_PROJECT= client_python
+
+NO_ARCH= yes
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-prometheus-client/distinfo b/net-mgmt/py-prometheus-client/distinfo
new file mode 100644
index 000000000000..b46804d101d0
--- /dev/null
+++ b/net-mgmt/py-prometheus-client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524048766
+SHA256 (prometheus-client_python-v0.2.0_GH0.tar.gz) = d270837133c3e808ac66a4f5f9ae1b671296c171b23d48a509cfa38c7017376d
+SIZE (prometheus-client_python-v0.2.0_GH0.tar.gz) = 41574
diff --git a/net-mgmt/py-prometheus-client/pkg-descr b/net-mgmt/py-prometheus-client/pkg-descr
new file mode 100644
index 000000000000..6069e0bb07a4
--- /dev/null
+++ b/net-mgmt/py-prometheus-client/pkg-descr
@@ -0,0 +1,3 @@
+Prometheus instrumentation library for Python applications
+
+WWW: https://github.com/prometheus/client_python