aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-12-16 17:37:53 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-12-16 17:37:53 +0000
commitbb7c943a406e818e89a66972e1a42faeef5c294e (patch)
tree949118efa9dfdee0b92bad6c0328948d9fff8d11 /net-mgmt
parentba3f78055cf79dec9f66458c1284a2bfe2215e66 (diff)
downloadports-bb7c943a406e818e89a66972e1a42faeef5c294e.tar.gz
ports-bb7c943a406e818e89a66972e1a42faeef5c294e.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/librenms/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/net-mgmt/librenms/Makefile b/net-mgmt/librenms/Makefile
index ecf34481e15f..49cd982ffc5a 100644
--- a/net-mgmt/librenms/Makefile
+++ b/net-mgmt/librenms/Makefile
@@ -3,11 +3,7 @@
PORTNAME= librenms
PORTVERSION= 1.45
-PORTREVISION= 1
-# RELEASE_TIMESTAMP is used for a patch inside the vendor code
-# it represents the release date via: git show --pretty='%H|%ct' -s 1.42.01
-# It sits here so you remember to update it with each release
-RELEASE_TIMESTAMP= 1539772408
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= LOCAL/dvl:vendor
@@ -18,8 +14,14 @@ COMMENT= Autodiscovering PHP/MySQL/SNMP based network monitoring
LICENSE= GPLv3
-# perhaps we also need python-memcache python-mysqldb
+USES= python${PY_MYSQL} shebangfix
+
+# RELEASE_TIMESTAMP is used for a patch inside the vendor code
+# it represents the release date via: git show --pretty='%H|%ct' -s 1.42.01
+# It sits here so you remember to update it with each release
+RELEASE_TIMESTAMP= 1539772408
+# perhaps we also need python-memcache python-mysqldb
RUN_DEPENDS+= rrdtool:databases/rrdtool \
dot:graphics/graphviz \
${LOCALBASE}/share/pear/Net/IPv4.php:net/pear-Net_IPv4@${PHP_FLAVOR} \
@@ -28,8 +30,6 @@ RUN_DEPENDS+= rrdtool:databases/rrdtool \
bash:shells/bash \
sudo:security/sudo
-USES= python${PY_MYSQL} shebangfix
-
USE_PHP= ctype curl filter gd hash json ldap mbstring mysqli openssl pdo pdo_mysql posix session simplexml snmp tokenizer xml zip
USE_GITHUB= yes
@@ -157,6 +157,9 @@ do-install:
# Ensure PHP and Python scripts are executable
${FIND} ${STAGEDIR}/${WWWDIR} -type f -name '*.py' -or -type f -name \
'*.php' -exec ${CHMOD} +x {} \;
+# these values should be outside the www tree now
+ ${MKDIR} ${STAGEDIR}/var/log/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}/var/db/${PORTNAME}
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}/${DOCSDIR}
@@ -171,10 +174,6 @@ do-install-EXAMPLES-on:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${EXAMPLESDIR}
.endfor
-# these values should be outside the www tree now
- ${MKDIR} ${STAGEDIR}/var/log/${PORTNAME}
- ${MKDIR} ${STAGEDIR}/var/db/${PORTNAME}
-
post-install:
@${FIND} -s ${STAGEDIR}${WWWDIR} -type f '(' -name '*.orig' -or -name '*.bak' -or -name '.gitignore' ')' -delete
@${FIND} -s ${STAGEDIR}${WWWDIR} -not -type d | ${SORT} | \