aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-10-07 19:43:33 +0000
committerMark Felder <feld@FreeBSD.org>2014-10-07 19:43:33 +0000
commitbfa6325392d9a6ea46ef47a02841d20db3e54fc1 (patch)
tree76508ae2a10da6e544d4e87ddda9104ca70bc179 /net-mgmt
parentccfac88b3a16a66843943ef06f2f5d7828155a74 (diff)
downloadports-bfa6325392d9a6ea46ef47a02841d20db3e54fc1.tar.gz
ports-bfa6325392d9a6ea46ef47a02841d20db3e54fc1.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/xymon-server/Makefile27
-rw-r--r--net-mgmt/xymon-server/files/patch-xymond-Makefile19
-rw-r--r--net-mgmt/xymon-server/files/xymon-server.in6
-rw-r--r--net-mgmt/xymon-server/pkg-plist142
4 files changed, 86 insertions, 108 deletions
diff --git a/net-mgmt/xymon-server/Makefile b/net-mgmt/xymon-server/Makefile
index f4b115baaa68..6bdf5f7bda6c 100644
--- a/net-mgmt/xymon-server/Makefile
+++ b/net-mgmt/xymon-server/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xymon
PORTVERSION= 4.3.17
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt www
MASTER_SITES= SF/xymon/Xymon/${PORTVERSION}
PKGNAMESUFFIX= -server${PKGNAMESUFFIX2}
@@ -29,7 +29,10 @@ XYMONUSER?= xymon
XYMONHOSTNAME?= xymon.example.com
XYMONHOSTIP?= 127.0.0.1
-USES= gmake
+USES= cpe gmake shebangfix
+CPE_VENDOR= xymon
+CPE_PRODUCT= xymon
+SHEBANG_FILES= ${WRKSRC}/xymond/xymonreports.sh.DIST ${WRKSRC}/build/upgrade430.sh
USE_OPENSSL= yes
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ENV= MAKE=gmake
@@ -43,9 +46,9 @@ USE_RC_SUBR= xymon-server
SUB_LIST+= XYMONUSER="${XYMONUSER}"
PLIST_SUB+= XYMONUSER="${XYMONUSER}"
-CONFIG_FILES= alerts.cfg analysis.cfg cgioptions.cfg client-local.cfg \
- columndoc.csv combo.cfg graphs.cfg holidays.cfg protocols.cfg \
- rrddefinitions.cfg tasks.cfg xymonserver.cfg
+CONFIG_FILES= cgioptions.cfg client-local.cfg \
+ columndoc.csv graphs.cfg protocols.cfg \
+ tasks.cfg xymonserver.cfg xymon-apache.conf
FIXME1= alerts.cfg hosts.cfg xymon-apache-open xymon-apache-secure
FIXME2= analysis.cfg combo.cfg holidays.cfg rrddefinitions.cfg \
snmpmibs.cfg xymonmenu.cfg xymonserver-migration.cfg
@@ -66,8 +69,6 @@ LIB_DEPENDS+= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|!/bin/bash|!/usr/local/bin/bash|' \
- ${WRKSRC}/xymond/xymonreports.sh.DIST
${REINPLACE_CMD} -e 's|web-build client|web-build|' ${WRKSRC}/build/Makefile.rules
${REINPLACE_CMD} -e 's|install-docs install-client|install-docs|' ${WRKSRC}/build/Makefile.rules
${REINPLACE_CMD} -e 's|$(INSTALLETCDIR)/protocols.cfg|$(INSTALLETCDIR)/protocols.cfg.DIST|' ${WRKSRC}/xymonnet/Makefile
@@ -82,19 +83,13 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/build/upgrade430.sh ${STAGEDIR}${WWWDIR}/server/bin/
${INSTALL_PROGRAM} ${WRKSRC}/build/renamevars ${STAGEDIR}${WWWDIR}/server/bin/
.for i in ${FIXME1}
- ${INSTALL_DATA} ${WRKSRC}/xymond/etcfiles/${i}.DIST ${STAGEDIR}${WWWDIR}/server/etc/
+ ${INSTALL_DATA} ${WRKSRC}/xymond/etcfiles/${i}.DIST ${STAGEDIR}${WWWDIR}/server/etc/${i}.sample
.endfor
.for i in ${FIXME2}
- ${INSTALL_DATA} ${WRKSRC}/xymond/etcfiles/${i} ${STAGEDIR}${WWWDIR}/server/etc/${i}.DIST
+ ${INSTALL_DATA} ${WRKSRC}/xymond/etcfiles/${i} ${STAGEDIR}${WWWDIR}/server/etc/${i}.sample
.endfor
.for i in ${CONFIG_FILES}
- ${CP} -np ${STAGEDIR}${WWWDIR}/server/etc/${i}.DIST \
- ${STAGEDIR}${WWWDIR}/server/etc/${i} || ${TRUE}
+ ${MV} ${STAGEDIR}${WWWDIR}/server/etc/${i}.DIST ${STAGEDIR}${WWWDIR}/server/etc/${i}.sample
.endfor
- # this dir should NOT get installed with the package; will do in rc script
- ${RMDIR} ${STAGEDIR}/var/log/xymon
- ${RMDIR} ${STAGEDIR}/var/log
- ${RMDIR} ${STAGEDIR}/var
-
.include <bsd.port.mk>
diff --git a/net-mgmt/xymon-server/files/patch-xymond-Makefile b/net-mgmt/xymon-server/files/patch-xymond-Makefile
index 65b1eef1df76..30d1ede61c56 100644
--- a/net-mgmt/xymon-server/files/patch-xymond-Makefile
+++ b/net-mgmt/xymon-server/files/patch-xymond-Makefile
@@ -1,6 +1,6 @@
---- xymond/Makefile.orig 2011-12-12 23:18:17.000000000 +0100
-+++ xymond/Makefile 2012-01-12 06:55:06.000000000 +0100
-@@ -153,13 +153,13 @@
+--- xymond/Makefile.orig 2014-02-10 21:13:18 UTC
++++ xymond/Makefile
+@@ -180,25 +180,20 @@
cp -fp *.8 $(INSTALLROOT)$(MANROOT)/man8/
install-cfg:
@@ -21,3 +21,16 @@
cd $(INSTALLROOT)$(XYMONHOME); rm -f xymon.sh; ln -sf bin/xymon.sh .
cd wwwfiles; find . | grep -v RCS | grep -v ".svn" | grep -v DIST | ../../build/setup-newfiles $(INSTALLROOT)$(INSTALLWWWDIR)/ ../../build/md5.dat
cd webfiles; find . | grep -v RCS | grep -v ".svn" | grep -v DIST | ../../build/setup-newfiles $(INSTALLROOT)$(INSTALLWEBDIR)/ ../../build/md5.dat
+- touch $(INSTALLROOT)$(INSTALLETCDIR)/critical.cfg $(INSTALLROOT)$(INSTALLETCDIR)/critical.cfg.bak
+- chmod 664 $(INSTALLROOT)$(INSTALLETCDIR)/critical.cfg $(INSTALLROOT)$(INSTALLETCDIR)/critical.cfg.bak
+- mkdir -p $(INSTALLROOT)$(XYMONLOGDIR); chmod 755 $(INSTALLROOT)$(XYMONLOGDIR)
+ mkdir -p $(INSTALLROOT)$(INSTALLETCDIR)/tasks.d; chmod 755 $(INSTALLROOT)$(INSTALLETCDIR)/tasks.d
+ ifndef PKGBUILD
+- chown $(XYMONUSER) $(INSTALLROOT)$(XYMONLOGDIR) $(INSTALLROOT)$(XYMONHOME) $(INSTALLROOT)$(XYMONHOME)/* $(INSTALLROOT)$(INSTALLBINDIR)/* $(INSTALLROOT)$(INSTALLETCDIR)/* $(INSTALLROOT)$(INSTALLEXTDIR)/* $(INSTALLROOT)$(INSTALLWEBDIR)/* $(INSTALLROOT)$(INSTALLWWWDIR)/gifs $(INSTALLROOT)$(INSTALLWWWDIR)/gifs/* $(INSTALLROOT)$(INSTALLWWWDIR)/menu $(INSTALLROOT)$(INSTALLWWWDIR)/menu/* $(INSTALLROOT)$(INSTALLWWWDIR)/help $(INSTALLROOT)$(INSTALLWWWDIR)/notes $(INSTALLROOT)$(INSTALLWWWDIR)/html $(INSTALLROOT)$(INSTALLWWWDIR)/wml $(INSTALLROOT)$(XYMONVAR) $(INSTALLROOT)$(XYMONVAR)/*
++ chown $(XYMONUSER) $(INSTALLROOT)$(XYMONHOME) $(INSTALLROOT)$(XYMONHOME)/* $(INSTALLROOT)$(INSTALLBINDIR)/* $(INSTALLROOT)$(INSTALLETCDIR)/* $(INSTALLROOT)$(INSTALLEXTDIR)/* $(INSTALLROOT)$(INSTALLWEBDIR)/* $(INSTALLROOT)$(INSTALLWWWDIR)/gifs $(INSTALLROOT)$(INSTALLWWWDIR)/gifs/* $(INSTALLROOT)$(INSTALLWWWDIR)/menu $(INSTALLROOT)$(INSTALLWWWDIR)/menu/* $(INSTALLROOT)$(INSTALLWWWDIR)/help $(INSTALLROOT)$(INSTALLWWWDIR)/notes $(INSTALLROOT)$(INSTALLWWWDIR)/html $(INSTALLROOT)$(INSTALLWWWDIR)/wml $(INSTALLROOT)$(XYMONVAR) $(INSTALLROOT)$(XYMONVAR)/*
+ chgrp `$(IDTOOL) -g $(XYMONUSER)` $(INSTALLROOT)$(XYMONLOGDIR) $(INSTALLROOT)$(XYMONHOME) $(INSTALLROOT)$(XYMONHOME)/* $(INSTALLROOT)$(INSTALLBINDIR)/* $(INSTALLROOT)$(INSTALLETCDIR)/* $(INSTALLROOT)$(INSTALLEXTDIR)/* $(INSTALLROOT)$(INSTALLWEBDIR)/* $(INSTALLROOT)$(INSTALLWWWDIR)/gifs $(INSTALLROOT)$(INSTALLWWWDIR)/gifs/* $(INSTALLROOT)$(INSTALLWWWDIR)/menu $(INSTALLROOT)$(INSTALLWWWDIR)/menu/* $(INSTALLROOT)$(INSTALLWWWDIR)/help $(INSTALLROOT)$(INSTALLWWWDIR)/notes $(INSTALLROOT)$(INSTALLWWWDIR)/html $(INSTALLROOT)$(INSTALLWWWDIR)/wml $(INSTALLROOT)$(XYMONVAR) $(INSTALLROOT)$(XYMONVAR)/*
+- chgrp $(HTTPDGID) $(INSTALLROOT)$(INSTALLETCDIR)/critical.cfg $(INSTALLROOT)$(INSTALLETCDIR)/critical.cfg.bak
+- chmod 664 $(INSTALLROOT)$(INSTALLETCDIR)/critical.cfg $(INSTALLROOT)$(INSTALLETCDIR)/critical.cfg.bak
+
+ chown root $(INSTALLROOT)$(INSTALLBINDIR)/xymonping || echo "Could not make xymonping owned by root, continuing"
+ chmod 4755 $(INSTALLROOT)$(INSTALLBINDIR)/xymonping || echo "Could not make xymonping suid-root, continuing"
diff --git a/net-mgmt/xymon-server/files/xymon-server.in b/net-mgmt/xymon-server/files/xymon-server.in
index 92fff2720c49..d4748bddfe57 100644
--- a/net-mgmt/xymon-server/files/xymon-server.in
+++ b/net-mgmt/xymon-server/files/xymon-server.in
@@ -27,6 +27,12 @@ xymon_prestart()
if [ ! -d /var/log/xymon ]; then
install -d -o xymon /var/log/xymon
fi
+
+ for i in critical.cfg critical.cfg.bak ; do
+ if [ ! -f ${i} ]; then
+ install -o xymon -g xymon /dev/null %%WWWDIR%%/server/etc/${i} ;
+ fi
+ done
}
run_rc_command "$1"
diff --git a/net-mgmt/xymon-server/pkg-plist b/net-mgmt/xymon-server/pkg-plist
index af08e470ece7..8387718dd142 100644
--- a/net-mgmt/xymon-server/pkg-plist
+++ b/net-mgmt/xymon-server/pkg-plist
@@ -163,61 +163,25 @@ man/man8/xymonproxy.8
%%WWWDIR%%/server/bin/xymonping
%%WWWDIR%%/server/bin/xymonproxy
%%WWWDIR%%/server/bin/xymonreports.sh
-%%WWWDIR%%/server/etc/xymon-apache-open.DIST
-%%WWWDIR%%/server/etc/xymon-apache-secure.DIST
-%%WWWDIR%%/server/etc/xymon-apache.conf.DIST
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/alerts.cfg %D/%%WWWDIR%%/server/etc/alerts.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/alerts.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/analysis.cfg %D/%%WWWDIR%%/server/etc/analysis.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/analysis.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/cgioptions.cfg %D/%%WWWDIR%%/server/etc/cgioptions.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/cgioptions.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/client-local.cfg %D/%%WWWDIR%%/server/etc/client-local.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/client-local.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/columndoc.csv %D/%%WWWDIR%%/server/etc/columndoc.csv.DIST; then rm -f %D/%%WWWDIR%%/server/etc/columndoc.csv; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/combo.cfg %D/%%WWWDIR%%/server/etc/combo.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/combo.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/graphs.cfg %D/%%WWWDIR%%/server/etc/graphs.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/graphs.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/holidays.cfg %D/%%WWWDIR%%/server/etc/holidays.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/holidays.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/hosts.cfg %D/%%WWWDIR%%/server/etc/hosts.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/hosts.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/protocols.cfg %D/%%WWWDIR%%/server/etc/protocols.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/protocols.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/rrddefinitions.cfg %D/%%WWWDIR%%/server/etc/rrddefinitions.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/rrddefinitions.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/snmpmibs.cfg %D/%%WWWDIR%%/server/etc/snmpmibs.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/snmpmibs.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/tasks.cfg %D/%%WWWDIR%%/server/etc/tasks.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/tasks.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/xymonmenu.cfg %D/%%WWWDIR%%/server/etc/xymonmenu.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/xymonmenu.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/xymonserver-migration.cfg %D/%%WWWDIR%%/server/etc/xymonserver-migration.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/xymonserver-migration.cfg; fi
-@unexec if cmp -s %D/%%WWWDIR%%/server/etc/xymonserver.cfg %D/%%WWWDIR%%/server/etc/xymonserver.cfg.DIST; then rm -f %D/%%WWWDIR%%/server/etc/xymonserver.cfg; fi
-@unexec if test ! -s %D/%%WWWDIR%%/server/etc/critical.cfg; then rm -f %D/%%WWWDIR%%/server/etc/critical.cfg; fi
-@unexec if test ! -s %D/%%WWWDIR%%/server/etc/critical.cfg.bak; then rm -f %D/%%WWWDIR%%/server/etc/critical.cfg.bak; fi
-%%WWWDIR%%/server/etc/alerts.cfg.DIST
-@exec [ ! -f %B/alerts.cfg ] && cp %B/%f %B/alerts.cfg
-%%WWWDIR%%/server/etc/analysis.cfg.DIST
-@exec [ ! -f %B/analysis.cfg ] && cp %B/%f %B/analysis.cfg
-%%WWWDIR%%/server/etc/cgioptions.cfg.DIST
-@exec [ ! -f %B/cgioptions.cfg ] && cp %B/%f %B/cgioptions.cfg
-%%WWWDIR%%/server/etc/client-local.cfg.DIST
-@exec [ ! -f %B/client-local.cfg ] && cp %B/%f %B/client-local.cfg
-%%WWWDIR%%/server/etc/columndoc.csv.DIST
-@exec [ ! -f %B/columndoc.csv ] && cp %B/%f %B/columndoc.csv
-%%WWWDIR%%/server/etc/combo.cfg.DIST
-@exec [ ! -f %B/combo.cfg ] && cp %B/%f %B/combo.cfg
-%%WWWDIR%%/server/etc/graphs.cfg.DIST
-@exec [ ! -f %B/graphs.cfg ] && cp %B/%f %B/graphs.cfg
-%%WWWDIR%%/server/etc/holidays.cfg.DIST
-@exec [ ! -f %B/holidays.cfg ] && cp %B/%f %B/holidays.cfg
-%%WWWDIR%%/server/etc/hosts.cfg.DIST
-@exec [ ! -f %B/hosts.cfg ] && cp %B/%f %B/hosts.cfg
-%%WWWDIR%%/server/etc/protocols.cfg.DIST
-@exec [ ! -f %B/protocols.cfg ] && cp %B/%f %B/protocols.cfg
-%%WWWDIR%%/server/etc/rrddefinitions.cfg.DIST
-@exec [ ! -f %B/rrddefinitions.cfg ] && cp %B/%f %B/rrddefinitions.cfg
-%%WWWDIR%%/server/etc/snmpmibs.cfg.DIST
-@exec [ ! -f %B/snmpmibs.cfg ] && cp %B/%f %B/snmpmibs.cfg
-%%WWWDIR%%/server/etc/tasks.cfg.DIST
-@exec [ ! -f %B/tasks.cfg ] && cp %B/%f %B/tasks.cfg
-%%WWWDIR%%/server/etc/xymonmenu.cfg.DIST
-@exec [ ! -f %B/xymonmenu.cfg ] && cp %B/%f %B/xymonmenu.cfg
-%%WWWDIR%%/server/etc/xymonserver-migration.cfg.DIST
-@exec [ ! -f %B/xymonserver-migration.cfg ] && cp %B/%f %B/xymonserver-migration.cfg
-%%WWWDIR%%/server/etc/xymonserver.cfg.DIST
-@exec [ ! -f %B/xymonserver.cfg ] && cp %B/%f %B/xymonserver.cfg
-@exec touch %D/%%WWWDIR%%/server/etc/critical.cfg %D/%%WWWDIR%%/server/etc/critical.cfg.bak
-@exec chown %%XYMONUSER%% %D/%%WWWDIR%%/server/etc/critical.cfg.bak %D/%%WWWDIR%%/server/etc/critical.cfg
+%%WWWDIR%%/server/etc/xymon-apache-open.sample
+%%WWWDIR%%/server/etc/xymon-apache-secure.sample
+%%WWWDIR%%/server/etc/xymon-apache.conf.sample
+@sample %%WWWDIR%%/server/etc/alerts.cfg.sample
+@sample %%WWWDIR%%/server/etc/analysis.cfg.sample
+@sample %%WWWDIR%%/server/etc/cgioptions.cfg.sample
+@sample %%WWWDIR%%/server/etc/client-local.cfg.sample
+@sample %%WWWDIR%%/server/etc/columndoc.csv.sample
+@sample %%WWWDIR%%/server/etc/combo.cfg.sample
+@sample %%WWWDIR%%/server/etc/graphs.cfg.sample
+@sample %%WWWDIR%%/server/etc/holidays.cfg.sample
+@sample %%WWWDIR%%/server/etc/hosts.cfg.sample
+@sample %%WWWDIR%%/server/etc/protocols.cfg.sample
+@sample %%WWWDIR%%/server/etc/rrddefinitions.cfg.sample
+@sample %%WWWDIR%%/server/etc/snmpmibs.cfg.sample
+@sample %%WWWDIR%%/server/etc/tasks.cfg.sample
+@sample %%WWWDIR%%/server/etc/xymonmenu.cfg.sample
+@sample %%WWWDIR%%/server/etc/xymonserver-migration.cfg.sample
+@sample %%WWWDIR%%/server/etc/xymonserver.cfg.sample
%%WWWDIR%%/server/ext/xymonnet-again.sh
%%WWWDIR%%/server/web/acknowledge_footer
%%WWWDIR%%/server/web/acknowledge_form
@@ -468,37 +432,37 @@ man/man8/xymonproxy.8
@exec install -d -o %%XYMONUSER%% %D/%%WWWDIR%%/server/www/snap
@exec install -d -o %%XYMONUSER%% %D/%%WWWDIR%%/server/www/wml
@exec chown %%XYMONUSER%% %D/%%WWWDIR%%/server/www
-@dirrm %%WWWDIR%%/server/www/wml
-@dirrm %%WWWDIR%%/server/www/snap
-@dirrm %%WWWDIR%%/server/www/rep
-@dirrm %%WWWDIR%%/server/www/notes
-@dirrm %%WWWDIR%%/server/www/menu
-@dirrm %%WWWDIR%%/server/www/html
-@dirrm %%WWWDIR%%/server/www/help/manpages/man8
-@dirrm %%WWWDIR%%/server/www/help/manpages/man7
-@dirrm %%WWWDIR%%/server/www/help/manpages/man5
-@dirrm %%WWWDIR%%/server/www/help/manpages/man1
-@dirrm %%WWWDIR%%/server/www/help/manpages
-@dirrm %%WWWDIR%%/server/www/help
-@dirrm %%WWWDIR%%/server/www/gifs
-@dirrm %%WWWDIR%%/server/www
-@dirrm %%WWWDIR%%/server/web
-@dirrm %%WWWDIR%%/server/tmp
-@dirrm %%WWWDIR%%/server/ext
-@dirrm %%WWWDIR%%/server/etc/tasks.d
-@dirrm %%WWWDIR%%/server/etc
-@dirrm %%WWWDIR%%/server/download
-@dirrm %%WWWDIR%%/server/bin
-@dirrm %%WWWDIR%%/server
-@dirrm %%WWWDIR%%/data/rrd
-@dirrm %%WWWDIR%%/data/logs
-@dirrm %%WWWDIR%%/data/hostdata
-@dirrm %%WWWDIR%%/data/histlogs
-@dirrm %%WWWDIR%%/data/hist
-@dirrm %%WWWDIR%%/data/disabled
-@dirrm %%WWWDIR%%/data/data
-@dirrm %%WWWDIR%%/data/acks
-@dirrm %%WWWDIR%%/data
-@dirrm %%WWWDIR%%/cgi-secure
-@dirrm %%WWWDIR%%/cgi-bin
-@dirrmtry %%WWWDIR%%
+@dir %%WWWDIR%%/server/www/wml
+@dir %%WWWDIR%%/server/www/snap
+@dir %%WWWDIR%%/server/www/rep
+@dir %%WWWDIR%%/server/www/notes
+@dir %%WWWDIR%%/server/www/menu
+@dir %%WWWDIR%%/server/www/html
+@dir %%WWWDIR%%/server/www/help/manpages/man8
+@dir %%WWWDIR%%/server/www/help/manpages/man7
+@dir %%WWWDIR%%/server/www/help/manpages/man5
+@dir %%WWWDIR%%/server/www/help/manpages/man1
+@dir %%WWWDIR%%/server/www/help/manpages
+@dir %%WWWDIR%%/server/www/help
+@dir %%WWWDIR%%/server/www/gifs
+@dir %%WWWDIR%%/server/www
+@dir %%WWWDIR%%/server/web
+@dir %%WWWDIR%%/server/tmp
+@dir %%WWWDIR%%/server/ext
+@dir %%WWWDIR%%/server/etc/tasks.d
+@dir %%WWWDIR%%/server/etc
+@dir %%WWWDIR%%/server/download
+@dir %%WWWDIR%%/server/bin
+@dir %%WWWDIR%%/server
+@dir %%WWWDIR%%/data/rrd
+@dir %%WWWDIR%%/data/logs
+@dir %%WWWDIR%%/data/hostdata
+@dir %%WWWDIR%%/data/histlogs
+@dir %%WWWDIR%%/data/hist
+@dir %%WWWDIR%%/data/disabled
+@dir %%WWWDIR%%/data/data
+@dir %%WWWDIR%%/data/acks
+@dir %%WWWDIR%%/data
+@dir %%WWWDIR%%/cgi-secure
+@dir %%WWWDIR%%/cgi-bin
+@dir %%WWWDIR%%