aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2018-10-12 12:19:57 +0000
committerLars Engels <lme@FreeBSD.org>2018-10-12 12:19:57 +0000
commitd0cabae5aa2a4220f68ca2b10ef7299c353b8081 (patch)
treef2c130f189181a77083d78bcf199359801b87e2b /net-mgmt
parentcd5aa204ce9a41418315279194a591bd6ca8d875 (diff)
downloadports-d0cabae5aa2a4220f68ca2b10ef7299c353b8081.tar.gz
ports-d0cabae5aa2a4220f68ca2b10ef7299c353b8081.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/icinga2/Makefile1
-rw-r--r--net-mgmt/icinga2/files/icinga2.in14
2 files changed, 8 insertions, 7 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 1a48a497d6cf..84a7d2ffce4c 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= icinga2
DISTVERSIONPREFIX= v
DISTVERSION= 2.9.2
+PORTREVISION= 1
CATEGORIES= net-mgmt
MAINTAINER= lme@FreeBSD.org
diff --git a/net-mgmt/icinga2/files/icinga2.in b/net-mgmt/icinga2/files/icinga2.in
index b2b6a3033fa5..8f89f2f6d2b8 100644
--- a/net-mgmt/icinga2/files/icinga2.in
+++ b/net-mgmt/icinga2/files/icinga2.in
@@ -19,7 +19,7 @@
. /etc/rc.subr
-# Add /usr/local/bin to path, so that the notification scripts
+# Add /usr/local/bin to path, so that the notification scripts
# can work (#!/usr/bin/env bash)
export PATH=$PATH:%%LOCALBASE%%/bin:%%PREFIX%%/sbin
@@ -86,7 +86,6 @@ reload_precmd() {
start_precmd() {
if checkyesno "icinga2_mkvar"; then
# Create necessary directories / change ownership
- #
# While this is also done through pkg-plist, /var might be on a ramdisk,
# so make sure all needed files and directories are created before starting
# Icinga.
@@ -96,17 +95,18 @@ start_precmd() {
"${icinga2_rundir}" "${icinga2_cachedir}"; do
if [ ! -d "${d}" ]; then
install -d -o ${icinga2_user} -g ${icinga2_group} "${d}"
- else
- chown ${icinga2_user}:${icinga2_group} "${d}"
fi
done
- install -d -o ${icinga2_user} -g %%WWWGRP%% "${icinga2_rundir}/cmd"
+ install -d -o ${icinga2_user} -g www "${icinga2_rundir}/cmd"
- chown -R ${icinga2_user}:${icinga2_user} "${icinga2_libdir}"
- chown -R ${icinga2_user}:${icinga2_user} "${icinga2_spooldir}"
fi
+ chown -R ${icinga2_user}:${icinga2_group} "${icinga2_libdir}"
+ chown -R ${icinga2_user}:${icinga2_group} "${icinga2_spooldir}"
+ chown -R ${icinga2_user}:${icinga2_group} "${icinga2_cachedir}"
+ chown -R ${icinga2_user}:www "${icinga2_rundir}/cmd"
+
if ! icinga2_checkconfig; then
return 1
fi