aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-19 16:20:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-19 16:20:39 +0000
commitdde812764a64b0b6235c64619b02ed6dff282d53 (patch)
tree7ebaf557ef4906cab705151d2cd2543c05fe8b31 /net-mgmt
parent7ab53826574e08618229128b8b52f5d010706093 (diff)
downloadports-dde812764a64b0b6235c64619b02ed6dff282d53.tar.gz
ports-dde812764a64b0b6235c64619b02ed6dff282d53.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/noc/Makefile8
-rw-r--r--net-mgmt/noc/distinfo6
-rw-r--r--net-mgmt/noc/files/noc.sh.in2
-rw-r--r--net-mgmt/noc/files/patch-fm_index.html8
-rw-r--r--net-mgmt/noc/files/patch-scripts_post-install2
-rw-r--r--net-mgmt/noc/files/pkg-install.in2
-rw-r--r--net-mgmt/noc/pkg-plist264
7 files changed, 278 insertions, 14 deletions
diff --git a/net-mgmt/noc/Makefile b/net-mgmt/noc/Makefile
index 1cc2224649f8..7630f0f34bb1 100644
--- a/net-mgmt/noc/Makefile
+++ b/net-mgmt/noc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= noc
-PORTVERSION= 0.2.7
+PORTVERSION= 0.3
CATEGORIES= net-mgmt python
MASTER_SITES= http://trac.nocproject.org/trac/downloads/
DISTNAME= noc-${PORTVERSION}
@@ -49,7 +49,8 @@ PLIST_SUB= NOCDIR=${NOCDIR} \
NOCGROUP=${NOCGROUP} \
NOCUID=${NOCUID} \
NOCGID=${NOCGID} \
- LOCALSTATE_DIR=${LOCALSTATE_DIR}
+ LOCALSTATE_DIR=${LOCALSTATE_DIR} \
+ PYTHONBASE=${PYTHONBASE}
SUB_FILES= pkg-install \
pkg-deinstall \
@@ -67,6 +68,7 @@ NOC_CONF_FILES= etc/noc-activator.defaults \
etc/noc-launcher.defaults \
etc/noc-notifier.defaults \
etc/noc-sae.defaults \
+ etc/noc-probe.defaults \
etc/noc.defaults
post-patch:
@@ -75,7 +77,7 @@ post-patch:
${REINPLACE_CMD} -e "s@^\(repo *=\).*@\1 ${NOCDBDIR}/repo@" -e "s@^\(backup_dir *=\).*@\1 ${NOCDBDIR}/backup@" etc/noc.defaults; \
${REINPLACE_CMD} -e "s@^\(PREFIX=\"\).*@\1${NOCDIR}\"@" setup.py; \
_sed_script=`${MKTEMP} tmp.XXXXXX`; \
- for cmd in telnet ssh rsync pg_dump tar gzip smidump smilint fping dig; do \
+ for cmd in telnet ssh rsync pg_dump tar gzip smidump smilint fping dig gpg; do \
${ECHO} "s@^\\($${cmd} *\\)=.*\$$@\\1 = "`${WHICH} $${cmd}`'@' >> $${_sed_script} ; \
done; \
${REINPLACE_CMD} -f $${_sed_script} ${NOC_CONF_FILES}; \
diff --git a/net-mgmt/noc/distinfo b/net-mgmt/noc/distinfo
index 95687a6a4914..784ec44f6f8c 100644
--- a/net-mgmt/noc/distinfo
+++ b/net-mgmt/noc/distinfo
@@ -1,3 +1,3 @@
-MD5 (noc-0.2.7.tar.gz) = fdeadb104be5ec5906deb8b6776e1f9d
-SHA256 (noc-0.2.7.tar.gz) = 010f7721c98fef6c22de8873610cdd4a23b3cf1c710464bff05196ba73256413
-SIZE (noc-0.2.7.tar.gz) = 1024056
+MD5 (noc-0.3.tar.gz) = 0fb283ca3fd78c50bf74d140d51ed04b
+SHA256 (noc-0.3.tar.gz) = f6f957d106dc325d0727064f28033b458bf3119171cbea37b4becc496931f24b
+SIZE (noc-0.3.tar.gz) = 1186654
diff --git a/net-mgmt/noc/files/noc.sh.in b/net-mgmt/noc/files/noc.sh.in
index 7b81576b8ba9..c3deb39bf486 100644
--- a/net-mgmt/noc/files/noc.sh.in
+++ b/net-mgmt/noc/files/noc.sh.in
@@ -30,6 +30,8 @@ load_rc_config $name
: ${noc_config="%%NOCDIR%%/etc/noc-launcher.conf"}
: ${noc_flags="-c ${noc_config}"}
+export PATH=$PATH:%%PYTHONBASE%%/bin
+
noc_chdir=%%NOCDIR%%
command=%%NOCDIR%%/scripts/noc-launcher.py
command_interpreter=python
diff --git a/net-mgmt/noc/files/patch-fm_index.html b/net-mgmt/noc/files/patch-fm_index.html
new file mode 100644
index 000000000000..e5e935eb5678
--- /dev/null
+++ b/net-mgmt/noc/files/patch-fm_index.html
@@ -0,0 +1,8 @@
+--- fm/index.html.bak 2009-09-05 14:50:04.000000000 +0700
++++ fm/index.html 2009-09-05 00:28:58.000000000 +0700
+@@ -146,4 +146,5 @@ $(document).ready(function(){
+ </TBODY>
+ </TABLE>
+ <DIV ID="pager"></DIV>
++<DIV ID="cover"></DIV>
+ {%endblock%}
diff --git a/net-mgmt/noc/files/patch-scripts_post-install b/net-mgmt/noc/files/patch-scripts_post-install
index 082b6070bbaf..793e4169596f 100644
--- a/net-mgmt/noc/files/patch-scripts_post-install
+++ b/net-mgmt/noc/files/patch-scripts_post-install
@@ -12,7 +12,7 @@
@@ -15,7 +15,7 @@ cd $PREFIX
sed_script=`mktemp tmp.XXXXXX`
rm $sed_script
- for cmd in telnet ssh rsync pg_dump tar gzip smidump smilint fping dig; do
+ for cmd in telnet ssh rsync pg_dump tar gzip smidump smilint fping dig gpg; do
- echo 's@^\\($cmd *\\)=.*\$@\\1 = '`which $cmd`'@' >> $sed_script
+ echo "s@^\\($cmd *\\)=.*\$@\\1 = "`which $cmd`'@' >> $sed_script
done
diff --git a/net-mgmt/noc/files/pkg-install.in b/net-mgmt/noc/files/pkg-install.in
index fba96d5fe509..97a11b95b411 100644
--- a/net-mgmt/noc/files/pkg-install.in
+++ b/net-mgmt/noc/files/pkg-install.in
@@ -103,7 +103,7 @@ if [ "$2" = "POST-INSTALL" ]; then
##
chmod 640 ${NOCDIR}/etc/*.conf
chown ${NOCUSER}:${NOCGROUP} ${NOCDIR}/etc/*.conf
- chmod -R +r ${NOCDIR}/share/mibs/
+ chmod -R +r,go-w ${NOCDIR}/share/mibs/
##
## Create required directories
##
diff --git a/net-mgmt/noc/pkg-plist b/net-mgmt/noc/pkg-plist
index 40f03da117b8..052c16acea16 100644
--- a/net-mgmt/noc/pkg-plist
+++ b/net-mgmt/noc/pkg-plist
@@ -183,18 +183,36 @@ noc/dns/migrations/0015_dnszonerecordtype_validate.pyo
noc/dns/migrations/0016_autozones_path.py
noc/dns/migrations/0016_autozones_path.pyc
noc/dns/migrations/0016_autozones_path.pyo
+noc/dns/migrations/0017_dnszone_paid_till.py
+noc/dns/migrations/0017_dnszone_paid_till.pyc
+noc/dns/migrations/0017_dnszone_paid_till.pyo
+noc/dns/migrations/0018_domain_expired.py
+noc/dns/migrations/0018_domain_expired.pyc
+noc/dns/migrations/0018_domain_expired.pyo
noc/dns/migrations/__init__.py
noc/dns/migrations/__init__.pyc
noc/dns/migrations/__init__.pyo
noc/dns/models.py
noc/dns/models.pyc
noc/dns/models.pyo
+noc/dns/periodics/__init__.py
+noc/dns/periodics/__init__.pyc
+noc/dns/periodics/__init__.pyo
+noc/dns/periodics/check_domain_expiration.py
+noc/dns/periodics/check_domain_expiration.pyc
+noc/dns/periodics/check_domain_expiration.pyo
+noc/dns/periodics/update_domain_expiration.py
+noc/dns/periodics/update_domain_expiration.pyc
+noc/dns/periodics/update_domain_expiration.pyo
noc/dns/reports/__init__.py
noc/dns/reports/__init__.pyc
noc/dns/reports/__init__.pyo
noc/dns/reports/duplicated_fqdns.py
noc/dns/reports/duplicated_fqdns.pyc
noc/dns/reports/duplicated_fqdns.pyo
+noc/dns/reports/expiring_domains.py
+noc/dns/reports/expiring_domains.pyc
+noc/dns/reports/expiring_domains.pyo
noc/dns/reports/missed_p2p_addresses.py
noc/dns/reports/missed_p2p_addresses.pyc
noc/dns/reports/missed_p2p_addresses.pyo
@@ -204,6 +222,7 @@ noc/dns/reports/ns_zones.pyo
noc/dns/reports/supported_servers.py
noc/dns/reports/supported_servers.pyc
noc/dns/reports/supported_servers.pyo
+noc/dns/tools.html
noc/dns/urls.py
noc/dns/urls.pyc
noc/dns/urls.pyo
@@ -223,6 +242,8 @@ noc/etc/noc-fcgi.defaults
noc/etc/noc-launcher.defaults
@unexec if cmp -s %D/noc/etc/noc-notifier.defaults %D/noc/etc/noc-notifier.conf; then rm -f %D/noc/etc/noc-notifier.conf; fi
noc/etc/noc-notifier.defaults
+@unexec if cmp -s %D/noc/etc/noc-probe.defaults %D/noc/etc/noc-probe.conf; then rm -f %D/noc/etc/noc-probe.conf; fi
+noc/etc/noc-probe.defaults
@unexec if cmp -s %D/noc/etc/noc-sae.defaults %D/noc/etc/noc-sae.conf; then rm -f %D/noc/etc/noc-sae.conf; fi
noc/etc/noc-sae.defaults
@unexec if cmp -s %D/noc/etc/noc.defaults %D/noc/etc/noc.conf; then rm -f %D/noc/etc/noc.conf; fi
@@ -248,6 +269,9 @@ noc/fm/management/__init__.pyo
noc/fm/management/commands/__init__.py
noc/fm/management/commands/__init__.pyc
noc/fm/management/commands/__init__.pyo
+noc/fm/management/commands/check-required-mibs.py
+noc/fm/management/commands/check-required-mibs.pyc
+noc/fm/management/commands/check-required-mibs.pyo
noc/fm/management/commands/import-mib.py
noc/fm/management/commands/import-mib.pyc
noc/fm/management/commands/import-mib.pyo
@@ -330,6 +354,9 @@ noc/fm/migrations/0024_event_correlation_rule.pyo
noc/fm/migrations/0025_eventarchivationrule.py
noc/fm/migrations/0025_eventarchivationrule.pyc
noc/fm/migrations/0025_eventarchivationrule.pyo
+noc/fm/migrations/0026_postprocessingrule_params.py
+noc/fm/migrations/0026_postprocessingrule_params.pyc
+noc/fm/migrations/0026_postprocessingrule_params.pyo
noc/fm/migrations/__init__.py
noc/fm/migrations/__init__.pyc
noc/fm/migrations/__init__.pyo
@@ -432,6 +459,9 @@ noc/fm/rules/classes/memory.pyo
noc/fm/rules/classes/phone.py
noc/fm/rules/classes/phone.pyc
noc/fm/rules/classes/phone.pyo
+noc/fm/rules/classes/pm.py
+noc/fm/rules/classes/pm.pyc
+noc/fm/rules/classes/pm.pyo
noc/fm/rules/classes/poe.py
noc/fm/rules/classes/poe.pyc
noc/fm/rules/classes/poe.pyo
@@ -462,6 +492,15 @@ noc/fm/rules/classification/Audiocodes/Mediant2000/config.pyo
noc/fm/rules/classification/Audiocodes/__init__.py
noc/fm/rules/classification/Audiocodes/__init__.pyc
noc/fm/rules/classification/Audiocodes/__init__.pyo
+noc/fm/rules/classification/Cisco/AireOS/__init__.py
+noc/fm/rules/classification/Cisco/AireOS/__init__.pyc
+noc/fm/rules/classification/Cisco/AireOS/__init__.pyo
+noc/fm/rules/classification/Cisco/AireOS/dot11.py
+noc/fm/rules/classification/Cisco/AireOS/dot11.pyc
+noc/fm/rules/classification/Cisco/AireOS/dot11.pyo
+noc/fm/rules/classification/Cisco/AireOS/radius.py
+noc/fm/rules/classification/Cisco/AireOS/radius.pyc
+noc/fm/rules/classification/Cisco/AireOS/radius.pyo
noc/fm/rules/classification/Cisco/IOS/__init__.py
noc/fm/rules/classification/Cisco/IOS/__init__.pyc
noc/fm/rules/classification/Cisco/IOS/__init__.pyo
@@ -585,6 +624,9 @@ noc/fm/rules/classification/auth.pyo
noc/fm/rules/classification/bgp.py
noc/fm/rules/classification/bgp.pyc
noc/fm/rules/classification/bgp.pyo
+noc/fm/rules/classification/config.py
+noc/fm/rules/classification/config.pyc
+noc/fm/rules/classification/config.pyo
noc/fm/rules/classification/dot11.py
noc/fm/rules/classification/dot11.pyc
noc/fm/rules/classification/dot11.pyo
@@ -603,6 +645,9 @@ noc/fm/rules/classification/fallback.pyo
noc/fm/rules/classification/link.py
noc/fm/rules/classification/link.pyc
noc/fm/rules/classification/link.pyo
+noc/fm/rules/classification/pm.py
+noc/fm/rules/classification/pm.pyc
+noc/fm/rules/classification/pm.pyo
noc/fm/rules/classification/stp.py
noc/fm/rules/classification/stp.pyc
noc/fm/rules/classification/stp.pyo
@@ -612,8 +657,9 @@ noc/fm/rules/classification/system.pyo
noc/fm/rules/correlation/__init__.py
noc/fm/rules/correlation/__init__.pyc
noc/fm/rules/correlation/__init__.pyo
-noc/fm/rules/correlation/bgp.krb
-noc/fm/rules/correlation/common.krb
+noc/fm/rules/correlation/dot11.py
+noc/fm/rules/correlation/dot11.pyc
+noc/fm/rules/correlation/dot11.pyo
noc/fm/rules/correlation/ipsec.py
noc/fm/rules/correlation/ipsec.pyc
noc/fm/rules/correlation/ipsec.pyo
@@ -624,6 +670,9 @@ noc/fm/rules/correlation/link.pyo
noc/fm/rules/correlation/loadbalance.py
noc/fm/rules/correlation/loadbalance.pyc
noc/fm/rules/correlation/loadbalance.pyo
+noc/fm/rules/correlation/radius.py
+noc/fm/rules/correlation/radius.pyc
+noc/fm/rules/correlation/radius.pyo
noc/fm/rules/correlation/system.py
noc/fm/rules/correlation/system.pyc
noc/fm/rules/correlation/system.pyo
@@ -664,6 +713,9 @@ noc/ip/migrations/0004_default_vrf.pyo
noc/ip/migrations/0005_free_ip.py
noc/ip/migrations/0005_free_ip.pyc
noc/ip/migrations/0005_free_ip.pyo
+noc/ip/migrations/0006_vrf_description.py
+noc/ip/migrations/0006_vrf_description.pyc
+noc/ip/migrations/0006_vrf_description.pyo
noc/ip/migrations/__init__.py
noc/ip/migrations/__init__.pyc
noc/ip/migrations/__init__.pyo
@@ -697,6 +749,7 @@ noc/kb/admin.py
noc/kb/admin.pyc
noc/kb/admin.pyo
noc/kb/index.html
+noc/kb/index_category.html
noc/kb/management/__init__.py
noc/kb/management/__init__.pyc
noc/kb/management/__init__.pyo
@@ -790,6 +843,9 @@ noc/lib/fileutils.pyo
noc/lib/fsm.py
noc/lib/fsm.pyc
noc/lib/fsm.pyo
+noc/lib/gpg.py
+noc/lib/gpg.pyc
+noc/lib/gpg.pyo
noc/lib/highlight.py
noc/lib/highlight.pyc
noc/lib/highlight.pyo
@@ -799,6 +855,9 @@ noc/lib/ip.pyo
noc/lib/nbsocket.py
noc/lib/nbsocket.pyc
noc/lib/nbsocket.pyo
+noc/lib/pmhash.py
+noc/lib/pmhash.pyc
+noc/lib/pmhash.pyo
noc/lib/pyquote.py
noc/lib/pyquote.pyc
noc/lib/pyquote.pyo
@@ -927,6 +986,12 @@ noc/main/migrations/0016_user_profile.pyo
noc/main/migrations/0017_initial_userprofilecontacts.py
noc/main/migrations/0017_initial_userprofilecontacts.pyc
noc/main/migrations/0017_initial_userprofilecontacts.pyo
+noc/main/migrations/0018_systemnotification.py
+noc/main/migrations/0018_systemnotification.pyc
+noc/main/migrations/0018_systemnotification.pyo
+noc/main/migrations/0019_unhandled_exception.py
+noc/main/migrations/0019_unhandled_exception.pyc
+noc/main/migrations/0019_unhandled_exception.pyo
noc/main/migrations/__init__.py
noc/main/migrations/__init__.pyc
noc/main/migrations/__init__.pyo
@@ -1125,18 +1190,74 @@ noc/peer/whois.pyo
noc/pm/__init__.py
noc/pm/__init__.pyc
noc/pm/__init__.pyo
+noc/pm/admin.py
+noc/pm/admin.pyc
+noc/pm/admin.pyo
+noc/pm/index.html
+noc/pm/management/__init__.py
+noc/pm/management/__init__.pyc
+noc/pm/management/__init__.pyo
+noc/pm/management/commands/__init__.py
+noc/pm/management/commands/__init__.pyc
+noc/pm/management/commands/__init__.pyo
+noc/pm/management/commands/ts-export.py
+noc/pm/management/commands/ts-export.pyc
+noc/pm/management/commands/ts-export.pyo
+noc/pm/management/commands/ts-list.py
+noc/pm/management/commands/ts-list.pyc
+noc/pm/management/commands/ts-list.pyo
+noc/pm/management/commands/ts-rm.py
+noc/pm/management/commands/ts-rm.pyc
+noc/pm/management/commands/ts-rm.pyo
+noc/pm/migrations/0001_initial.py
+noc/pm/migrations/0001_initial.pyc
+noc/pm/migrations/0001_initial.pyo
+noc/pm/migrations/__init__.py
+noc/pm/migrations/__init__.pyc
+noc/pm/migrations/__init__.pyo
noc/pm/models.py
noc/pm/models.pyc
noc/pm/models.pyo
+noc/pm/probe.py
+noc/pm/probe.pyc
+noc/pm/probe.pyo
noc/pm/probes/__init__.py
noc/pm/probes/__init__.pyc
noc/pm/probes/__init__.pyo
noc/pm/probes/http.py
noc/pm/probes/http.pyc
noc/pm/probes/http.pyo
-noc/pm/sla.py
-noc/pm/sla.pyc
-noc/pm/sla.pyo
+noc/pm/probes/popen.py
+noc/pm/probes/popen.pyc
+noc/pm/probes/popen.pyo
+noc/pm/probes/postgresql.py
+noc/pm/probes/postgresql.pyc
+noc/pm/probes/postgresql.pyo
+noc/pm/probes/process.py
+noc/pm/probes/process.pyc
+noc/pm/probes/process.pyo
+noc/pm/probes/smtp.py
+noc/pm/probes/smtp.pyc
+noc/pm/probes/smtp.pyo
+noc/pm/probes/snmp.py
+noc/pm/probes/snmp.pyc
+noc/pm/probes/snmp.pyo
+noc/pm/probes/snmp_interface.py
+noc/pm/probes/snmp_interface.pyc
+noc/pm/probes/snmp_interface.pyo
+noc/pm/probes/ssh.py
+noc/pm/probes/ssh.pyc
+noc/pm/probes/ssh.pyo
+noc/pm/probes/tcp.py
+noc/pm/probes/tcp.pyc
+noc/pm/probes/tcp.pyo
+noc/pm/probes/test.py
+noc/pm/probes/test.pyc
+noc/pm/probes/test.pyo
+noc/pm/urls.py
+noc/pm/urls.pyc
+noc/pm/urls.pyo
+noc/pm/view.html
noc/pm/views.py
noc/pm/views.pyc
noc/pm/views.pyo
@@ -1167,9 +1288,15 @@ noc/sa/interfaces/igetarp.pyo
noc/sa/interfaces/igetconfig.py
noc/sa/interfaces/igetconfig.pyc
noc/sa/interfaces/igetconfig.pyo
+noc/sa/interfaces/igetdhcpbinding.py
+noc/sa/interfaces/igetdhcpbinding.pyc
+noc/sa/interfaces/igetdhcpbinding.pyo
noc/sa/interfaces/igetdot11associations.py
noc/sa/interfaces/igetdot11associations.pyc
noc/sa/interfaces/igetdot11associations.pyo
+noc/sa/interfaces/igetlocalusers.py
+noc/sa/interfaces/igetlocalusers.pyc
+noc/sa/interfaces/igetlocalusers.pyo
noc/sa/interfaces/igetmacaddresstable.py
noc/sa/interfaces/igetmacaddresstable.pyc
noc/sa/interfaces/igetmacaddresstable.pyo
@@ -1179,6 +1306,9 @@ noc/sa/interfaces/igetversion.pyo
noc/sa/interfaces/igetvlans.py
noc/sa/interfaces/igetvlans.pyc
noc/sa/interfaces/igetvlans.pyo
+noc/sa/interfaces/ihaslocaluser.py
+noc/sa/interfaces/ihaslocaluser.pyc
+noc/sa/interfaces/ihaslocaluser.pyo
noc/sa/interfaces/ihasvlan.py
noc/sa/interfaces/ihasvlan.pyc
noc/sa/interfaces/ihasvlan.pyo
@@ -1304,6 +1434,19 @@ noc/sa/profiles/Cisco/ASA/highlight.py
noc/sa/profiles/Cisco/ASA/highlight.pyc
noc/sa/profiles/Cisco/ASA/highlight.pyo
noc/sa/profiles/Cisco/ASA/supported.csv
+noc/sa/profiles/Cisco/AireOS/__init__.py
+noc/sa/profiles/Cisco/AireOS/__init__.pyc
+noc/sa/profiles/Cisco/AireOS/__init__.pyo
+noc/sa/profiles/Cisco/AireOS/get_config.py
+noc/sa/profiles/Cisco/AireOS/get_config.pyc
+noc/sa/profiles/Cisco/AireOS/get_config.pyo
+noc/sa/profiles/Cisco/AireOS/get_version.py
+noc/sa/profiles/Cisco/AireOS/get_version.pyc
+noc/sa/profiles/Cisco/AireOS/get_version.pyo
+noc/sa/profiles/Cisco/AireOS/highlight.py
+noc/sa/profiles/Cisco/AireOS/highlight.pyc
+noc/sa/profiles/Cisco/AireOS/highlight.pyo
+noc/sa/profiles/Cisco/AireOS/supported.csv
noc/sa/profiles/Cisco/FWSM/__init__.py
noc/sa/profiles/Cisco/FWSM/__init__.pyc
noc/sa/profiles/Cisco/FWSM/__init__.pyo
@@ -1326,9 +1469,15 @@ noc/sa/profiles/Cisco/IOS/get_arp.pyo
noc/sa/profiles/Cisco/IOS/get_config.py
noc/sa/profiles/Cisco/IOS/get_config.pyc
noc/sa/profiles/Cisco/IOS/get_config.pyo
+noc/sa/profiles/Cisco/IOS/get_dhcp_binding.py
+noc/sa/profiles/Cisco/IOS/get_dhcp_binding.pyc
+noc/sa/profiles/Cisco/IOS/get_dhcp_binding.pyo
noc/sa/profiles/Cisco/IOS/get_dot11_associations.py
noc/sa/profiles/Cisco/IOS/get_dot11_associations.pyc
noc/sa/profiles/Cisco/IOS/get_dot11_associations.pyo
+noc/sa/profiles/Cisco/IOS/get_local_users.py
+noc/sa/profiles/Cisco/IOS/get_local_users.pyc
+noc/sa/profiles/Cisco/IOS/get_local_users.pyo
noc/sa/profiles/Cisco/IOS/get_mac_address_table.py
noc/sa/profiles/Cisco/IOS/get_mac_address_table.pyc
noc/sa/profiles/Cisco/IOS/get_mac_address_table.pyo
@@ -1345,6 +1494,22 @@ noc/sa/profiles/Cisco/IOS/ping.py
noc/sa/profiles/Cisco/IOS/ping.pyc
noc/sa/profiles/Cisco/IOS/ping.pyo
noc/sa/profiles/Cisco/IOS/supported.csv
+noc/sa/profiles/Cisco/NXOS/__init__.py
+noc/sa/profiles/Cisco/NXOS/__init__.pyc
+noc/sa/profiles/Cisco/NXOS/__init__.pyo
+noc/sa/profiles/Cisco/NXOS/get_config.py
+noc/sa/profiles/Cisco/NXOS/get_config.pyc
+noc/sa/profiles/Cisco/NXOS/get_config.pyo
+noc/sa/profiles/Cisco/NXOS/get_local_user.py
+noc/sa/profiles/Cisco/NXOS/get_local_user.pyc
+noc/sa/profiles/Cisco/NXOS/get_local_user.pyo
+noc/sa/profiles/Cisco/NXOS/get_version.py
+noc/sa/profiles/Cisco/NXOS/get_version.pyc
+noc/sa/profiles/Cisco/NXOS/get_version.pyo
+noc/sa/profiles/Cisco/NXOS/highlight.py
+noc/sa/profiles/Cisco/NXOS/highlight.pyc
+noc/sa/profiles/Cisco/NXOS/highlight.pyo
+noc/sa/profiles/Cisco/NXOS/supported.csv
noc/sa/profiles/Cisco/__init__.py
noc/sa/profiles/Cisco/__init__.pyc
noc/sa/profiles/Cisco/__init__.pyo
@@ -1413,6 +1578,9 @@ noc/sa/profiles/Force10/FTOS/get_arp.pyo
noc/sa/profiles/Force10/FTOS/get_config.py
noc/sa/profiles/Force10/FTOS/get_config.pyc
noc/sa/profiles/Force10/FTOS/get_config.pyo
+noc/sa/profiles/Force10/FTOS/get_local_users.py
+noc/sa/profiles/Force10/FTOS/get_local_users.pyc
+noc/sa/profiles/Force10/FTOS/get_local_users.pyo
noc/sa/profiles/Force10/FTOS/get_mac_address_table.py
noc/sa/profiles/Force10/FTOS/get_mac_address_table.pyc
noc/sa/profiles/Force10/FTOS/get_mac_address_table.pyo
@@ -1435,9 +1603,25 @@ noc/sa/profiles/Generic/__init__.pyo
noc/sa/profiles/Generic/commands.py
noc/sa/profiles/Generic/commands.pyc
noc/sa/profiles/Generic/commands.pyo
+noc/sa/profiles/Generic/has_local_user.py
+noc/sa/profiles/Generic/has_local_user.pyc
+noc/sa/profiles/Generic/has_local_user.pyo
noc/sa/profiles/Generic/has_vlan.py
noc/sa/profiles/Generic/has_vlan.pyc
noc/sa/profiles/Generic/has_vlan.pyo
+noc/sa/profiles/HP/__init__.py
+noc/sa/profiles/HP/__init__.pyc
+noc/sa/profiles/HP/__init__.pyo
+noc/sa/profiles/HP/iLO2/__init__.py
+noc/sa/profiles/HP/iLO2/__init__.pyc
+noc/sa/profiles/HP/iLO2/__init__.pyo
+noc/sa/profiles/HP/iLO2/get_config.py
+noc/sa/profiles/HP/iLO2/get_config.pyc
+noc/sa/profiles/HP/iLO2/get_config.pyo
+noc/sa/profiles/HP/iLO2/get_version.py
+noc/sa/profiles/HP/iLO2/get_version.pyc
+noc/sa/profiles/HP/iLO2/get_version.pyo
+noc/sa/profiles/HP/iLO2/supported.csv
noc/sa/profiles/Huawei/UMG8900/__init__.py
noc/sa/profiles/Huawei/UMG8900/__init__.pyc
noc/sa/profiles/Huawei/UMG8900/__init__.pyo
@@ -1565,6 +1749,22 @@ noc/sa/profiles/Protei/MediaGateway/supported.csv
noc/sa/profiles/Protei/__init__.py
noc/sa/profiles/Protei/__init__.pyc
noc/sa/profiles/Protei/__init__.pyo
+noc/sa/profiles/Raisecom/ROS/__init__.py
+noc/sa/profiles/Raisecom/ROS/__init__.pyc
+noc/sa/profiles/Raisecom/ROS/__init__.pyo
+noc/sa/profiles/Raisecom/ROS/get_config.py
+noc/sa/profiles/Raisecom/ROS/get_config.pyc
+noc/sa/profiles/Raisecom/ROS/get_config.pyo
+noc/sa/profiles/Raisecom/ROS/get_version.py
+noc/sa/profiles/Raisecom/ROS/get_version.pyc
+noc/sa/profiles/Raisecom/ROS/get_version.pyo
+noc/sa/profiles/Raisecom/ROS/highlight.py
+noc/sa/profiles/Raisecom/ROS/highlight.pyc
+noc/sa/profiles/Raisecom/ROS/highlight.pyo
+noc/sa/profiles/Raisecom/ROS/supported.csv
+noc/sa/profiles/Raisecom/__init__.py
+noc/sa/profiles/Raisecom/__init__.pyc
+noc/sa/profiles/Raisecom/__init__.pyo
noc/sa/profiles/Ubiquiti/AirOS/__init__.py
noc/sa/profiles/Ubiquiti/AirOS/__init__.pyc
noc/sa/profiles/Ubiquiti/AirOS/__init__.pyo
@@ -1635,6 +1835,19 @@ noc/sa/profiles/Zyxel/ZyNOS/highlight.py
noc/sa/profiles/Zyxel/ZyNOS/highlight.pyc
noc/sa/profiles/Zyxel/ZyNOS/highlight.pyo
noc/sa/profiles/Zyxel/ZyNOS/supported.csv
+noc/sa/profiles/Zyxel/ZyNOSv2/__init__.py
+noc/sa/profiles/Zyxel/ZyNOSv2/__init__.pyc
+noc/sa/profiles/Zyxel/ZyNOSv2/__init__.pyo
+noc/sa/profiles/Zyxel/ZyNOSv2/get_config.py
+noc/sa/profiles/Zyxel/ZyNOSv2/get_config.pyc
+noc/sa/profiles/Zyxel/ZyNOSv2/get_config.pyo
+noc/sa/profiles/Zyxel/ZyNOSv2/get_version.py
+noc/sa/profiles/Zyxel/ZyNOSv2/get_version.pyc
+noc/sa/profiles/Zyxel/ZyNOSv2/get_version.pyo
+noc/sa/profiles/Zyxel/ZyNOSv2/highlight.py
+noc/sa/profiles/Zyxel/ZyNOSv2/highlight.pyc
+noc/sa/profiles/Zyxel/ZyNOSv2/highlight.pyo
+noc/sa/profiles/Zyxel/ZyNOSv2/supported.csv
noc/sa/profiles/Zyxel/__init__.py
noc/sa/profiles/Zyxel/__init__.pyc
noc/sa/profiles/Zyxel/__init__.pyo
@@ -1661,6 +1874,10 @@ noc/sa/protocols/Makefile
noc/sa/protocols/__init__.py
noc/sa/protocols/__init__.pyc
noc/sa/protocols/__init__.pyo
+noc/sa/protocols/pm.proto
+noc/sa/protocols/pm_pb2.py
+noc/sa/protocols/pm_pb2.pyc
+noc/sa/protocols/pm_pb2.pyo
noc/sa/protocols/sae.proto
noc/sa/protocols/sae_pb2.py
noc/sa/protocols/sae_pb2.pyc
@@ -1733,8 +1950,8 @@ noc/scripts/noc-correlator.py
noc/scripts/noc-fcgi.py
noc/scripts/noc-launcher.py
noc/scripts/noc-notifier.py
+noc/scripts/noc-probe.py
noc/scripts/noc-sae.py
-noc/scripts/noc-sla.py
noc/scripts/post-install
noc/scripts/post-update
noc/scripts/stdin-wrapper
@@ -1787,16 +2004,20 @@ noc/share/doc/en/ug/main.rst
noc/share/doc/en/ug/modules.rst
noc/share/doc/en/ug/overview.rst
noc/share/doc/en/ug/peer.rst
+noc/share/doc/en/ug/pm.rst
noc/share/doc/en/ug/profiles/Alcatel.AOS.rst
noc/share/doc/en/ug/profiles/Audiocodes.Mediant2000.rst
noc/share/doc/en/ug/profiles/Cisco.ASA.rst
+noc/share/doc/en/ug/profiles/Cisco.AireOS.rst
noc/share/doc/en/ug/profiles/Cisco.FWSM.rst
noc/share/doc/en/ug/profiles/Cisco.IOS.rst
+noc/share/doc/en/ug/profiles/Cisco.NXOS.rst
noc/share/doc/en/ug/profiles/DLink.DES3xxx.rst
noc/share/doc/en/ug/profiles/DLink.DGS3xxx.rst
noc/share/doc/en/ug/profiles/EdgeCore.ES35xx.rst
noc/share/doc/en/ug/profiles/EdgeCore.ES4xxx.rst
noc/share/doc/en/ug/profiles/Force10.FTOS.rst
+noc/share/doc/en/ug/profiles/HP.iLO2.rst
noc/share/doc/en/ug/profiles/Huawei.UMG8900.rst
noc/share/doc/en/ug/profiles/Huawei.VRP.rst
noc/share/doc/en/ug/profiles/InfiNet.WANFlexX.rst
@@ -1807,11 +2028,13 @@ noc/share/doc/en/ug/profiles/Juniper.ScreenOS.rst
noc/share/doc/en/ug/profiles/Linksys.SPS2xx.rst
noc/share/doc/en/ug/profiles/MikroTik.RouterOS.rst
noc/share/doc/en/ug/profiles/Protei.MediaGateway.rst
+noc/share/doc/en/ug/profiles/Raisecom.ROS.rst
noc/share/doc/en/ug/profiles/Ubiquity.AirOS.rst
noc/share/doc/en/ug/profiles/VoiceFinder.AddPack.rst
noc/share/doc/en/ug/profiles/ZTE.ZXDSL531.rst
noc/share/doc/en/ug/profiles/Zebra.Zebra.rst
noc/share/doc/en/ug/profiles/ZyXEL.ZyNOS.rst
+noc/share/doc/en/ug/profiles/Zyxel.ZyNOSv2.rst
noc/share/doc/en/ug/profiles/f5.BIGIP.rst
noc/share/doc/en/ug/sa.rst
noc/share/doc/en/ug/sa_activator_fsm.png
@@ -1825,6 +2048,8 @@ noc/share/doc/index/index.rst
noc/share/linux/lsb/init.d/noc-launcher
noc/share/linux/lsb/sysconfig/noc
noc/share/linux/ubuntu/init.d/noc-launcher
+noc/share/mibs/AIRESPACE-REF-MIB.mib
+noc/share/mibs/AIRESPACE-WIRELESS-MIB.mib
noc/share/mibs/BGP4-MIB.mib
noc/share/mibs/BRIDGE-MIB.mib
noc/share/mibs/CISCO-BGP4-MIB.mib
@@ -1833,6 +2058,9 @@ noc/share/mibs/CISCO-DIAL-CONTROL-MIB.mib
noc/share/mibs/CISCO-IPSEC-FLOW-MONITOR-MIB.mib
noc/share/mibs/CISCO-IPSEC-MIB.mib
noc/share/mibs/CISCO-ISDN-MIB.mib
+noc/share/mibs/CISCO-LWAPP-AAA-MIB.mib
+noc/share/mibs/CISCO-LWAPP-TC-MIB.mib
+noc/share/mibs/CISCO-LWAPP-WLAN-MIB.mib
noc/share/mibs/CISCO-MEDIA-GATEWAY-MIB.mib
noc/share/mibs/CISCO-SMI.mib
noc/share/mibs/CISCO-STP-EXTENSIONS-MIB.mib
@@ -1841,6 +2069,7 @@ noc/share/mibs/CISCO-TC.mib
noc/share/mibs/CISCO-VTP-MIB.mib
noc/share/mibs/CISCOTRAP-MIB.mib
noc/share/mibs/DIAL-CONTROL-MIB.mib
+noc/share/mibs/ENTITY-MIB.mib
noc/share/mibs/F5-BIGIP-COMMON-MIB.mib
noc/share/mibs/HCNUM-TC.mib
noc/share/mibs/IANAifType-MIB.mib
@@ -1877,24 +2106,32 @@ noc/share/sunos/manifest/noc-activator.xml
noc/share/sunos/manifest/noc-classifier.xml
noc/share/sunos/manifest/noc-correlator.xml
noc/share/sunos/manifest/noc-fcgi.xml
+noc/share/sunos/manifest/noc-launcher.xml
noc/share/sunos/manifest/noc-sae.xml
noc/static/css/databrowse.css
noc/static/css/diff.css
noc/static/css/highlight.css
noc/static/css/jquery.autocomplete.css
noc/static/css/jquery.pager.css
+noc/static/css/jquery.svg.css
noc/static/css/login.css
noc/static/css/main.css
noc/static/css/menu.css
noc/static/css/pygments.css
noc/static/css/rack.css
noc/static/css/sphinx.css
+noc/static/css/tablesorter.css
+noc/static/img/asc.gif
+noc/static/img/bg.gif
+noc/static/img/desc.gif
noc/static/img/indicator.gif
noc/static/img/logo.png
noc/static/js/jquery.autocomplete.js
noc/static/js/jquery.form.js
noc/static/js/jquery.js
noc/static/js/jquery.pager.js
+noc/static/js/jquery.svg.js
+noc/static/js/jquery.tablesorter.js
noc/static/js/menu.js
noc/template/admin/base.html
noc/template/admin/base_site.html
@@ -1903,6 +2140,7 @@ noc/template/admin/cm/config/change_list.html
noc/template/admin/cm/dns/change_list.html
noc/template/admin/cm/prefixlist/change_list.html
noc/template/admin/cm/rpsl/change_list.html
+noc/template/admin/dns/dnszone/change_list.html
noc/template/admin/fm/eventclassificationrule/change_form.html
noc/template/admin/fm/eventclassificationrule/change_list.html
noc/template/admin/fm/eventcorrelationrule/change_list.html
@@ -1961,6 +2199,8 @@ noc/vc/views.pyo
@dirrm noc/template/admin/fm/eventcorrelationrule
@dirrm noc/template/admin/fm/eventclassificationrule
@dirrm noc/template/admin/fm
+@dirrm noc/template/admin/dns/dnszone
+@dirrm noc/template/admin/dns
@dirrm noc/template/admin/cm/rpsl
@dirrm noc/template/admin/cm/prefixlist
@dirrm noc/template/admin/cm/dns
@@ -1996,6 +2236,7 @@ noc/vc/views.pyo
@dirrm noc/sa/protocols
@dirrm noc/sa/profiles/f5/BIGIP
@dirrm noc/sa/profiles/f5
+@dirrm noc/sa/profiles/Zyxel/ZyNOSv2
@dirrm noc/sa/profiles/Zyxel/ZyNOS
@dirrm noc/sa/profiles/Zyxel
@dirrm noc/sa/profiles/Zebra/Zebra
@@ -2006,6 +2247,8 @@ noc/vc/views.pyo
@dirrm noc/sa/profiles/VoiceFinder
@dirrm noc/sa/profiles/Ubiquiti/AirOS
@dirrm noc/sa/profiles/Ubiquiti
+@dirrm noc/sa/profiles/Raisecom/ROS
+@dirrm noc/sa/profiles/Raisecom
@dirrm noc/sa/profiles/Protei/MediaGateway
@dirrm noc/sa/profiles/Protei
@dirrm noc/sa/profiles/MikroTik/RouterOS
@@ -2022,6 +2265,8 @@ noc/vc/views.pyo
@dirrm noc/sa/profiles/Huawei/VRP
@dirrm noc/sa/profiles/Huawei/UMG8900
@dirrm noc/sa/profiles/Huawei
+@dirrm noc/sa/profiles/HP/iLO2
+@dirrm noc/sa/profiles/HP
@dirrm noc/sa/profiles/Generic
@dirrm noc/sa/profiles/Force10/FTOS
@dirrm noc/sa/profiles/Force10
@@ -2031,8 +2276,10 @@ noc/vc/views.pyo
@dirrm noc/sa/profiles/DLink/DGS3xxx
@dirrm noc/sa/profiles/DLink/DES3xxx
@dirrm noc/sa/profiles/DLink
+@dirrm noc/sa/profiles/Cisco/NXOS
@dirrm noc/sa/profiles/Cisco/IOS
@dirrm noc/sa/profiles/Cisco/FWSM
+@dirrm noc/sa/profiles/Cisco/AireOS
@dirrm noc/sa/profiles/Cisco/ASA
@dirrm noc/sa/profiles/Cisco
@dirrm noc/sa/profiles/Audiocodes/Mediant2000
@@ -2046,6 +2293,9 @@ noc/vc/views.pyo
@dirrm noc/sa/interfaces
@dirrm noc/sa
@dirrm noc/pm/probes
+@dirrm noc/pm/migrations
+@dirrm noc/pm/management/commands
+@dirrm noc/pm/management
@dirrm noc/pm
@dirrm noc/peer/migrations
@dirrm noc/peer
@@ -2083,6 +2333,7 @@ noc/vc/views.pyo
@dirrm noc/fm/rules/classification/DLink/DES3xxx
@dirrm noc/fm/rules/classification/DLink
@dirrm noc/fm/rules/classification/Cisco/IOS
+@dirrm noc/fm/rules/classification/Cisco/AireOS
@dirrm noc/fm/rules/classification/Cisco
@dirrm noc/fm/rules/classification/Audiocodes/Mediant2000
@dirrm noc/fm/rules/classification/Audiocodes
@@ -2098,6 +2349,7 @@ noc/vc/views.pyo
@dirrm noc/fm/management
@dirrm noc/fm
@dirrm noc/dns/reports
+@dirrm noc/dns/periodics
@dirrm noc/dns/migrations
@dirrm noc/dns/generators
@dirrm noc/dns