aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-03-29 18:16:46 +0000
committerSteve Wills <swills@FreeBSD.org>2017-03-29 18:16:46 +0000
commit094cd2c211bb2e5f1c814d3ab9b1611a019149c8 (patch)
treeef1b7ea1a2ccef9f2e07670e070921b394a1757c /net-mgmt
parent1735bebfe5dfe2952d5eb8944dc54001ca3ef4e8 (diff)
downloadports-094cd2c211bb2e5f1c814d3ab9b1611a019149c8.tar.gz
ports-094cd2c211bb2e5f1c814d3ab9b1611a019149c8.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/semaphore/Makefile64
-rw-r--r--net-mgmt/semaphore/distinfo53
-rw-r--r--net-mgmt/semaphore/files/patch-config.json13
-rw-r--r--net-mgmt/semaphore/files/semaphore.in23
-rw-r--r--net-mgmt/semaphore/pkg-descr3
6 files changed, 157 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 469869c54529..ce6a8e42b972 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -318,6 +318,7 @@
SUBDIR += seafile-client
SUBDIR += seafile-gui
SUBDIR += seafile-server
+ SUBDIR += semaphore
SUBDIR += send
SUBDIR += sendip
SUBDIR += sipcalc
diff --git a/net-mgmt/semaphore/Makefile b/net-mgmt/semaphore/Makefile
new file mode 100644
index 000000000000..419f8aa7e362
--- /dev/null
+++ b/net-mgmt/semaphore/Makefile
@@ -0,0 +1,64 @@
+# $FreeBSD$
+
+PORTNAME= semaphore
+PORTVERSION= 2.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net-mgmt
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Open Source alternative to Ansible Tower
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go \
+ ${LOCALBASE}/bin/go-bindata:devel/go-bindata \
+ npm>=0:www/npm
+RUN_DEPENDS= ansible:sysutils/ansible \
+ git:devel/git
+
+USE_GITHUB= yes
+GH_SUBDIR= src/github.com/ansible-semaphore/semaphore
+GH_ACCOUNT= ansible-semaphore
+GH_TUPLE= ansible-semaphore:semaphore-vendor:dcb3abe:vendor/public/vendor \
+ swills:semaphore-node_modules:v${PORTVERSION}:modules/public/node_modules \
+ swills:semaphore-rendered_files:v${PORTVERSION}:render/public.rendered \
+ bugsnag:bugsnag-go:70e1420:bugsnag/src/github.com/bugsnag/bugsnag-go \
+ bugsnag:panicwrap:aa7703c:panicwrap/src/github.com/bugsnag/panicwrap \
+ gin-gonic:gin:e2212d4:gonic/src/github.com/gin-gonic/gin \
+ go-sql-driver:mysql:9dee4ca:gomysql/src/github.com/go-sql-driver/mysql \
+ golang:protobuf:c9c7427:protobuf/src/github.com/golang/protobuf \
+ google:go-github:d683a1c:gogithub/src/github.com/google/go-github \
+ google:go-querystring:53e6ce1:querystring/src/github.com/google/go-querystring \
+ gorilla:securecookie:e59506c:securecookie/src/github.com/gorilla/securecookie \
+ gorilla:websocket:a91eba7:websocket/src/github.com/gorilla/websocket \
+ kardianos:osext:9d302b5:osext/src/github.com/kardianos/osext \
+ manucorporat:sse:ee05b12:sse/src/github.com/manucorporat/sse \
+ masterminds:squirrel:20f1922:squirrel/src/github.com/masterminds/squirrel \
+ lann:builder:f22ce00:builder/src/github.com/lann/builder \
+ lann:ps:62de8c4:ps/src/github.com/lann/ps \
+ mattn:go-isatty:fc9e8d8:go_isatty/src/github.com/mattn/go-isatty \
+ russross:blackfriday:5f33e7b:blackfriday/src/github.com/russross/blackfriday \
+ shurcooL:sanitized_anchor_name:1dba4b3:sanitized/src/github.com/shurcooL/sanitized_anchor_name \
+ golang:net:6c23252:net/src/golang.org/x/net \
+ golang:crypto:459e265:crypto/src/golang.org/x/crypto \
+ go-playground:validator:5f57d22:playground/src/gopkg.in/go-playground/validator.v8 \
+ go-gorp:gorp:c87af80:gorp/src/gopkg.in/gorp.v1 \
+ go-yaml:yaml:a3f3340:yaml/src/gopkg.in/yaml.v2
+
+PLIST_FILES= bin/semaphore \
+ "@sample etc/semaphore/semaphore_config.json.sample"
+
+USE_RC_SUBR= semaphore
+
+post-patch:
+ @${CP} -R ${WRKSRC}/public.rendered/public/ ${WRKSRC}/public/
+
+do-build:
+ @(cd ${WRKSRC}/public ; node ./bundler.js )
+ @(cd ${WRKSRC} ; go-bindata -o util/bindata.go -pkg util config.json db/migrations/ public/css public/html public/html/projects public/html/projects/repositories public/html/projects/inventory public/html/projects/templates public/html/projects/users public/html/projects/environment public/html/projects/keys public/html/users public/html/auth public/img public/js public/js/services public/js/controllers public/js/controllers/projects public/js/routes public/js/factories public/node_modules public/node_modules/lodash public/node_modules/lodash/fp public/node_modules/async public/node_modules/async/dist public/node_modules/async/internal public/vendor public/vendor/fontawesome public/vendor/fontawesome/less public/vendor/fontawesome/fonts public/vendor/sweetalert public/vendor/moment public/vendor/bootstrap public/vendor/bootstrap/fonts public/vendor/bootstrap/dist public/vendor/bootstrap/dist/css public/vendor/bootstrap/dist/fonts public/vendor/bootstrap/dist/js public/vendor/bootstrap/less public/vendor/bootstrap/less/mixins public/vendor/angular-loading-bar )
+ @(cd ${WRKSRC}/cli ; ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build -o semaphore ./... )
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cli/semaphore ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/semaphore
+ ${CP} ${WRKSRC}/config.json ${STAGEDIR}${PREFIX}/etc/semaphore/semaphore_config.json.sample
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/semaphore/distinfo b/net-mgmt/semaphore/distinfo
new file mode 100644
index 000000000000..82c692e84ebe
--- /dev/null
+++ b/net-mgmt/semaphore/distinfo
@@ -0,0 +1,53 @@
+TIMESTAMP = 1490753329
+SHA256 (ansible-semaphore-semaphore-v2.2.0_GH0.tar.gz) = e8495615640812853d729683c468bf653c1ba7b1823a1ce85532866a4f04dbc5
+SIZE (ansible-semaphore-semaphore-v2.2.0_GH0.tar.gz) = 150796
+SHA256 (ansible-semaphore-semaphore-vendor-dcb3abe_GH0.tar.gz) = cf3eea907e531447ab1992e080ef8e4be107673b91b35b7e465628bd9b7d580b
+SIZE (ansible-semaphore-semaphore-vendor-dcb3abe_GH0.tar.gz) = 1136879
+SHA256 (swills-semaphore-node_modules-v2.2.0_GH0.tar.gz) = 9c997fac40127dc7dc34816856da1ae0e83bdf3afed0c3eacb4f37bcf8b05b82
+SIZE (swills-semaphore-node_modules-v2.2.0_GH0.tar.gz) = 403647
+SHA256 (swills-semaphore-rendered_files-v2.2.0_GH0.tar.gz) = 58b37023b9d9ba8dfe8d4fd70c4c4d778588a325038070c301fa564f9af07e38
+SIZE (swills-semaphore-rendered_files-v2.2.0_GH0.tar.gz) = 144926
+SHA256 (bugsnag-bugsnag-go-70e1420_GH0.tar.gz) = 0c2b8f68195bef850283162fdde5235b5408172c268f4f1db26ed76f9d410b34
+SIZE (bugsnag-bugsnag-go-70e1420_GH0.tar.gz) = 111367
+SHA256 (bugsnag-panicwrap-aa7703c_GH0.tar.gz) = 64040e32f60b49d681d676b238a0458ed3bf230149f3dc1bfb11119ed83813a7
+SIZE (bugsnag-panicwrap-aa7703c_GH0.tar.gz) = 8463
+SHA256 (gin-gonic-gin-e2212d4_GH0.tar.gz) = ee90311f24299aeb72d5f2910330144e681e1975f78ef0e4e86778b15bf43d0a
+SIZE (gin-gonic-gin-e2212d4_GH0.tar.gz) = 111382
+SHA256 (go-sql-driver-mysql-9dee4ca_GH0.tar.gz) = d1c75ba6276a9b7688a561165b8939f3b0c1a8738305d852e27a185b062d6f1b
+SIZE (go-sql-driver-mysql-9dee4ca_GH0.tar.gz) = 62093
+SHA256 (golang-protobuf-c9c7427_GH0.tar.gz) = 71a9a376cdfd472f583ec0d1cd8e35baa14c5bb63b7ae4416ba5f378cc73b826
+SIZE (golang-protobuf-c9c7427_GH0.tar.gz) = 245281
+SHA256 (google-go-github-d683a1c_GH0.tar.gz) = f8320f37f17299b2ef74fe1472c6d5d0d3d85e62f0dfa041489f240b1f881e9f
+SIZE (google-go-github-d683a1c_GH0.tar.gz) = 167507
+SHA256 (google-go-querystring-53e6ce1_GH0.tar.gz) = 85e0895aef7f6045e3cc046f498c623c6ec467215ec831578be71ae63ec412af
+SIZE (google-go-querystring-53e6ce1_GH0.tar.gz) = 7490
+SHA256 (gorilla-securecookie-e59506c_GH0.tar.gz) = 3ad0c8b32b0b56ddf1808f765752398549386ca7816c04e0e1a50cbf61e0e8e2
+SIZE (gorilla-securecookie-e59506c_GH0.tar.gz) = 41286
+SHA256 (gorilla-websocket-a91eba7_GH0.tar.gz) = a62ed1f44e71e958c085caca430f4bdc8c2fe6040acb9b6b2980567aefebb96d
+SIZE (gorilla-websocket-a91eba7_GH0.tar.gz) = 42935
+SHA256 (kardianos-osext-9d302b5_GH0.tar.gz) = 8d62c9a81b4194c30ce17ff84d7ff88e0ca874991ee6b2b05840d52dd80339a8
+SIZE (kardianos-osext-9d302b5_GH0.tar.gz) = 4841
+SHA256 (manucorporat-sse-ee05b12_GH0.tar.gz) = 8ae20e2320e0756b3e38cf444e4eb4077d7977ef4c57b2a35ba5836a8ff1e2bc
+SIZE (manucorporat-sse-ee05b12_GH0.tar.gz) = 5409
+SHA256 (masterminds-squirrel-20f1922_GH0.tar.gz) = 682de3fad9912908bfa03e867de64a2f00de180e208f9ed9ba6fa12d17d76836
+SIZE (masterminds-squirrel-20f1922_GH0.tar.gz) = 16299
+SHA256 (lann-builder-f22ce00_GH0.tar.gz) = fbf3d5c84d3f836f36f8de96644875cc58cdaeffbf6409851fd3a31dc9a80696
+SIZE (lann-builder-f22ce00_GH0.tar.gz) = 5094
+SHA256 (lann-ps-62de8c4_GH0.tar.gz) = dd3cb64a93f9766d8a3762d9832aa0c25fcf475f32c5972866fe9050422d4dce
+SIZE (lann-ps-62de8c4_GH0.tar.gz) = 5529
+SHA256 (mattn-go-isatty-fc9e8d8_GH0.tar.gz) = bba2afe8904228211ac3f5fc4c14e065478e585a4052f56aa39671ab8c3140f3
+SIZE (mattn-go-isatty-fc9e8d8_GH0.tar.gz) = 3258
+SHA256 (russross-blackfriday-5f33e7b_GH0.tar.gz) = 30ec0d8bb17b404f7f3a59d574fa5728adc15b0248d433bd14d3ade1b8935b0e
+SIZE (russross-blackfriday-5f33e7b_GH0.tar.gz) = 71950
+SHA256 (shurcooL-sanitized_anchor_name-1dba4b3_GH0.tar.gz) = 0188ebad02ba0773a70431647bf7f40655dc0fdfccec8a3c682a20e97fd42d36
+SIZE (shurcooL-sanitized_anchor_name-1dba4b3_GH0.tar.gz) = 2054
+SHA256 (golang-net-6c23252_GH0.tar.gz) = 349e7e0743b43065d68657a0ef290996aa4aecae3a496bfb717f5ebf5cbb8942
+SIZE (golang-net-6c23252_GH0.tar.gz) = 859543
+SHA256 (golang-crypto-459e265_GH0.tar.gz) = ffb8479183f6b1d7ff5e444c7fedb28bf8995e33df7ae917a6c447b75b1dfc18
+SIZE (golang-crypto-459e265_GH0.tar.gz) = 1317091
+SHA256 (go-playground-validator-5f57d22_GH0.tar.gz) = 53b8e2eedf83fe9860e3b54668cb45d5064704de28747660a3a71aee0af3bf0f
+SIZE (go-playground-validator-5f57d22_GH0.tar.gz) = 61529
+SHA256 (go-gorp-gorp-c87af80_GH0.tar.gz) = 32cdd3d8b52b291074a58a3dc347eaf5e9ea0e3bf9dfaa9b8083af091b77d0b4
+SIZE (go-gorp-gorp-c87af80_GH0.tar.gz) = 36726
+SHA256 (go-yaml-yaml-a3f3340_GH0.tar.gz) = e2a3af32b0d55b2426229ea6efca85e4219209225f05fb57af55834a2dee2d1a
+SIZE (go-yaml-yaml-a3f3340_GH0.tar.gz) = 60720
diff --git a/net-mgmt/semaphore/files/patch-config.json b/net-mgmt/semaphore/files/patch-config.json
new file mode 100644
index 000000000000..441afa2f365a
--- /dev/null
+++ b/net-mgmt/semaphore/files/patch-config.json
@@ -0,0 +1,13 @@
+--- config.json.orig 2017-03-28 21:33:04 UTC
++++ config.json
+@@ -0,0 +1,10 @@
++{
++ "mysql": {
++ "host": "127.0.0.1:3306",
++ "user": "root",
++ "pass": "",
++ "name": "semaphore"
++ },
++ "session_db": "127.0.0.1:6379",
++ "port": ":3000"
++}
diff --git a/net-mgmt/semaphore/files/semaphore.in b/net-mgmt/semaphore/files/semaphore.in
new file mode 100644
index 000000000000..f4d5878bd95c
--- /dev/null
+++ b/net-mgmt/semaphore/files/semaphore.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+# PROVIDE: semaphore
+# KEYWORD: shutdown
+
+. /etc/rc.subr
+
+name=semaphore
+rcvar=semaphore_enable
+
+load_rc_config ${name}
+
+: ${semaphore_enable:="NO"}
+: ${semaphore_config="%%PREFIX%%/etc/semaphore/semaphore_config.json"}
+
+export PATH=${PATH}:%%PREFIX%%/bin
+
+pidfile="/var/run/${name}.pid"
+procname="%%PREFIX%%/bin/semaphore"
+command="/usr/sbin/daemon"
+command_args="-f -c -p ${pidfile} /usr/bin/env ${semaphore_env} ${procname} -config \"${semaphore_config}\""
+
+run_rc_command "$1"
diff --git a/net-mgmt/semaphore/pkg-descr b/net-mgmt/semaphore/pkg-descr
new file mode 100644
index 000000000000..745beceab3e2
--- /dev/null
+++ b/net-mgmt/semaphore/pkg-descr
@@ -0,0 +1,3 @@
+Open Source alternative to Ansible Tower
+
+WWW: https://ansible-semaphore.github.io/semaphore/