aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-01-10 11:26:36 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-01-10 11:26:36 +0000
commit3774dc0944ef1542b226552ac387d4866ece3d18 (patch)
treef4c80e18f07c53e259062d28d63bedc0e5e2755c /net-mgmt
parent057ee0b2a89effeb6dcea7f3fc12246986f3af2f (diff)
downloadports-3774dc0944ef1542b226552ac387d4866ece3d18.tar.gz
ports-3774dc0944ef1542b226552ac387d4866ece3d18.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/argus3-clients/Makefile37
1 files changed, 13 insertions, 24 deletions
diff --git a/net-mgmt/argus3-clients/Makefile b/net-mgmt/argus3-clients/Makefile
index 229edb511f1d..5bdf4deccad8 100644
--- a/net-mgmt/argus3-clients/Makefile
+++ b/net-mgmt/argus3-clients/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= net-mgmt security
MASTER_SITES= http://qosient.com/argus/src/ \
ftp://qosient.com/pub/argus/src/
-MAINTAINER= pauls@utdallas.edu
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Client programs for the argus IP network transaction auditing tool
LICENSE= GPLv3
@@ -16,30 +16,21 @@ CONFLICTS= argus-clients-2* argus-clients-sasl-2*
OPTIONS_DEFINE= GEOIP MYSQL SASL DOCS
OPTIONS_DEFAULT=MYSQL SASL
+OPTIONS_SUB= yes
+SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+SASL_CONFIGURE_ON= --with-sasl=${LOCALBASE}
+MYSQL_USE= MYSQL=yes
+GEOIP_LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+GEOIP_CONFIGURE_ON= --with-GeoIP=${LOCALBASE}
USES= bison ncurses perl5
USE_CSTD= gnu89
+GNU_CONFIGURE= yes
.include <bsd.port.options.mk>
-GNU_CONFIGURE= true
-
.if ${PORT_OPTIONS:MSASL}
PKGNAMESUFFIX+= -sasl
-LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
-CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-PLIST_SUB+= MYSQL=""
-.else
-PLIST_SUB+= MYSQL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
-CONFIGURE_ARGS+= --with-GeoIP=${LOCALBASE}
.endif
do-install:
@@ -59,15 +50,20 @@ do-install:
.for i in rasql rasqlinsert rasqltimeindex
${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${STAGEDIR}/${PREFIX}/bin/$i
.endfor
+.for i in rasql.1 rasqlinsert.1 rasqltimeindex.1
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/$i ${STAGEDIR}/${PREFIX}/man/man1
+.endfor
.endif
.for i in radark ragraph rahosts raports
${INSTALL_SCRIPT} ${WRKSRC}/bin/$i ${STAGEDIR}/${PREFIX}/bin/$i
.endfor
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}/${DOCSDIR}/
.for i in AUTHORS CHANGES CREDITS ChangeLog INSTALL \
MANIFEST README VERSION
${INSTALL_DATA} ${WRKSRC}/$i ${STAGEDIR}/${DOCSDIR}
.endfor
+.endif
.for i in ra.1 rabins.1 racluster.1 raconvert.1 racount.1 radump.1 raevent.1 \
rafilteraddr.1 ragraph.1 ragrep.1 rahisto.1 ralabel.1 ranonymize.1 \
rapath.1 rapolicy.1 rasort.1 rasplit.1 rastream.1 rastrip.1
@@ -79,17 +75,10 @@ do-install:
.for i in radium.8
${INSTALL_MAN} ${WRKSRC}/man/man8/$i ${STAGEDIR}/${PREFIX}/man/man8
.endfor
-.if ${PORT_OPTIONS:MMYSQL}
-.for i in rasql.1 rasqlinsert.1 rasqltimeindex.1
- ${INSTALL_MAN} ${WRKSRC}/man/man1/$i ${STAGEDIR}/${PREFIX}/man/man1
-.endfor
-.endif
-
${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}
.for i in Config Database Startup System
${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}/$i
.endfor
-
.for i in delegated-ipv4-latest excel.rc iana-address-file \
iana-ipv4-address iana-multicast-address iana-port-numbers \
racluster.conf radium.conf ragetcountrycodes.sh ralabel.conf \