aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2017-04-09 20:10:26 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2017-04-09 20:10:26 +0000
commit6ceb34ea75074ab4ec2f156f72ca17f60aafa3b0 (patch)
treee4d4a9df48136b28cb40deef1ed6642eaeb1a6c0 /net-mgmt
parent72082680641abecd1fb552cd4292c60faf49cffd (diff)
downloadports-6ceb34ea75074ab4ec2f156f72ca17f60aafa3b0.tar.gz
ports-6ceb34ea75074ab4ec2f156f72ca17f60aafa3b0.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zabbix22-frontend/Makefile2
-rw-r--r--net-mgmt/zabbix22-server/Makefile2
-rw-r--r--net-mgmt/zabbix22-server/distinfo6
-rw-r--r--net-mgmt/zabbix22-server/files/zabbix_agentd.in11
-rw-r--r--net-mgmt/zabbix22-server/files/zabbix_proxy.in8
-rw-r--r--net-mgmt/zabbix22-server/files/zabbix_server.in9
6 files changed, 32 insertions, 6 deletions
diff --git a/net-mgmt/zabbix22-frontend/Makefile b/net-mgmt/zabbix22-frontend/Makefile
index d70f8c4193c1..78418cbbf582 100644
--- a/net-mgmt/zabbix22-frontend/Makefile
+++ b/net-mgmt/zabbix22-frontend/Makefile
@@ -14,7 +14,7 @@ PLIST= ${PKGDIR}/pkg-plist.frontend
USE_PHP= bcmath ctype gd pcre snmp sockets mbstring session dom xml \
xmlreader xmlwriter simplexml gettext ldap
-WANT_PHP_WEB= yes
+USES+= php:web
OPTIONS_DEFINE= MYSQL MYSQLI PGSQL SQLITE ORACLE
OPTIONS_DEFAULT= MYSQL MYSQLI
diff --git a/net-mgmt/zabbix22-server/Makefile b/net-mgmt/zabbix22-server/Makefile
index 0cf04bafa7ee..4b6ac345cc70 100644
--- a/net-mgmt/zabbix22-server/Makefile
+++ b/net-mgmt/zabbix22-server/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= zabbix22
-PORTVERSION= 2.2.15
+PORTVERSION= 2.2.17
CATEGORIES= net-mgmt
MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
PKGNAMESUFFIX?= -server
diff --git a/net-mgmt/zabbix22-server/distinfo b/net-mgmt/zabbix22-server/distinfo
index c8594f708b9a..1be3c411af1a 100644
--- a/net-mgmt/zabbix22-server/distinfo
+++ b/net-mgmt/zabbix22-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1475755867
-SHA256 (zabbix-2.2.15.tar.gz) = 1dc370a04bc42bf21cdedc2dd53de051ac4a61d20ae83cd7c6e1cdd9c574f653
-SIZE (zabbix-2.2.15.tar.gz) = 15487398
+TIMESTAMP = 1489335489
+SHA256 (zabbix-2.2.17.tar.gz) = cf42c5db31c27466a9ec33b6bf22289bbc43ee4e5711e6d323d71644b743e535
+SIZE (zabbix-2.2.17.tar.gz) = 15494053
diff --git a/net-mgmt/zabbix22-server/files/zabbix_agentd.in b/net-mgmt/zabbix22-server/files/zabbix_agentd.in
index 7937923e8324..d3ac5102f812 100644
--- a/net-mgmt/zabbix22-server/files/zabbix_agentd.in
+++ b/net-mgmt/zabbix22-server/files/zabbix_agentd.in
@@ -11,8 +11,10 @@
# enable zabbix_agentd.
# zabbix_agentd_config (string): Set to the standard config file path by
# default.
-# zabbix_agentd_pidfile (string): Location of the zabbix_agentd pid file
+# zabbix_agentd_pidfile (string): Location of the zabbix_agent pid file
# Default is /var/run/zabbix/zabbix_agentd.pid
+# zabbix_agentd_paths (string): Set to standard path by default. Set a search
+# if you have custom userparams that need binaries elsewhere.
#
. /etc/rc.subr
@@ -25,10 +27,12 @@ load_rc_config $name
: ${zabbix_agentd_enable:=NO}
: ${zabbix_agentd_config:=%%ETCDIR%%/${name}.conf}
: ${zabbix_agentd_pidfile:=/var/run/zabbix/zabbix_agentd.pid}
+: ${zabbix_agentd_paths:=$PATH}
command="%%PREFIX%%/sbin/${name}"
required_files="${zabbix_agentd_config}"
+start_cmd=zabbix_agentd_cmd
start_precmd=zabbix_agentd_precmd
status_precmd=zabbix_agentd_precmd
stop_precmd=zabbix_agentd_precmd
@@ -52,4 +56,9 @@ zabbix_agentd_precmd()
rc_pid=$(check_pidfile ${pidfile} ${command})
}
+zabbix_agentd_cmd()
+{
+ PATH=$zabbix_agentd_paths $command -c $zabbix_agentd_config
+}
+
run_rc_command "$1"
diff --git a/net-mgmt/zabbix22-server/files/zabbix_proxy.in b/net-mgmt/zabbix22-server/files/zabbix_proxy.in
index d990d2338bba..f202f3825111 100644
--- a/net-mgmt/zabbix22-server/files/zabbix_proxy.in
+++ b/net-mgmt/zabbix22-server/files/zabbix_proxy.in
@@ -15,6 +15,8 @@
# default.
# zabbix_proxy_pidfile (string): Location of the zabbix_proxy pid file
# Default is /var/run/zabbix/zabbix_proxy.pid
+# zabbix_proxy_paths (string): Set to standard path by default. Set a search
+# if you have custom userparams that need binaries elsewhere.
#
. /etc/rc.subr
@@ -31,6 +33,7 @@ load_rc_config $name
command="%%PREFIX%%/sbin/${name}"
required_files="${zabbix_proxy_config}"
+start_cmd=zabbix_proxy_cmd
start_precmd=zabbix_proxy_precmd
status_precmd=zabbix_proxy_precmd
stop_precmd=zabbix_proxy_precmd
@@ -54,4 +57,9 @@ zabbix_proxy_precmd()
rc_pid=$(check_pidfile ${pidfile} ${command})
}
+zabbix_proxy_cmd()
+{
+ PATH=$zabbix_proxy_paths $command -c $zabbix_proxy_config
+}
+
run_rc_command "$1"
diff --git a/net-mgmt/zabbix22-server/files/zabbix_server.in b/net-mgmt/zabbix22-server/files/zabbix_server.in
index eb79cb37e8cb..5454914ff3b3 100644
--- a/net-mgmt/zabbix22-server/files/zabbix_server.in
+++ b/net-mgmt/zabbix22-server/files/zabbix_server.in
@@ -15,6 +15,8 @@
# default.
# zabbix_server_pidfile (string): Location of the zabbix_server pid file
# Default is /var/run/zabbix/zabbix_server.pid
+# zabbix_server_paths (string): Set to standard path by default. Set a search
+# if you have custom userparams that need binaries elsewhere.
#
. /etc/rc.subr
@@ -27,10 +29,12 @@ load_rc_config $name
: ${zabbix_server_enable:=NO}
: ${zabbix_server_config:=%%ETCDIR%%/${name}.conf}
: ${zabbix_server_pidfile:=/var/run/zabbix/zabbix_server.pid}
+: ${zabbix_server_paths:=$PATH}
command="%%PREFIX%%/sbin/${name}"
required_files="${zabbix_server_config}"
+start_cmd=zabbix_server_cmd
start_precmd=zabbix_server_precmd
status_precmd=zabbix_server_precmd
stop_precmd=zabbix_server_precmd
@@ -54,4 +58,9 @@ zabbix_server_precmd()
rc_pid=$(check_pidfile ${pidfile} ${command})
}
+zabbix_server_cmd()
+{
+ PATH=$zabbix_server_paths $command -c $zabbix_server_config
+}
+
run_rc_command "$1"