aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-08 16:57:58 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-08 16:57:58 +0000
commit77318e20c30995ae8ddf044fe882ba4cb82ccd48 (patch)
tree9a9c4c34b09a842726196ee38dab67a26cc36866 /net-mgmt
parentc49ecf92207b073d4750e3ac5e98650021a2b57c (diff)
downloadports-77318e20c30995ae8ddf044fe882ba4cb82ccd48.tar.gz
ports-77318e20c30995ae8ddf044fe882ba4cb82ccd48.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/check_mysql_health/Makefile38
-rw-r--r--net-mgmt/check_mysql_health/distinfo3
-rw-r--r--net-mgmt/check_mysql_health/pkg-descr3
4 files changed, 45 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index ad51b139ee67..3cf2b8aed32c 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -41,6 +41,7 @@
SUBDIR += cfgstoragemk
SUBDIR += cflowd
SUBDIR += check_multi
+ SUBDIR += check_mysql_health
SUBDIR += check_snmp_pkgvuln
SUBDIR += chillispot
SUBDIR += choparp
diff --git a/net-mgmt/check_mysql_health/Makefile b/net-mgmt/check_mysql_health/Makefile
new file mode 100644
index 000000000000..05a0372e1d81
--- /dev/null
+++ b/net-mgmt/check_mysql_health/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: check_mysql_health
+# Date created: November 8, 2010
+# Whom: pgollucci@p6m7g8.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= check_mysql_health
+PORTVERSION= 2.1.3
+CATEGORIES= net-mgmt
+MASTER_SITES= http://labs.consol.de/wp-content/uploads/2010/10/
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Nagios plugin to check various parameters of a MySQL database
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-statefiles-dir=${NAGIOSDIR} \
+ --with-nagios-user=${NAGIOSUSER} \
+ --with-nagios-group=${NAGIOSGROUP} \
+ --with-mymodules-dir=${PREFIX}/libexec/nagios \
+ --with-mymodules-dyn-dir=${PREFIX}/libexec/nagios \
+ --libexecdir=${PREFIX}/libexec/nagios \
+ --with-perl=${PERL}
+
+USE_PERL5= yes
+
+NAGIOSUSER?= nagios
+NAGIOSGROUP?= nagios
+NAGIOSDIR?= /var/spool/nagios
+
+PLIST_FILES= libexec/nagios/check_mysql_health
+PLIST_DIRS= libexec/nagios
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/check_mysql_health/distinfo b/net-mgmt/check_mysql_health/distinfo
new file mode 100644
index 000000000000..d64175640940
--- /dev/null
+++ b/net-mgmt/check_mysql_health/distinfo
@@ -0,0 +1,3 @@
+MD5 (check_mysql_health-2.1.3.tar.gz) = c8594745a3aecf07569d6f40dca0b40c
+SHA256 (check_mysql_health-2.1.3.tar.gz) = 55bdc589034105b09a7fcbed94f85c1f379da23fe00212b15b3f5a78be1d322e
+SIZE (check_mysql_health-2.1.3.tar.gz) = 115861
diff --git a/net-mgmt/check_mysql_health/pkg-descr b/net-mgmt/check_mysql_health/pkg-descr
new file mode 100644
index 000000000000..4c5de503d158
--- /dev/null
+++ b/net-mgmt/check_mysql_health/pkg-descr
@@ -0,0 +1,3 @@
+a plugin to check various parameters of a MySQL database
+
+WWW: http://labs.consol.de/lang/en/nagios/check_mysql_health/