aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-15 18:11:34 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-15 18:11:34 +0000
commitdbb402ee5853b69be77d9642d0f07370ab41df82 (patch)
tree04678015d72a810dc0a825ea35b59b3a595c8bea /net-mgmt
parentf84d85f72cadef8b3daf377d6c7c7e696b352550 (diff)
downloadports-dbb402ee5853b69be77d9642d0f07370ab41df82.tar.gz
ports-dbb402ee5853b69be77d9642d0f07370ab41df82.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cacti/Makefile13
-rw-r--r--net-mgmt/cacti/files/patch-scripts__3com_cable_modem.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__diskfree.pl7
-rw-r--r--net-mgmt/cacti/files/patch-scripts__linux_memory.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__loadavg.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__loadavg_multi.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__ping.pl10
-rw-r--r--net-mgmt/cacti/files/patch-scripts__query_unix_partitions.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__unix_processes.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__unix_tcp_connections.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__unix_users.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__weatherbug.pl8
-rw-r--r--net-mgmt/cacti/files/patch-scripts__webhits.pl8
13 files changed, 18 insertions, 92 deletions
diff --git a/net-mgmt/cacti/Makefile b/net-mgmt/cacti/Makefile
index 1bfc0a305f6d..52858f4baf88 100644
--- a/net-mgmt/cacti/Makefile
+++ b/net-mgmt/cacti/Makefile
@@ -20,12 +20,25 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
PATCH_STRIP= -p1
+USES= shebangfix
USE_MYSQL= yes
USE_PHP= mysql pcre session sockets snmp xml
WANT_PHP_WEB= yes
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
+SHEBANG_FILES= scripts/3com_cable_modem.pl \
+ scripts/diskfree.pl \
+ scripts/linux_memory.pl \
+ scripts/loadavg.pl \
+ scripts/loadavg_multi.pl \
+ scripts/ping.pl \
+ scripts/query_unix_partitions.pl \
+ scripts/unix_processes.pl \
+ scripts/unix_tcp_connections.pl \
+ scripts/unix_users.pl \
+ scripts/weatherbug.pl \
+ scripts/webhits.pl
CACTIDIR?= share/cacti
CACTIUSER?= cacti
diff --git a/net-mgmt/cacti/files/patch-scripts__3com_cable_modem.pl b/net-mgmt/cacti/files/patch-scripts__3com_cable_modem.pl
deleted file mode 100644
index 9c6d36d9c50b..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__3com_cable_modem.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/3com_cable_modem.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/3com_cable_modem.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- open(PROCESS, "/bin/bash -c 'wget --quiet -O - http://192.168.100.1/cgibin/opcfg | grep \"10.18.18.11\" -c' |");
- $status = <PROCESS>;
diff --git a/net-mgmt/cacti/files/patch-scripts__diskfree.pl b/net-mgmt/cacti/files/patch-scripts__diskfree.pl
index 8f83817deec6..9d0465e31c57 100644
--- a/net-mgmt/cacti/files/patch-scripts__diskfree.pl
+++ b/net-mgmt/cacti/files/patch-scripts__diskfree.pl
@@ -1,9 +1,8 @@
---- ./scripts/diskfree.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/diskfree.pl 2014-08-11 17:34:23.000000000 -0700
+--- ./scripts/diskfree.pl.orig 2014-08-15 15:39:51.000000000 +0200
++++ ./scripts/diskfree.pl 2014-08-15 15:40:16.000000000 +0200
@@ -1,5 +1,5 @@
--#!/usr/bin/perl
+ #!/usr/bin/perl
-open(PROCESS,"df --block-size=1024 -P $ARGV[0] | grep -v Filesystem |");
-+#!/usr/local/bin/perl
+open(PROCESS,"df -k $ARGV[0] | grep -v Filesystem |");
foreach (<PROCESS>) {
if ($_ =~ /($ARGV[0])(.* )(.*[0-9])(.* )(.*[0-9])(.* )(.*[0-9])(.* )(.*[0-9])%(.* )/) {
diff --git a/net-mgmt/cacti/files/patch-scripts__linux_memory.pl b/net-mgmt/cacti/files/patch-scripts__linux_memory.pl
deleted file mode 100644
index 79eb27b95e4f..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__linux_memory.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/linux_memory.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/linux_memory.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- open(PROCESS, "cat /proc/meminfo | grep -w $ARGV[0] |");
- foreach (<PROCESS>) {
diff --git a/net-mgmt/cacti/files/patch-scripts__loadavg.pl b/net-mgmt/cacti/files/patch-scripts__loadavg.pl
deleted file mode 100644
index 78d57891d428..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__loadavg.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/loadavg.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/loadavg.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- #get load avg for 5;15;30 min
- open(PROCESS,"uptime |");
diff --git a/net-mgmt/cacti/files/patch-scripts__loadavg_multi.pl b/net-mgmt/cacti/files/patch-scripts__loadavg_multi.pl
deleted file mode 100644
index 33c6a1454bc0..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__loadavg_multi.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/loadavg_multi.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/loadavg_multi.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- #get load avg for 1;5;10 min
- open(PROCESS, "uptime |");
diff --git a/net-mgmt/cacti/files/patch-scripts__ping.pl b/net-mgmt/cacti/files/patch-scripts__ping.pl
index c17f4d38588d..65e3f1e06ec2 100644
--- a/net-mgmt/cacti/files/patch-scripts__ping.pl
+++ b/net-mgmt/cacti/files/patch-scripts__ping.pl
@@ -1,11 +1,5 @@
---- ./scripts/ping.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/ping.pl 2014-08-11 17:34:23.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- # take care for tcp:hostname or TCP:ip@
- $host = $ARGV[0];
+--- ./scripts/ping.pl.orig 2014-08-15 15:39:56.000000000 +0200
++++ ./scripts/ping.pl 2014-08-15 15:40:35.000000000 +0200
@@ -6,7 +6,7 @@
# old linux version use "icmp_seq"
diff --git a/net-mgmt/cacti/files/patch-scripts__query_unix_partitions.pl b/net-mgmt/cacti/files/patch-scripts__query_unix_partitions.pl
deleted file mode 100644
index 37ac965ae44c..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__query_unix_partitions.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/query_unix_partitions.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/query_unix_partitions.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- if (($ARGV[0] ne "query") && ($ARGV[0] ne "get") && ($ARGV[0] ne "index") && ($ARGV[0] ne "num_indexes")) {
- print "usage:\n\n";
diff --git a/net-mgmt/cacti/files/patch-scripts__unix_processes.pl b/net-mgmt/cacti/files/patch-scripts__unix_processes.pl
deleted file mode 100644
index 3e216cd4ec03..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__unix_processes.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/unix_processes.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/unix_processes.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- open(PROCESS, "ps ax | grep -c : |");
- $output = <PROCESS>;
diff --git a/net-mgmt/cacti/files/patch-scripts__unix_tcp_connections.pl b/net-mgmt/cacti/files/patch-scripts__unix_tcp_connections.pl
deleted file mode 100644
index 48a9a437fe3c..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__unix_tcp_connections.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/unix_tcp_connections.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/unix_tcp_connections.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- my $grep_string = $ARGV[0];
-
diff --git a/net-mgmt/cacti/files/patch-scripts__unix_users.pl b/net-mgmt/cacti/files/patch-scripts__unix_users.pl
deleted file mode 100644
index 1e3e861ad394..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__unix_users.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/unix_users.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/unix_users.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- my $grep_string = $ARGV[0];
-
diff --git a/net-mgmt/cacti/files/patch-scripts__weatherbug.pl b/net-mgmt/cacti/files/patch-scripts__weatherbug.pl
deleted file mode 100644
index 8ee812b24c8c..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__weatherbug.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/weatherbug.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/weatherbug.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- $output = `/bin/bash -c 'wget --quiet -O - \"http:\/\/wisapidata.weatherbug.com\/WxDataISAPI\/WxDataISAPI.dll?Magic=10991&RegNum=3647055&ZipCode=17241&StationID=NWVLL&Units=0&Version=2.7&Fore=1&t=1015084854\/"'`;
-
diff --git a/net-mgmt/cacti/files/patch-scripts__webhits.pl b/net-mgmt/cacti/files/patch-scripts__webhits.pl
deleted file mode 100644
index 6b7e86e8c402..000000000000
--- a/net-mgmt/cacti/files/patch-scripts__webhits.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./scripts/webhits.pl.orig 2013-08-06 19:31:19.000000000 -0700
-+++ ./scripts/webhits.pl 2014-08-11 18:37:08.000000000 -0700
-@@ -1,4 +1,4 @@
--#!/usr/bin/perl
-+#!/usr/local/bin/perl
-
- if ($ARGV[0] eq "") {
- $log_path = "/var/log/httpd/access_log";