aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-14 08:36:27 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-14 08:36:27 +0000
commit0e20a6bc8b3cc203d7b9f5a244aa3d9113b38fe6 (patch)
tree9e70363b4f60695bce71e0c50170307edd54d076 /net-mgmt
parent50bfb14f4ee10ea51c1b06acf469dfe9f39dda46 (diff)
downloadports-0e20a6bc8b3cc203d7b9f5a244aa3d9113b38fe6.tar.gz
ports-0e20a6bc8b3cc203d7b9f5a244aa3d9113b38fe6.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/arpwatch/Makefile3
-rw-r--r--net-mgmt/arpwatch/files/patch-ah13
-rw-r--r--net-mgmt/arpwatch/files/patch-al20
-rw-r--r--net-mgmt/arpwatch/files/patch-am33
4 files changed, 65 insertions, 4 deletions
diff --git a/net-mgmt/arpwatch/Makefile b/net-mgmt/arpwatch/Makefile
index 0bbd713f09a3..93e4d70d682f 100644
--- a/net-mgmt/arpwatch/Makefile
+++ b/net-mgmt/arpwatch/Makefile
@@ -7,7 +7,7 @@
PORTNAME= arpwatch
PORTVERSION= 2.1.a11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt
MASTER_SITES= http://www.Awfulhak.org/arpwatch/ \
ftp://ftp.ee.lbl.gov/
@@ -18,7 +18,6 @@ COMMENT= Monitor arp & rarp requests
CONFLICTS= arpwatch-devel-2.*
-USE_SIZE= yes
GNU_CONFIGURE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --quiet
diff --git a/net-mgmt/arpwatch/files/patch-ah b/net-mgmt/arpwatch/files/patch-ah
index b292b25116d0..19fab58ae8fa 100644
--- a/net-mgmt/arpwatch/files/patch-ah
+++ b/net-mgmt/arpwatch/files/patch-ah
@@ -1,5 +1,5 @@
---- report.c.orig Sun Oct 1 00:41:10 2000
-+++ report.c Thu May 16 11:34:33 2002
+--- report.c.orig Sat Sep 30 19:41:10 2000
++++ report.c Tue Apr 13 17:47:16 2004
@@ -45,6 +45,8 @@
#include <ctype.h>
@@ -27,6 +27,15 @@
char *watchee = WATCHEE;
char *sendmail = PATH_SENDMAIL;
char *unknown = "<unknown>";
+@@ -303,7 +307,7 @@
+ (void)fprintf(f, "From: %s\n", watchee);
+ (void)fprintf(f, "To: %s\n", watcher);
+ hn = gethname(a);
+- if (!isdigit(*hn))
++ if (hn != NULL)
+ (void)fprintf(f, "Subject: %s (%s)\n", title, hn);
+ else {
+ (void)fprintf(f, "Subject: %s\n", title);
@@ -344,6 +348,25 @@
exit(1);
}
diff --git a/net-mgmt/arpwatch/files/patch-al b/net-mgmt/arpwatch/files/patch-al
new file mode 100644
index 000000000000..b8aebbe36559
--- /dev/null
+++ b/net-mgmt/arpwatch/files/patch-al
@@ -0,0 +1,20 @@
+--- db.c.orig Sat Sep 30 19:39:58 2000
++++ db.c Tue Apr 13 17:42:20 2004
+@@ -283,7 +283,7 @@
+ BCOPY(e, ep->e, 6);
+ if (h == NULL && !initializing)
+ h = getsname(a);
+- if (h != NULL && !isdigit((int)*h))
++ if (h != NULL)
+ strcpy(ep->h, h);
+ ep->t = t;
+ return (ep);
+@@ -301,7 +301,7 @@
+ return;
+ ep = ap->elist[0];
+ h = getsname(ap->a);
+- if (!isdigit((int)*h) && strcmp(h, ep->h) != 0) {
++ if (h != NULL && strcmp(h, ep->h) != 0) {
+ syslog(LOG_INFO, "hostname changed %s %s %s -> %s",
+ intoa(ap->a), e2str(ep->e), ep->h, h);
+ strcpy(ep->h, h);
diff --git a/net-mgmt/arpwatch/files/patch-am b/net-mgmt/arpwatch/files/patch-am
new file mode 100644
index 000000000000..fec1ea1570bf
--- /dev/null
+++ b/net-mgmt/arpwatch/files/patch-am
@@ -0,0 +1,33 @@
+--- dns.c.orig Fri Oct 13 21:50:52 2000
++++ dns.c Tue Apr 13 17:35:07 2004
+@@ -137,7 +137,7 @@
+ return (0);
+ }
+
+-/* Return the cannonical name of the host */
++/* Return the canonical name of the host (NULL if not found) */
+ char *
+ gethname(u_int32_t a)
+ {
+@@ -150,18 +150,18 @@
+ hp = gethostbyaddr((char *)&a, sizeof(a), AF_INET);
+ _res.options = options;
+ if (hp == NULL)
+- return (intoa(a));
++ return NULL;
+ return (hp->h_name);
+ }
+
+-/* Return the simple name of the host */
++/* Return the simple name of the host (NULL if not found) */
+ char *
+ getsname(register u_int32_t a)
+ {
+ register char *s, *cp;
+
+ s = gethname(a);
+- if (!isdigit((int)*s)) {
++ if (s != NULL) {
+ cp = strchr(s, '.');
+ if (cp != NULL)
+ *cp = '\0';