aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-07 09:45:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-07 09:45:08 +0000
commit9a964a363d610ff240201b4696031ce7bd4c8b86 (patch)
tree8cb39628b8d164019c872bc3e9b730baee16164b /net-mgmt
parentbe6dd2c30d71b0eeebd7cc2f3eb91c3361c5dc61 (diff)
downloadports-9a964a363d610ff240201b4696031ce7bd4c8b86.tar.gz
ports-9a964a363d610ff240201b4696031ce7bd4c8b86.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ettercap/Makefile128
-rw-r--r--net-mgmt/ettercap/distinfo4
-rw-r--r--net-mgmt/ettercap/files/patch-configure129
-rw-r--r--net-mgmt/ettercap/files/patch-share::Makefile.in11
-rw-r--r--net-mgmt/ettercap/pkg-plist58
5 files changed, 155 insertions, 175 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index 6a6395226918..eaa9ed785b6b 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -5,108 +5,104 @@
# $FreeBSD$
#
-PORTNAME= ettercap
-PORTVERSION= 0.7.3
-DISTVERSIONPREFIX= NG-
-PORTREVISION= 10
-PORTEPOCH= 1
-CATEGORIES= net-mgmt security
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/NG-${PORTVERSION} \
- ${MASTER_SITE_PACKETSTORM:S:%SUBDIR%:sniffers/ettercap:}
-
-MAINTAINER= ports@FreeBSD.org
+PORTNAME= ettercap
+PORTVERSION= 0.7.4
+PORTEPOCH= 1
+CATEGORIES= net-mgmt security
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}-Lazarus \
+ ${MASTER_SITE_PACKETSTORM:S:%SUBDIR%:sniffers/ettercap:}
+
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A network sniffer/interceptor/injector/logger for switched LANs
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LOCALBASE}/bin/libnet11-config:${PORTSDIR}/net/libnet
-OPTIONS= GTK "Build with GTK2+ GUI" on \
- ICONV "Build with support for UTF-8" on \
- PLUGINS "Build with ettercap plugins" on \
- SSL "Build with support for SSH1 and SSL decryption" on \
- PCRE "Build with PCRE regexps in filters" on
+OPTIONS= GTK "Build with GTK2+ GUI" on \
+ ICONV "Build with support for UTF-8" on \
+ PCRE "Build with PCRE regexps in filters" on \
+ PLUGINS "Build with ettercap plugins" on \
+ SSL "Build with support for SSH1 and SSL decryption" on
-WANT_GNOME= yes
-USE_AUTOTOOLS= libltdl
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= LIBS="${LDFLAGS}"
+CONFIGURE_ARGS= --enable-plugins
+CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
+USE_AUTOTOOLS= libltdl libtool
+USE_BISON= build
+WANT_GNOME= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
MAN5= etter.conf.5
MAN8= ettercap.8 ettercap_curses.8 etterfilter.8 etterlog.8
DOCS= AUTHORS CHANGELOG README README.BINARIES README.BUGS \
- README.CVS README.PLATFORMS THANKS TODO TODO.TESTING \
+ README.GIT README.PLATFORMS THANKS TODO TODO.TESTING \
doc/capture doc/decoders doc/dissectors doc/threads
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
-.include <bsd.port.pre.mk>
-
-CFLAGS+= ${PTHREAD_CFLAGS}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= LIBS="${LDFLAGS}"
-CONFIGURE_ARGS+= --enable-plugins
+.include <bsd.port.options.mk>
.if !defined(WITHOUT_GTK)
-USE_GNOME= glib20 atk pango gtk20
-PKGNAMESUFFIX+= -gtk2
-CONFIGURE_ARGS+= --enable-gtk
+USE_GNOME= atk glib20 gtk20 pango
+PKGNAMESUFFIX+= -gtk2
+CONFIGURE_ARGS+=--enable-gtk
.else
-CONFIGURE_ARGS+= --disable-gtk
+CONFIGURE_ARGS+=--disable-gtk
.endif
.if !defined(WITHOUT_ICONV)
-USE_ICONV= yes
-CONFIGURE_ARGS+= --with-iconv=${LOCALBASE}
+USE_ICONV= yes
+CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
.endif
.if !defined(WITHOUT_PCRE)
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-CONFIGURE_ARGS+= --with-libpcre=${LOCALBASE}
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+=--with-libpcre=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --without-libpcre
+CONFIGURE_ARGS+=--without-libpcre
.endif
.if !defined(WITHOUT_PLUGINS)
-MAN8+= ettercap_plugins.8
-DOCS+= doc/plugins
-CONFIGURE_ARGS+= --enable-plugins
-PLIST_SUB+= PLUGINS=""
+MAN8+= ettercap_plugins.8
+DOCS+= doc/plugins
+CONFIGURE_ARGS+=--enable-plugins
+PLIST_SUB+= PLUGINS=""
.else
-CONFIGURE_ARGS+= --disable-plugins
-PLIST_SUB+= PLUGINS="@comment "
+CONFIGURE_ARGS+=--disable-plugins
+PLIST_SUB+= PLUGINS="@comment "
.endif
.if !defined(WITHOUT_SSL)
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
.else
-CONFIGURE_ARGS+= --without-openssl
+CONFIGURE_ARGS+=--without-openssl
.endif
post-patch:
- @${REINPLACE_CMD} -Ee \
- 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|; \
- s|test -f /usr/include/libnet\.h|${TRUE}|; \
- s|(LNETINC=).*|\1"`${LIBNET_CONFIG} --cflags`"|; \
- s|(LNETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -E -e 's|(^pkgdatadir.+=).+|\1 ${DATADIR}|' \
- ${WRKSRC}/share/Makefile.in
+ @${REINPLACE_CMD} -E \
+ -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
+ -e 's|test -f /usr/include/libnet\.h|${TRUE}|' \
+ -e 's|(LNETINC=).*|\1"`${LIBNET_CONFIG} --cflags`"|' \
+ -e 's|(LNETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -E \
+ -e 's|(^pkgdatadir.+=).+|\1 ${DATADIR}|' \
+ -e '/^install-exec-am:/ s|: .*$$|:|'\
+ ${WRKSRC}/share/Makefile.in
# Fix objformat
@${REINPLACE_CMD} -E -e 's|(^.*=).*/usr/bin/objformat.*|\1"elf"|' \
${WRKSRC}/aclocal.m4 ${WRKSRC}/configure
post-install:
- @${INSTALL_DATA} ${WRKSRC}/share/etter.conf \
- ${PREFIX}/etc/etter.conf.sample
-. if !exists(${PREFIX}/etc/etter.conf)
- @${INSTALL_DATA} ${WRKSRC}/share/etter.conf ${PREFIX}/etc/etter.conf
-. endif
-. if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-. for i in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
-. endfor
-. endif
+ ${INSTALL_DATA} ${WRKSRC}/share/etter.conf ${PREFIX}/etc/etter.conf.sample
+.if !exists(${PREFIX}/etc/etter.conf)
+ ${INSTALL_DATA} ${WRKSRC}/share/etter.conf ${PREFIX}/etc/etter.conf
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/ettercap/distinfo b/net-mgmt/ettercap/distinfo
index 52e0fddb72bd..52973e3ed868 100644
--- a/net-mgmt/ettercap/distinfo
+++ b/net-mgmt/ettercap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ettercap-NG-0.7.3.tar.gz) = c74239052d62565c13a82f9bbf217a4fdcce4b34949e361b53bb3f28e3168543
-SIZE (ettercap-NG-0.7.3.tar.gz) = 1138643
+SHA256 (ettercap-0.7.4.tar.gz) = 301a0d3e1cd8a73d985df79fdbce4410008c7cbb32eb78ae2d0475bf686202f8
+SIZE (ettercap-0.7.4.tar.gz) = 2946394
diff --git a/net-mgmt/ettercap/files/patch-configure b/net-mgmt/ettercap/files/patch-configure
index 77db4c590bf0..004fbb2716d5 100644
--- a/net-mgmt/ettercap/files/patch-configure
+++ b/net-mgmt/ettercap/files/patch-configure
@@ -1,75 +1,86 @@
---- configure.orig Fri Jun 14 18:53:14 2002
-+++ configure Wed Jul 17 17:09:18 2002
-@@ -27504,8 +27504,8 @@
- rm -f conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
- if test "$ac_cv_search_pthread_create" = no; then
-- for ac_lib in c_r pthread; do
-- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
-+# for ac_lib in c_r pthread; do
-+ LIBS="%%PTHREAD_LIBS%% $ac_func_search_save_LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
+--- configure.orig 2012-01-03 10:07:17.000000000 +0800
++++ configure 2012-02-02 03:41:52.196909256 +0800
+@@ -15293,22 +15293,23 @@
+ return 0;
+ }
_ACEOF
-@@ -27550,7 +27550,7 @@
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-- ac_cv_search_pthread_create="-l$ac_lib"
-+ ac_cv_search_pthread_create="%%PTHREAD_LIBS%%"
- break
+-for ac_lib in '' c_r pthread; do
+- if test -z "$ac_lib"; then
+- ac_res="none required"
+- else
+- ac_res=-l$ac_lib
+- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+- fi
+- if ac_fn_c_try_link "$LINENO"; then :
+- ac_cv_search_pthread_create=$ac_res
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+- conftest$ac_exeext
+- if ${ac_cv_search_pthread_create+:} false; then :
+- break
+-fi
+-done
++#for ac_lib in '' c_r pthread; do
++# if test -z "$ac_lib"; then
++# ac_res="none required"
++# else
++# ac_res=-l$ac_lib
++# LIBS="-l$ac_lib $ac_func_search_save_LIBS"
++# fi
++# if ac_fn_c_try_link "$LINENO"; then :
++# ac_cv_search_pthread_create=$ac_res
++#fi
++#rm -f core conftest.err conftest.$ac_objext \
++# conftest$ac_exeext
++# if ${ac_cv_search_pthread_create+:} false; then :
++# break
++#fi
++#done
++ac_cv_search_pthread_create=%%PTHREAD_LIBS%%
+ if ${ac_cv_search_pthread_create+:} false; then :
+
else
- echo "$as_me: failed program was:" >&5
-@@ -27559,7 +27559,7 @@
- fi
- rm -f conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
-- done
-+# done
- fi
- LIBS=$ac_func_search_save_LIBS
- fi
-@@ -27699,10 +27699,10 @@
+@@ -15384,10 +15385,10 @@
fi
- elif test "$OS" != "MACOSX" -a "$OS" != "WINDOWS"; then
-- echo "$as_me:$LINENO: checking whether $CC accepts -pthread" >&5
--echo $ECHO_N "checking whether $CC accepts -pthread... $ECHO_C" >&6
-+ echo "$as_me:$LINENO: checking whether $CC accepts %%PTHREAD_LIBS%%" >&5
-+echo $ECHO_N "checking whether $CC accepts %%PTHREAD_LIBS%%... $ECHO_C" >&6
+ elif test "$OS" = "MACOSX"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $CC accepts -pthread" >&5
+-$as_echo_n "checking whether $CC accepts -pthread... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $CC accepts %%PTHREAD_LIBS%%" >&5
++$as_echo_n "checking whether $CC accepts %%PTHREAD_LIBS%%... " >&6; }
LDFLAGS_store="$LDFLAGS"
-- LDFLAGS="$LDFLAGS -pthread"
-+ LDFLAGS="$LDFLAGS %%PTHREAD_LIBS%%"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -30441,14 +30441,14 @@
+- LDFLAGS="$LDFLAGS -pthread -fnested-functions"
++ LDFLAGS="$LDFLAGS %%PTHREAD_LIBS%% -fnested-functions"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -16387,14 +16388,14 @@
;;
- no) echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6
+ no) { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+ $as_echo "no" >&6; }
- DEBUG_FLAGS="-O2 -funroll-loops -fomit-frame-pointer -Wall"
+ DEBUG_FLAGS="-Wall"
ac_ec_debug=no
;;
esac
else
- echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+ $as_echo "no" >&6; }
- DEBUG_FLAGS="-O2 -funroll-loops -fomit-frame-pointer -Wall"
+ DEBUG_FLAGS="-Wall"
ac_ec_debug=no
- fi;
-@@ -30935,7 +30935,7 @@
+ fi
+@@ -16544,7 +16545,7 @@
OLDLDFLAGS="${LDFLAGS}"
OLDLIBS="${LIBS}"
- LDFLAGS="$PCAPLIB"
+ LDFLAGS="$LDFLAGS $PCAPLIB"
LIBS="$LIBS"
-
- echo "$as_me:$LINENO: checking for pcap_datalink_val_to_description in -lpcap" >&5
-@@ -31271,6 +31271,16 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for pcap_datalink_val_to_description in -lwpcap" >&5
+ $as_echo_n "checking for pcap_datalink_val_to_description in -lwpcap... " >&6; }
+@@ -17002,6 +17003,14 @@
@@ -81,22 +92,6 @@
+ HAVE_PCRE_FALSE=
+fi
+
-+
-+
-
ac_ec_pcre=no
-@@ -32817,6 +32827,13 @@
- { { echo "$as_me:$LINENO: error: conditional \"OPENSSL\" was never defined.
- Usually this means the macro was only invoked conditionally." >&5
- echo "$as_me: error: conditional \"OPENSSL\" was never defined.
-+Usually this means the macro was only invoked conditionally." >&2;}
-+ { (exit 1); exit 1; }; }
-+fi
-+if test -z "${HAVE_PCRE_TRUE}" && test -z "${HAVE_PCRE_FALSE}"; then
-+ { { echo "$as_me:$LINENO: error: conditional \"HAVE_PCRE\" was never defined.
-+Usually this means the macro was only invoked conditionally." >&5
-+echo "$as_me: error: conditional \"HAVE_PCRE\" was never defined.
- Usually this means the macro was only invoked conditionally." >&2;}
- { (exit 1); exit 1; }; }
- fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libpcre" >&5
diff --git a/net-mgmt/ettercap/files/patch-share::Makefile.in b/net-mgmt/ettercap/files/patch-share::Makefile.in
deleted file mode 100644
index 02b8e5164a3a..000000000000
--- a/net-mgmt/ettercap/files/patch-share::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- share/Makefile.in.orig Thu Oct 7 21:05:28 2004
-+++ share/Makefile.in Thu Oct 7 21:35:57 2004
-@@ -416,7 +416,7 @@
-
- install-data-am: install-pkgdataDATA
-
--install-exec-am: install-sysconfDATA
-+install-exec-am:
-
- install-info: install-info-am
-
diff --git a/net-mgmt/ettercap/pkg-plist b/net-mgmt/ettercap/pkg-plist
index c15d3577f402..a24cc5793794 100644
--- a/net-mgmt/ettercap/pkg-plist
+++ b/net-mgmt/ettercap/pkg-plist
@@ -4,61 +4,61 @@ bin/etterlog
@unexec if cmp -s %D/etc/etter.conf.sample %D/etc/etter.conf; then rm -f %D/etc/etter.conf; else echo "If permanently deleting this package, %D/etc/etter.conf must be removed manually."; fi
etc/etter.conf.sample
@exec [ -f %B/etter.conf ] || cp %B/%f %B/etter.conf
-%%PLUGINS%%lib/ettercap/ec_arp_cop.la
+%%PLUGINS%%lib/ettercap/ec_arp_cop.a
%%PLUGINS%%lib/ettercap/ec_arp_cop.so
-%%PLUGINS%%lib/ettercap/ec_autoadd.la
+%%PLUGINS%%lib/ettercap/ec_autoadd.a
%%PLUGINS%%lib/ettercap/ec_autoadd.so
-%%PLUGINS%%lib/ettercap/ec_chk_poison.la
+%%PLUGINS%%lib/ettercap/ec_chk_poison.a
%%PLUGINS%%lib/ettercap/ec_chk_poison.so
-%%PLUGINS%%lib/ettercap/ec_dns_spoof.la
+%%PLUGINS%%lib/ettercap/ec_dns_spoof.a
%%PLUGINS%%lib/ettercap/ec_dns_spoof.so
-%%PLUGINS%%lib/ettercap/ec_dos_attack.la
+%%PLUGINS%%lib/ettercap/ec_dos_attack.a
%%PLUGINS%%lib/ettercap/ec_dos_attack.so
-%%PLUGINS%%lib/ettercap/ec_dummy.la
+%%PLUGINS%%lib/ettercap/ec_dummy.a
%%PLUGINS%%lib/ettercap/ec_dummy.so
-%%PLUGINS%%lib/ettercap/ec_find_conn.la
+%%PLUGINS%%lib/ettercap/ec_find_conn.a
%%PLUGINS%%lib/ettercap/ec_find_conn.so
-%%PLUGINS%%lib/ettercap/ec_find_ettercap.la
+%%PLUGINS%%lib/ettercap/ec_find_ettercap.a
%%PLUGINS%%lib/ettercap/ec_find_ettercap.so
-%%PLUGINS%%lib/ettercap/ec_find_ip.la
+%%PLUGINS%%lib/ettercap/ec_find_ip.a
%%PLUGINS%%lib/ettercap/ec_find_ip.so
-%%PLUGINS%%lib/ettercap/ec_finger.la
+%%PLUGINS%%lib/ettercap/ec_finger.a
%%PLUGINS%%lib/ettercap/ec_finger.so
-%%PLUGINS%%lib/ettercap/ec_finger_submit.la
+%%PLUGINS%%lib/ettercap/ec_finger_submit.a
%%PLUGINS%%lib/ettercap/ec_finger_submit.so
-%%PLUGINS%%lib/ettercap/ec_gre_relay.la
+%%PLUGINS%%lib/ettercap/ec_gre_relay.a
%%PLUGINS%%lib/ettercap/ec_gre_relay.so
-%%PLUGINS%%lib/ettercap/ec_gw_discover.la
+%%PLUGINS%%lib/ettercap/ec_gw_discover.a
%%PLUGINS%%lib/ettercap/ec_gw_discover.so
-%%PLUGINS%%lib/ettercap/ec_isolate.la
+%%PLUGINS%%lib/ettercap/ec_isolate.a
%%PLUGINS%%lib/ettercap/ec_isolate.so
-%%PLUGINS%%lib/ettercap/ec_link_type.la
+%%PLUGINS%%lib/ettercap/ec_link_type.a
%%PLUGINS%%lib/ettercap/ec_link_type.so
-%%PLUGINS%%lib/ettercap/ec_pptp_chapms1.la
+%%PLUGINS%%lib/ettercap/ec_pptp_chapms1.a
%%PLUGINS%%lib/ettercap/ec_pptp_chapms1.so
-%%PLUGINS%%lib/ettercap/ec_pptp_clear.la
+%%PLUGINS%%lib/ettercap/ec_pptp_clear.a
%%PLUGINS%%lib/ettercap/ec_pptp_clear.so
-%%PLUGINS%%lib/ettercap/ec_pptp_pap.la
+%%PLUGINS%%lib/ettercap/ec_pptp_pap.a
%%PLUGINS%%lib/ettercap/ec_pptp_pap.so
-%%PLUGINS%%lib/ettercap/ec_pptp_reneg.la
+%%PLUGINS%%lib/ettercap/ec_pptp_reneg.a
%%PLUGINS%%lib/ettercap/ec_pptp_reneg.so
-%%PLUGINS%%lib/ettercap/ec_rand_flood.la
+%%PLUGINS%%lib/ettercap/ec_rand_flood.a
%%PLUGINS%%lib/ettercap/ec_rand_flood.so
-%%PLUGINS%%lib/ettercap/ec_remote_browser.la
+%%PLUGINS%%lib/ettercap/ec_remote_browser.a
%%PLUGINS%%lib/ettercap/ec_remote_browser.so
-%%PLUGINS%%lib/ettercap/ec_reply_arp.la
+%%PLUGINS%%lib/ettercap/ec_reply_arp.a
%%PLUGINS%%lib/ettercap/ec_reply_arp.so
-%%PLUGINS%%lib/ettercap/ec_repoison_arp.la
+%%PLUGINS%%lib/ettercap/ec_repoison_arp.a
%%PLUGINS%%lib/ettercap/ec_repoison_arp.so
-%%PLUGINS%%lib/ettercap/ec_scan_poisoner.la
+%%PLUGINS%%lib/ettercap/ec_scan_poisoner.a
%%PLUGINS%%lib/ettercap/ec_scan_poisoner.so
-%%PLUGINS%%lib/ettercap/ec_search_promisc.la
+%%PLUGINS%%lib/ettercap/ec_search_promisc.a
%%PLUGINS%%lib/ettercap/ec_search_promisc.so
-%%PLUGINS%%lib/ettercap/ec_smb_clear.la
+%%PLUGINS%%lib/ettercap/ec_smb_clear.a
%%PLUGINS%%lib/ettercap/ec_smb_clear.so
-%%PLUGINS%%lib/ettercap/ec_smb_down.la
+%%PLUGINS%%lib/ettercap/ec_smb_down.a
%%PLUGINS%%lib/ettercap/ec_smb_down.so
-%%PLUGINS%%lib/ettercap/ec_stp_mangler.la
+%%PLUGINS%%lib/ettercap/ec_stp_mangler.a
%%PLUGINS%%lib/ettercap/ec_stp_mangler.so
%%PLUGINS%%@dirrm lib/ettercap
%%DATADIR%%/etter.dns
@@ -82,7 +82,7 @@ etc/etter.conf.sample
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.BINARIES
%%PORTDOCS%%%%DOCSDIR%%/README.BUGS
-%%PORTDOCS%%%%DOCSDIR%%/README.CVS
+%%PORTDOCS%%%%DOCSDIR%%/README.GIT
%%PORTDOCS%%%%DOCSDIR%%/README.PLATFORMS
%%PORTDOCS%%%%DOCSDIR%%/THANKS
%%PORTDOCS%%%%DOCSDIR%%/TODO