aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2022-05-25 08:00:39 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2022-05-25 08:08:24 +0000
commit1eeb11e6bf3af20d235313e05dd9bcdedf4ace44 (patch)
treeaffe611db5ba42485297dada167f75149740feb2 /net-mgmt
parent6ace3810ab0bf2a79d24582a6671943fb807374e (diff)
downloadports-1eeb11e6bf3af20d235313e05dd9bcdedf4ace44.tar.gz
ports-1eeb11e6bf3af20d235313e05dd9bcdedf4ace44.zip
net-mgmt/rubygem-oxidized-web: Unbreak with Ruby 3.0
PR: 263470 Reported by: Einar Bjarni Halldórsson <einar@isnic.is> Approved by: Nick Hilliard <nick@foobar.org> (maintainer) MFH: 2022Q2 (cherry picked from commit 027f28dd50081220b9f9b33a85fda8377be5e94a)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/rubygem-oxidized-web/Makefile2
-rw-r--r--net-mgmt/rubygem-oxidized-web/files/patch-lib_oxidized_web.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/rubygem-oxidized-web/Makefile b/net-mgmt/rubygem-oxidized-web/Makefile
index 1d6e660c3118..4291f617c041 100644
--- a/net-mgmt/rubygem-oxidized-web/Makefile
+++ b/net-mgmt/rubygem-oxidized-web/Makefile
@@ -2,7 +2,7 @@
PORTNAME= oxidized-web
PORTVERSION= 0.13.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt rubygems
MASTER_SITES= RG
diff --git a/net-mgmt/rubygem-oxidized-web/files/patch-lib_oxidized_web.rb b/net-mgmt/rubygem-oxidized-web/files/patch-lib_oxidized_web.rb
new file mode 100644
index 000000000000..7547653b6af7
--- /dev/null
+++ b/net-mgmt/rubygem-oxidized-web/files/patch-lib_oxidized_web.rb
@@ -0,0 +1,11 @@
+--- lib/oxidized/web.rb.orig 2022-04-22 14:40:24 UTC
++++ lib/oxidized/web.rb
+@@ -26,7 +26,7 @@ module Oxidized
+
+ def run
+ @thread = Thread.new do
+- Rack::Handler::Puma.run @app, @opts
++ Rack::Handler::Puma.run @app, **@opts
+ exit!
+ end
+ end