aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-06-13 22:57:53 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-06-13 22:57:53 +0000
commit370a89712d4aa379127fd0555d28dd408b076954 (patch)
tree696e4c601b7d1bf1384a74704d0faf239cf1fa29 /net-mgmt
parent71b0a9d1a88c3b887a23bd7f676f121d827ce00d (diff)
downloadports-370a89712d4aa379127fd0555d28dd408b076954.tar.gz
ports-370a89712d4aa379127fd0555d28dd408b076954.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zabbix/Makefile13
-rw-r--r--net-mgmt/zabbix2/Makefile13
2 files changed, 16 insertions, 10 deletions
diff --git a/net-mgmt/zabbix/Makefile b/net-mgmt/zabbix/Makefile
index 012b175458b0..4861802f8ae1 100644
--- a/net-mgmt/zabbix/Makefile
+++ b/net-mgmt/zabbix/Makefile
@@ -28,7 +28,10 @@ USE_GMAKE= yes
USE_PHP= gd snmp sockets pcre bcmath
USE_RC_SUBR= zabbix_server.sh
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-agent --enable-server --with-net-snmp --with-jabber
+CONFIGURE_ARGS= --disable-agent --enable-server \
+ --with-net-snmp=${LOCALBASE}/bin/net-snmp-config \
+ --with-curl=${LOCALBASE}/bin/curl-config \
+ --with-jabber=${LOCALBASE}
MAKE_ARGS= ARCH=freebsd
SUB_FILES= pkg-message
@@ -36,7 +39,7 @@ SUB_FILES= pkg-message
.ifndef WITHOUT_LDAP
USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--with-ldap
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls \
sasl2.2:${PORTSDIR}/security/cyrus-sasl2
.endif
@@ -45,13 +48,13 @@ RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
.ifndef WITHOUT_MYSQL
USE_PHP+= mysql
-CONFIGURE_ARGS+=--with-mysql
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/bin/mysql_config
.elifdef WITH_PGSQL
USE_PHP+= pgsql
-CONFIGURE_ARGS+=--with-pgsql
+CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}/bin/pg_config
.elifdef WITH_SQLITE
USE_PHP+= sqlite
-CONFIGURE_ARGS+=--with-sqlite
+CONFIGURE_ARGS+=--with-sqlite=${LOCALBASE}
.else
IGNORE= zabbix needs a database backend
.endif
diff --git a/net-mgmt/zabbix2/Makefile b/net-mgmt/zabbix2/Makefile
index 012b175458b0..4861802f8ae1 100644
--- a/net-mgmt/zabbix2/Makefile
+++ b/net-mgmt/zabbix2/Makefile
@@ -28,7 +28,10 @@ USE_GMAKE= yes
USE_PHP= gd snmp sockets pcre bcmath
USE_RC_SUBR= zabbix_server.sh
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-agent --enable-server --with-net-snmp --with-jabber
+CONFIGURE_ARGS= --disable-agent --enable-server \
+ --with-net-snmp=${LOCALBASE}/bin/net-snmp-config \
+ --with-curl=${LOCALBASE}/bin/curl-config \
+ --with-jabber=${LOCALBASE}
MAKE_ARGS= ARCH=freebsd
SUB_FILES= pkg-message
@@ -36,7 +39,7 @@ SUB_FILES= pkg-message
.ifndef WITHOUT_LDAP
USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--with-ldap
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls \
sasl2.2:${PORTSDIR}/security/cyrus-sasl2
.endif
@@ -45,13 +48,13 @@ RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
.ifndef WITHOUT_MYSQL
USE_PHP+= mysql
-CONFIGURE_ARGS+=--with-mysql
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/bin/mysql_config
.elifdef WITH_PGSQL
USE_PHP+= pgsql
-CONFIGURE_ARGS+=--with-pgsql
+CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}/bin/pg_config
.elifdef WITH_SQLITE
USE_PHP+= sqlite
-CONFIGURE_ARGS+=--with-sqlite
+CONFIGURE_ARGS+=--with-sqlite=${LOCALBASE}
.else
IGNORE= zabbix needs a database backend
.endif