aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2011-07-04 03:59:48 +0000
committerSahil Tandon <sahil@FreeBSD.org>2011-07-04 03:59:48 +0000
commit5242f58159c2d0f0517de9315c3e73e49464d6e4 (patch)
treeb044afbd7922dba2c3eeeaac3dbc7ede0ddb1356 /net-mgmt
parent601dcfda361d1a4558486d947d89680e9e8dd0cf (diff)
downloadports-5242f58159c2d0f0517de9315c3e73e49464d6e4.tar.gz
ports-5242f58159c2d0f0517de9315c3e73e49464d6e4.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile6
-rw-r--r--net-mgmt/collectd5/Makefile6
2 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index a11522f9d088..d01df047174f 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -29,6 +29,7 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
CURL_XML "Input: CURL XML generic web statistics" Off \
DBI "Input: database abstraction library" Off \
DISK "Input: Disk performance statistics" Off \
+ GCRYPT "Build with libgcrypt" Off \
NUTUPS "Input: NUT UPS daemon" Off \
INTERFACE "Input: Network interfaces (libstatgrab)" On \
MBMON "Input: MBMon" Off \
@@ -222,6 +223,11 @@ CONFIGURE_ARGS+=--disable-disk
PLIST_SUB+= DISK="@comment "
.endif
+.if defined(WITH_GCRYPT)
+CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
+LIB_DEPENDS+= gcrypt.17:${PORTSDIR}/security/libgcrypt
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index a11522f9d088..d01df047174f 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -29,6 +29,7 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
CURL_XML "Input: CURL XML generic web statistics" Off \
DBI "Input: database abstraction library" Off \
DISK "Input: Disk performance statistics" Off \
+ GCRYPT "Build with libgcrypt" Off \
NUTUPS "Input: NUT UPS daemon" Off \
INTERFACE "Input: Network interfaces (libstatgrab)" On \
MBMON "Input: MBMon" Off \
@@ -222,6 +223,11 @@ CONFIGURE_ARGS+=--disable-disk
PLIST_SUB+= DISK="@comment "
.endif
+.if defined(WITH_GCRYPT)
+CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
+LIB_DEPENDS+= gcrypt.17:${PORTSDIR}/security/libgcrypt
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut