aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 03:05:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 03:05:48 +0000
commit5b96d0a9567e649c783ac418d8e2bde2f6adfc22 (patch)
tree8b423bf71fff78a00604f3c63e5c97500c8a780a /net-mgmt
parent3e84456d0e9ec790ccd9350f80ea60af92eb7d68 (diff)
downloadports-5b96d0a9567e649c783ac418d8e2bde2f6adfc22.tar.gz
ports-5b96d0a9567e649c783ac418d8e2bde2f6adfc22.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp-devel/Makefile4
-rw-r--r--net-mgmt/net-snmp/Makefile4
-rw-r--r--net-mgmt/net-snmp4/Makefile4
-rw-r--r--net-mgmt/net-snmp53/Makefile4
-rw-r--r--net-mgmt/sendip/Makefile1
5 files changed, 13 insertions, 4 deletions
diff --git a/net-mgmt/net-snmp-devel/Makefile b/net-mgmt/net-snmp-devel/Makefile
index 613403bd60a0..2e54654d465d 100644
--- a/net-mgmt/net-snmp-devel/Makefile
+++ b/net-mgmt/net-snmp-devel/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= net-snmp
MAINTAINER= kuriyama@FreeBSD.org
+USE_REINPLACE= yes
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -89,7 +90,8 @@ SHLIB_VERSION= 5
PLIST_SUB+= shlib=${SHLIB_VERSION}
post-patch:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ ${WRKSRC}/aclocal.m4
pre-install:
-@[ -f ${STARTUP_FILE} ] && \
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 613403bd60a0..2e54654d465d 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= net-snmp
MAINTAINER= kuriyama@FreeBSD.org
+USE_REINPLACE= yes
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -89,7 +90,8 @@ SHLIB_VERSION= 5
PLIST_SUB+= shlib=${SHLIB_VERSION}
post-patch:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ ${WRKSRC}/aclocal.m4
pre-install:
-@[ -f ${STARTUP_FILE} ] && \
diff --git a/net-mgmt/net-snmp4/Makefile b/net-mgmt/net-snmp4/Makefile
index 2c183f3c5ae5..63af22705d76 100644
--- a/net-mgmt/net-snmp4/Makefile
+++ b/net-mgmt/net-snmp4/Makefile
@@ -18,6 +18,7 @@ MASTER_SITE_SUBDIR= net-snmp
MAINTAINER= kuriyama@FreeBSD.org
USE_AUTOCONF_VER=213
+USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
@@ -69,7 +70,8 @@ SHLIB_VERSION= 4
PLIST_SUB+= shlib=${SHLIB_VERSION}
post-patch:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ ${WRKSRC}/aclocal.m4
post-install:
@( cd ${PREFIX}/bin && strip ${BIN} )
diff --git a/net-mgmt/net-snmp53/Makefile b/net-mgmt/net-snmp53/Makefile
index 613403bd60a0..2e54654d465d 100644
--- a/net-mgmt/net-snmp53/Makefile
+++ b/net-mgmt/net-snmp53/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= net-snmp
MAINTAINER= kuriyama@FreeBSD.org
+USE_REINPLACE= yes
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -89,7 +90,8 @@ SHLIB_VERSION= 5
PLIST_SUB+= shlib=${SHLIB_VERSION}
post-patch:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ ${WRKSRC}/aclocal.m4
pre-install:
-@[ -f ${STARTUP_FILE} ] && \
diff --git a/net-mgmt/sendip/Makefile b/net-mgmt/sendip/Makefile
index 2fc7cba7890c..a71fbdc39edc 100644
--- a/net-mgmt/sendip/Makefile
+++ b/net-mgmt/sendip/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= joseph@randomnetworks.com
USE_GMAKE= yes
USE_REINPLACE= yes
+USE_PERL5= yes
MAN1= sendip.1