aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-10-01 18:52:37 +0000
committerStefan Eßer <se@FreeBSD.org>2020-10-01 18:52:37 +0000
commit96c28738775b02ef197c348c609a61b7d73ec70b (patch)
tree41ea2f30f8d38609bb0a869b5e429f8ffac6614b /net-mgmt
parent4f2717f16dabd756513ffa8723bb064e3da47282 (diff)
downloadports-96c28738775b02ef197c348c609a61b7d73ec70b.tar.gz
ports-96c28738775b02ef197c348c609a61b7d73ec70b.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/mbrowse/Makefile15
-rw-r--r--net-mgmt/mbrowse/files/patch-src_callbacks.c11
2 files changed, 22 insertions, 4 deletions
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
index 84754adc5efe..6531a18b8df1 100644
--- a/net-mgmt/mbrowse/Makefile
+++ b/net-mgmt/mbrowse/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mbrowse
PORTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
@@ -11,14 +12,20 @@ COMMENT= SNMP MIB Browser for X
LICENSE= GPLv2
-LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
+LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libpkg.so:ports-mgmt/pkg
+USES= gnome pkgconfig ssl
+USE_GNOME= cairo gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
-PLIST_FILES= bin/mbrowse
-USES= gnome pkgconfig
-USE_GNOME= gtk20
+
CONFIGURE_ARGS= --with-snmp-prefix=${PREFIX} --with-snmp-type=net
+
CPPFLAGS+= `net-snmp-config --cflags`
LDFLAGS+= `net-snmp-config --libs`
+PLIST_FILES= bin/mbrowse
+
.include <bsd.port.mk>
diff --git a/net-mgmt/mbrowse/files/patch-src_callbacks.c b/net-mgmt/mbrowse/files/patch-src_callbacks.c
new file mode 100644
index 000000000000..73afc7f1af76
--- /dev/null
+++ b/net-mgmt/mbrowse/files/patch-src_callbacks.c
@@ -0,0 +1,11 @@
+--- src/callbacks.c.orig 2010-11-16 10:20:23 UTC
++++ src/callbacks.c
+@@ -28,7 +28,7 @@ extern int delete;
+ extern int context_id;
+ extern int tview;
+
+-struct menu_items bookmark_items[128];
++extern struct menu_items bookmark_items[128];
+ extern int dont_select_damnit;
+ extern int dont_update_entry;
+ static struct tree *mibtree;