aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-01-13 22:18:07 +0000
committerSteve Wills <swills@FreeBSD.org>2013-01-13 22:18:07 +0000
commitae655e5d4af7e69d3921ce2ea5ee85460e18191f (patch)
tree1771dac0febe4c4e3c87b87bc9722067f1c8ab0f /net-mgmt
parent2beedf4aa0bb1adc1f5b9798580264cdf2292f70 (diff)
downloadports-ae655e5d4af7e69d3921ce2ea5ee85460e18191f.tar.gz
ports-ae655e5d4af7e69d3921ce2ea5ee85460e18191f.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd5/Makefile54
-rw-r--r--net-mgmt/collectd5/files/patch-configure.in11
-rw-r--r--net-mgmt/collectd5/files/patch-src__Makefile.am9
-rw-r--r--net-mgmt/collectd5/pkg-plist8
4 files changed, 77 insertions, 5 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index a7215f5b1d8f..f2f6d368557c 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -17,11 +17,13 @@ WANT_GNOME= yes
LATEST_LINK= collectd5
OPTIONS_DEFINE= CGI BIND DEBUG GCRYPT VIRT
-OPTIONS_MULTI= INPUT OUTPUT
-OPTIONS_MULTI_OUTPUT= RRDTOOL RRDCACHED WRITE_GRAPHITE WRITE_HTTP
-OPTIONS_MULTI_INPUT= APACHE APCUPS CURL CURL_JSON CURL_XML DBI DISK \
- GCRYPT NUTUPS INTERFACE MBMON MEMCACHED MYSQL NGINX OPENVPN \
- PDNS PGSQL PING PYTHON ROUTEROS SNMP TOKYOTYRANT XMMS
+OPTIONS_GROUP= INPUT OUTPUT
+OPTIONS_GROUP_OUTPUT= RRDTOOL RRDCACHED WRITE_GRAPHITE WRITE_HTTP NOTIFYEMAIL
+OPTIONS_GROUP_INPUT= APACHE APCUPS CURL CURL_JSON CURL_XML DBI DISK GCRYPT \
+ NUTUPS INTERFACE IPMI MBMON MEMCACHED MYSQL NGINX \
+ OPENVPN PDNS PGSQL PING PYTHON ROUTEROS SNMP TABLE \
+ TOKYOTYRANT VARNISH XMMS
+
OPTIONS_DEFAULT= BIND INTERFACE PING SNMP RRDTOOL RRDCACHED
CGI_DESC= Install collection.cgi (requires RRDTOOL)
@@ -39,9 +41,11 @@ DBI_DESC= database abstraction library
DISK_DESC= Disk performance statistics
NUTUPS_DESC= NUT UPS daemon
INTERFACE_DESC= Network interfaces (libstatgrab)
+IPMI_DESC= IPMI plugin (openipmi)
MBMON_DESC= MBMon
MEMCACHED_DESC= Memcached
MYSQL_DESC= MySQL
+NOTIFYEMAIL_DESC= Email notifications (libesmtp)
NGINX_DESC= Nginx
OPENVPN_DESC= OpenVPN statistics
PDNS_DESC= PowerDNS
@@ -50,7 +54,9 @@ PING_DESC= Network latency (liboping)
PYTHON_DESC= Python plugin
ROUTEROS_DESC= RouterOS plugin
SNMP_DESC= SNMP
+TABLE_DESC= Table plugin
TOKYOTYRANT_DESC= Tokyotyrant database
+VARNISH_DESC= Varnish plugin
XMMS_DESC= XMMS
# OUTPUT
RRDTOOL_DESC= RRDTool
@@ -290,6 +296,26 @@ CONFIGURE_ARGS+=--disable-mysql
PLIST_SUB+= MYSQL="@comment "
.endif
+.if ${PORT_OPTIONS:MIPMI}
+USE_PKGCONFIG= yes
+CONFIGURE_ARGS+=--enable-ipmi
+LIB_DEPENDS+= OpenIPMI:${PORTSDIR}/sysutils/openipmi
+PLIST_SUB+= IPMI=""
+.else
+CONFIGURE_ARGS+=--disable-ipmi
+PLIST_SUB+= IPMI="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MNOTIFYEMAIL}
+LIB_DEPENDS+= esmtp:${PORTSDIR}/mail/libesmtp
+CONFIGURE_ARGS+=--enable-notify_email
+CONFIGURE_ARGS+=--with-libesmtp=${PREFIX}
+PLIST_SUB+= NOTIFYEMAIL=""
+.else
+CONFIGURE_ARGS+=--disable-notify_email
+PLIST_SUB+= NOTIFYEMAIL="@comment "
+.endif
+
.if ${PORT_OPTIONS:MNGINX}
RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
@@ -380,6 +406,14 @@ CONFIGURE_ARGS+=--disable-snmp
PLIST_SUB+= SNMP="@comment "
.endif
+.if ${PORT_OPTIONS:MTABLE}
+CONFIGURE_ARGS+=--enable-table
+PLIST_SUB+= TABLE=""
+.else
+CONFIGURE_ARGS+=--disable-table
+PLIST_SUB+= TABLE="@comment "
+.endif
+
.if ${PORT_OPTIONS:MTOKYOTYRANT}
LIB_DEPENDS+= tokyotyrant:${PORTSDIR}/databases/tokyotyrant
CONFIGURE_ARGS+=--enable-tokyotyrant
@@ -390,6 +424,16 @@ CONFIGURE_ARGS+=--disable-tokyotyrant --without-libtokyotyrant
PLIST_SUB+= TOKYOTYRANT="@comment "
.endif
+.if ${PORT_OPTIONS:MVARNISH}
+LIB_DEPENDS+= varnishapi:${PORTSDIR}/www/varnish
+CONFIGURE_ARGS+=--enable-varnish
+CONFIGURE_ARGS+=--with-libvarnish=${PREFIX}
+PLIST_SUB+= VARNISH=""
+.else
+CONFIGURE_ARGS+=--disable-varnish
+PLIST_SUB+= VARNISH="@comment "
+.endif
+
.if ${PORT_OPTIONS:MVIRT}
CONFIGURE_ARGS+=--enable-libvirt
LIB_DEPENDS+= virt.1000:${PORTSDIR}/devel/libvirt
diff --git a/net-mgmt/collectd5/files/patch-configure.in b/net-mgmt/collectd5/files/patch-configure.in
index f34d0762fed9..5b5252dcf09b 100644
--- a/net-mgmt/collectd5/files/patch-configure.in
+++ b/net-mgmt/collectd5/files/patch-configure.in
@@ -64,6 +64,17 @@
AC_CHECK_FUNC(PyObject_CallFunction,
[with_python="yes"],
+--- configure.in.orig 2013-01-03 17:07:22.000000000 +0000
++++ configure.in 2013-01-03 17:07:58.000000000 +0000
+@@ -4057,7 +4057,7 @@
+ then
+ AC_MSG_NOTICE([Not checking for libvarnish: Manually configured])
+ with_libvarnish_cflags="-I$withval/include"
+- with_libvarnish_libs="-L$withval/lib -lvarnish -lvarnishcompat -lvarnishapi"
++ with_libvarnish_libs="-L$withval/lib/varnish -lvarnish -lvarnishcompat -lvarnishapi"
+ with_libvarnish="yes"
+ fi; fi; fi
+ ],
@@ -4580,6 +4583,12 @@
plugin_zfs_arc="yes"
fi
diff --git a/net-mgmt/collectd5/files/patch-src__Makefile.am b/net-mgmt/collectd5/files/patch-src__Makefile.am
index db1f43092fdd..f9241d5f42b5 100644
--- a/net-mgmt/collectd5/files/patch-src__Makefile.am
+++ b/net-mgmt/collectd5/files/patch-src__Makefile.am
@@ -45,6 +45,15 @@
endif
if BUILD_WITH_LIBDEVINFO
memory_la_LIBADD += -ldevinfo
+@@ -763,7 +763,7 @@
+ pkglib_LTLIBRARIES += notify_email.la
+ notify_email_la_SOURCES = notify_email.c
+ notify_email_la_LDFLAGS = -module -avoid-version
+-notify_email_la_LIBADD = -lesmtp -lssl -lcrypto -lpthread -ldl
++notify_email_la_LIBADD = -lesmtp -lssl -lcrypto -lpthread
+ collectd_LDADD += "-dlopen" notify_email.la
+ collectd_DEPENDENCIES += notify_email.la
+ endif
@@ -1021,7 +1021,7 @@
collectd_LDADD += "-dlopen" swap.la
collectd_DEPENDENCIES += swap.la
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index 70d3b8c495bf..4e9aa4d73b93 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -45,6 +45,8 @@ lib/collectd/filecount.la
lib/collectd/filecount.so
%%INTERFACE%%lib/collectd/interface.la
%%INTERFACE%%lib/collectd/interface.so
+%%IPMI%%lib/collectd/ipmi.la
+%%IPMI%%lib/collectd/ipmi.so
lib/collectd/load.la
lib/collectd/load.so
lib/collectd/logfile.la
@@ -57,6 +59,8 @@ lib/collectd/memory.la
lib/collectd/memory.so
%%MYSQL%%lib/collectd/mysql.la
%%MYSQL%%lib/collectd/mysql.so
+%%NOTIFYEMAIL%%lib/collectd/notify_email.la
+%%NOTIFYEMAIL%%lib/collectd/notify_email.so
%%NGINX%%lib/collectd/nginx.la
%%NGINX%%lib/collectd/nginx.so
lib/collectd/network.la
@@ -97,6 +101,8 @@ lib/collectd/tcpconns.la
lib/collectd/tcpconns.so
lib/collectd/threshold.la
lib/collectd/threshold.so
+%%TABLE%%lib/collectd/table.la
+%%TABLE%%lib/collectd/table.so
%%TOKYOTYRANT%%lib/collectd/tokyotyrant.la
%%TOKYOTYRANT%%lib/collectd/tokyotyrant.so
lib/collectd/unixsock.la
@@ -107,6 +113,8 @@ lib/collectd/users.la
lib/collectd/users.so
lib/collectd/uuid.la
lib/collectd/uuid.so
+%%VARNISH%%lib/collectd/varnish.la
+%%VARNISH%%lib/collectd/varnish.so
%%VIRT%%lib/collectd/libvirt.la
%%VIRT%%lib/collectd/libvirt.so
%%WRITE_GRAPHITE%%lib/collectd/write_graphite.so