aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-09-01 00:29:12 +0000
committerSteve Wills <swills@FreeBSD.org>2018-09-01 00:29:12 +0000
commit4f76c2f04aa8d2035f1792373bd1210aaaa3e4a4 (patch)
tree916b827f549d45551fc5ca73ad78b61422b201d6 /net-mgmt
parentd8ccf484c678f3c2cab09b323dfabc491d7af757 (diff)
downloadports-4f76c2f04aa8d2035f1792373bd1210aaaa3e4a4.tar.gz
ports-4f76c2f04aa8d2035f1792373bd1210aaaa3e4a4.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ocsinventory-agent/Makefile15
-rw-r--r--net-mgmt/ocsinventory-agent/distinfo5
-rw-r--r--net-mgmt/ocsinventory-agent/pkg-plist32
3 files changed, 37 insertions, 15 deletions
diff --git a/net-mgmt/ocsinventory-agent/Makefile b/net-mgmt/ocsinventory-agent/Makefile
index 9125d80310d9..4519d3b94a89 100644
--- a/net-mgmt/ocsinventory-agent/Makefile
+++ b/net-mgmt/ocsinventory-agent/Makefile
@@ -1,13 +1,10 @@
# $FreeBSD$
-PORTNAME= Ocsinventory
-PORTVERSION= 2.1.1
-PORTREVISION= 4
+PORTNAME= ocsinventory
+PORTVERSION= 2.4.2
PORTEPOCH= 1
CATEGORIES= net-mgmt
-MASTER_SITES= http://launchpad.net/ocsinventory-unix-agent/stable-${PORTVERSION:R}/${PORTVERSION}/+download/
-PKGNAMESUFFIX= -Unix-Agent
-DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+PKGNAMESUFFIX= -agent
MAINTAINER= ports@FreeBSD.org
COMMENT= Keep track of the computers configuration and software
@@ -21,11 +18,15 @@ RUN_DEPENDS= lspci:sysutils/pciutils \
p5-XML-Simple>=0:textproc/p5-XML-Simple \
p5-libwww>=0:www/p5-libwww
+GH_PROJECT= UnixAgent
+GH_ACCOUNT= OCSInventory-NG
+GH_TAGNAME= v${PORTVERSION}
+
USES= perl5 shebangfix
SHEBANG_FILES= postinst.pl
+USE_GITHUB= yes
USE_PERL5= configure
CONFIGURE_ENV= PERL_AUTOINSTALL=1
-WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
SUB_FILES= pkg-message
SUB_LIST= SITE_PERL=${PREFIX}/${SITE_PERL_REL}
NO_ARCH= yes
diff --git a/net-mgmt/ocsinventory-agent/distinfo b/net-mgmt/ocsinventory-agent/distinfo
index a017e243ef83..4b1de3bcc7cc 100644
--- a/net-mgmt/ocsinventory-agent/distinfo
+++ b/net-mgmt/ocsinventory-agent/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Ocsinventory-Unix-Agent-2.1.1.tar.gz) = dc321bc23c73c7d2147e80082f993e0c3faaca8195126050b86d9d3da7cc63a3
-SIZE (Ocsinventory-Unix-Agent-2.1.1.tar.gz) = 1851193
+TIMESTAMP = 1535558398
+SHA256 (OCSInventory-NG-UnixAgent-2.4.2-v2.4.2_GH0.tar.gz) = f18dba7e650ed27258653c53956d44417ef09d43d55dbff23a66de26cccd0dd6
+SIZE (OCSInventory-NG-UnixAgent-2.4.2-v2.4.2_GH0.tar.gz) = 1396404
diff --git a/net-mgmt/ocsinventory-agent/pkg-plist b/net-mgmt/ocsinventory-agent/pkg-plist
index a6417223614a..118f4bddaddb 100644
--- a/net-mgmt/ocsinventory-agent/pkg-plist
+++ b/net-mgmt/ocsinventory-agent/pkg-plist
@@ -1,8 +1,4 @@
bin/ocsinventory-agent
-%%PERL5_MAN3%%/Ocsinventory::Agent::Common.3.gz
-%%PERL5_MAN3%%/Ocsinventory::Agent::Modules::Apache::Vhosts::Common.3.gz
-%%PERL5_MAN3%%/Ocsinventory::Agent::Modules::Databases::Oracle::Instances.3.gz
-%%PERL5_MAN3%%/Ocsinventory::Agent::XML::Inventory.3.gz
%%SITE_PERL%%/Ocsinventory/Agent.pm
%%SITE_PERL%%/Ocsinventory/Agent/AccountConfig.pm
%%SITE_PERL%%/Ocsinventory/Agent/AccountInfo.pm
@@ -19,6 +15,7 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Drives.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Hardware.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/IPv4.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/LVM.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Mem.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Memory.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Modems.pm
@@ -45,6 +42,7 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Uptime.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Batteries.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Bios.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Memory.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Ports.pm
@@ -67,6 +65,11 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/Pacman.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/RPM.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Printers/Cups.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Repository.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Repository/BSD.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Repository/CentOS.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Repository/Debian.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Repository/Rhel.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Screen.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Users.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/HPUX.pm
@@ -99,6 +102,8 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/i386/CPU.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/m68k.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/m68k/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/s390x.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/s390x/CPU.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/LSB.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/ArchLinux.pm
@@ -118,22 +123,26 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/NonLSB/VmWare.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Domains.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Drives.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Inputs.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/LVM.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Mem.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Network/IPv4.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Network/IP.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Network/Networks.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Sounds.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/3ware.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/Adaptec.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/FusionIO.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/HP.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/Lsilogic.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/Megacli.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages/ServeRaid.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Sys.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Uptime.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Bios.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Camera.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Controllers.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Domains.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Drives.pm
@@ -147,6 +156,7 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Sound.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Storages.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Uptime.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/UUID.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS/Video.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Bios.pm
@@ -159,12 +169,17 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Memory.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Networks.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Packages.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Ports.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Slots.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Storages.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Users.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Docker.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Jails.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Libvirt.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Lxc.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Parallels.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Qemu.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/SolarisLdoms.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/SolarisZones.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/VirtualBox.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/VmWareDesktop.pm
@@ -172,7 +187,9 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/VmWareWorkstation.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Vmsystem.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Xen.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Xen/XL.pm
%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/Xen/XM.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/Virtualization/XenCitrixServer.pm
%%SITE_PERL%%/Ocsinventory/Agent/Common.pm
%%SITE_PERL%%/Ocsinventory/Agent/Config.pm
%%SITE_PERL%%/Ocsinventory/Agent/Hooks.pm
@@ -182,7 +199,6 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/Agent/Modules/Databases/Oracle/Instances.pm
%%SITE_PERL%%/Ocsinventory/Agent/Modules/Download.pm
%%SITE_PERL%%/Ocsinventory/Agent/Modules/Example.pm
-%%SITE_PERL%%/Ocsinventory/Agent/Modules/Processes.pm
%%SITE_PERL%%/Ocsinventory/Agent/Modules/Snmp.pm
%%SITE_PERL%%/Ocsinventory/Agent/Modules/Snmp/11.pm
%%SITE_PERL%%/Ocsinventory/Agent/Modules/Snmp/231.pm
@@ -215,3 +231,7 @@ bin/ocsinventory-agent
%%SITE_PERL%%/Ocsinventory/LoggerBackend/Syslog.pm
%%SITE_PERL%%/Ocsinventory/Unix/postinst.pl
%%PERL5_MAN1%%/ocsinventory-agent.1.gz
+%%PERL5_MAN3%%/Ocsinventory::Agent::Common.3.gz
+%%PERL5_MAN3%%/Ocsinventory::Agent::Modules::Apache::Vhosts::Common.3.gz
+%%PERL5_MAN3%%/Ocsinventory::Agent::Modules::Databases::Oracle::Instances.3.gz
+%%PERL5_MAN3%%/Ocsinventory::Agent::XML::Inventory.3.gz