aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-17 07:38:15 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-17 07:38:15 +0000
commit15c4a5ecf338d0133b87647ab773c6df26f3ea15 (patch)
tree320f49e86d38a480aace5bd0e27c34d6c8f75c2c /net-mgmt
parenta9836219c62bdf7cdcfc3af658d25ae25aeaeb11 (diff)
downloadports-15c4a5ecf338d0133b87647ab773c6df26f3ea15.tar.gz
ports-15c4a5ecf338d0133b87647ab773c6df26f3ea15.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile4
-rw-r--r--net-mgmt/collectd5/Makefile4
-rw-r--r--net-mgmt/icinga/Makefile5
-rw-r--r--net-mgmt/nagios/Makefile5
-rw-r--r--net-mgmt/nagios4/Makefile5
-rw-r--r--net-mgmt/yaf/Makefile2
6 files changed, 16 insertions, 9 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index ac9f5c3f5f69..49281aa7f5a2 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -12,9 +12,11 @@ COMMENT= Systems & network statistics collection daemon
LICENSE= GPLv2
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USES= gmake libtool
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf autoheader automake libltdl
+USE_AUTOTOOLS= autoconf autoheader automake
WANT_GNOME= yes
OPTIONS_DEFINE= CGI BIND DEBUG GCRYPT LIBVIRT
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 625f44dee35d..b22f2c96d3a2 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -14,9 +14,11 @@ COMMENT= Systems & network statistics collection daemon
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USES= gmake pkgconfig tar:bzip2 libtool
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= aclocal autoconf autoheader automake libltdl libtoolize
+USE_AUTOTOOLS= aclocal autoconf autoheader automake libtoolize
# Only autoconf stage and sigrok plugin need GLIB:
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/glib-2.0.pc:${PORTSDIR}/devel/glib20
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index e01e029955bf..e05b8d4c77b4 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -12,10 +12,11 @@ COMMENT= Enterprise grade open source monitoring system based on Nagios
LICENSE= GPLv2
-LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libgd.so:${PORTSDIR}/graphics/gd
USES= iconv gmake
-USE_AUTOTOOLS= autoconf libltdl
+USE_AUTOTOOLS= autoconf
USE_RC_SUBR= icinga
GNU_CONFIGURE= yes
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 5b3e4336a1e6..f790e02de3c1 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -12,13 +12,14 @@ COMMENT= Powerful network monitoring system
LICENSE= GPLv2
-LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libgd.so:${PORTSDIR}/graphics/gd
PORTSCOUT= limit:^3.
USES= iconv perl5 uidfix
USE_PERL5= build
-USE_AUTOTOOLS= autoconf libltdl
+USE_AUTOTOOLS= autoconf
USE_PHP= yes
USE_RC_SUBR= nagios
diff --git a/net-mgmt/nagios4/Makefile b/net-mgmt/nagios4/Makefile
index 249912435581..ad490ca699c3 100644
--- a/net-mgmt/nagios4/Makefile
+++ b/net-mgmt/nagios4/Makefile
@@ -13,11 +13,12 @@ COMMENT= Powerful network monitoring system
LICENSE= GPLv2
-LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libgd.so:${PORTSDIR}/graphics/gd
USES= gmake iconv perl5 uidfix
USE_PERL5= build
-USE_AUTOTOOLS= autoconf libltdl
+USE_AUTOTOOLS= autoconf
USE_PHP= xml
USE_RC_SUBR= nagios
diff --git a/net-mgmt/yaf/Makefile b/net-mgmt/yaf/Makefile
index fbd569393eea..5cc47429fd27 100644
--- a/net-mgmt/yaf/Makefile
+++ b/net-mgmt/yaf/Makefile
@@ -13,12 +13,12 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfixbuf.so:${PORTSDIR}/net/libfixbuf \
+ libltdl.so:${PORTSDIR}/devel/libltdl \
libpcre.so:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= libtool pathfix perl5 pkgconfig
-USE_AUTOTOOLS= libltdl
USE_GNOME= glib20
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-doxygen-doc --enable-applabel --enable-plugins