aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2008-04-20 17:24:09 +0000
committerStefan Eßer <se@FreeBSD.org>2008-04-20 17:24:09 +0000
commit2066612ac72227369a38bc44da787488791ceb5a (patch)
tree1f9a8ea72733834275e6db732c3528c4e68014cb /net-mgmt
parente866d4fe980de544dd9e24763bd54dfffd26ec49 (diff)
downloadports-2066612ac72227369a38bc44da787488791ceb5a.tar.gz
ports-2066612ac72227369a38bc44da787488791ceb5a.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/argus3/Makefile69
-rw-r--r--net-mgmt/argus3/distinfo3
-rw-r--r--net-mgmt/argus3/files/patch-Makefile.in13
-rw-r--r--net-mgmt/argus3/files/patch-argus_Makefile.in20
-rw-r--r--net-mgmt/argus3/files/patch-common_Makefile.in11
-rw-r--r--net-mgmt/argus3/pkg-descr12
-rw-r--r--net-mgmt/argus3/pkg-plist18
8 files changed, 147 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index f81bed535e28..0fb2e4cdcdc1 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -15,6 +15,7 @@
SUBDIR += argus
SUBDIR += argus-clients
SUBDIR += argus-monitor
+ SUBDIR += argus3
SUBDIR += arpalert
SUBDIR += arpscan
SUBDIR += arpwatch
diff --git a/net-mgmt/argus3/Makefile b/net-mgmt/argus3/Makefile
new file mode 100644
index 000000000000..bb56cac5bfa1
--- /dev/null
+++ b/net-mgmt/argus3/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: argus3
+# Date created: 08 Jul 2006
+# Whom: Stefan Esser <se@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= argus
+PORTVERSION= 3.0.0
+CATEGORIES= net-mgmt security
+MASTER_SITES= http://qosient.com/argus/src/ \
+ ftp://qosient.com/pub/argus/src/
+
+MAINTAINER= se@freebsd.org
+COMMENT= A generic IP network transaction auditing tool
+
+#RUN_DEPENDS= ${LOCALBASE}/bin/ragrep:${PORTSDIR}/net-mgmt/argus3-clients
+
+OPTIONS+= SASL "SASL authentication support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SASL)
+PKGNAMESUFFIX= -sasl
+LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+.endif
+
+USE_BISON= build
+GNU_CONFIGURE= true
+.if defined(WITH_SASL)
+CONFIGURE_ARGS+= --with-sasl=${PREFIX}
+.endif
+
+MAN5= argus.conf.5
+MAN8= argus.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/argus ${PREFIX}/sbin/argus
+# ${INSTALL_SCRIPT} ${WRKSRC}/bin/argusbug ${PREFIX}/bin/argusbug
+ ${MKDIR} ${EXAMPLESDIR}/Archive ${EXAMPLESDIR}/Config \
+ ${EXAMPLESDIR}/Deployment ${EXAMPLESDIR}/Startup \
+ ${EXAMPLESDIR}/System
+.for i in README \
+ Archive/argusarchive \
+ Config/argus.conf \
+ Deployment/sample \
+ Startup/argus Startup/README \
+ System/crontab System/magic
+ ${INSTALL_DATA} ${WRKSRC}/support/$i ${EXAMPLESDIR}/$i
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+.for i in FAQ HOW-TO
+ ${INSTALL_DATA} ${WRKSRC}/doc/$i ${DOCSDIR}/
+.endfor
+.endif
+.if !defined(NOMAN)
+#.for i in ${MAN1}
+# ${INSTALL_DATA} ${WRKSRC}/man/man1/$i ${MANPREFIX}/man/man1
+#.endfor
+.for i in ${MAN5}
+ ${INSTALL_DATA} ${WRKSRC}/man/man5/$i ${MANPREFIX}/man/man5
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_DATA} ${WRKSRC}/man/man8/$i ${MANPREFIX}/man/man8
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/argus3/distinfo b/net-mgmt/argus3/distinfo
new file mode 100644
index 000000000000..c2ee550b0415
--- /dev/null
+++ b/net-mgmt/argus3/distinfo
@@ -0,0 +1,3 @@
+MD5 (argus-3.0.0.tar.gz) = 532dd9d86dacc2b497e24776c2c7eb96
+SHA256 (argus-3.0.0.tar.gz) = c2c40903ed592f045b73ee94e84431e4dcbb5ef9d07c6d967daf16068ed282cf
+SIZE (argus-3.0.0.tar.gz) = 400426
diff --git a/net-mgmt/argus3/files/patch-Makefile.in b/net-mgmt/argus3/files/patch-Makefile.in
new file mode 100644
index 000000000000..dff9eb96ea4d
--- /dev/null
+++ b/net-mgmt/argus3/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in~ 2008-02-05 04:37:42.000000000 +0100
++++ Makefile.in 2008-02-07 10:37:29.349769845 +0100
+@@ -27,8 +27,9 @@
+ INSTALL_DATA = @INSTALL_DATA@
+
+ DEFS = @DEFS@
+-LIBS = @LIBS@
++LIBS = @LIB_SASL@ @LIBS@
+ WRAPLIBS = @WRAPLIBS@
++CPPFLAGS = @SASLFLAGS@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
diff --git a/net-mgmt/argus3/files/patch-argus_Makefile.in b/net-mgmt/argus3/files/patch-argus_Makefile.in
new file mode 100644
index 000000000000..625181a89c66
--- /dev/null
+++ b/net-mgmt/argus3/files/patch-argus_Makefile.in
@@ -0,0 +1,20 @@
+--- argus/Makefile.in~ 2008-02-05 04:37:42.000000000 +0100
++++ argus/Makefile.in 2008-02-07 10:39:11.099545848 +0100
+@@ -41,7 +41,7 @@
+
+ CC = @CC@
+ CCOPT = @V_CCOPT@
+-INCLS = -I$(srcdir) @V_INCLS@ -I$(srcdir)/../include
++INCLS = -I$(srcdir) @V_INCLS@ -I$(srcdir)/../include @SASLFLAGS@
+ DEFS = @DEFS@ -DARGUS_SYSLOG=1
+ #DEFS = -DARGUSPERFMETRICS=1 @DEFS@
+
+@@ -79,7 +79,7 @@
+
+ OBJ = $(SRC:.c=.o)
+
+-LIB = @LIBS@ $(WRAPLIBS) $(COMPATLIB) ../lib/argus_common.a -lm
++LIB = @LIBS@ @LIB_SASL@ $(WRAPLIBS) $(COMPATLIB) ../lib/argus_common.a -lm
+
+ HDR = pcap.h pcap-int.h pcap-namedb.h pcap-nit.h pcap-pf.h \
+ ethertype.h gencode.h gnuc.h
diff --git a/net-mgmt/argus3/files/patch-common_Makefile.in b/net-mgmt/argus3/files/patch-common_Makefile.in
new file mode 100644
index 000000000000..2952f1819410
--- /dev/null
+++ b/net-mgmt/argus3/files/patch-common_Makefile.in
@@ -0,0 +1,11 @@
+--- common/Makefile.in~ 2008-02-05 04:37:42.000000000 +0100
++++ common/Makefile.in 2008-02-06 18:11:34.685979351 +0100
+@@ -32,7 +32,7 @@
+
+ CC = @CC@
+ CCOPT = @V_CCOPT@
+-INCLS = -I$(srcdir) @V_INCLS@ -I$(srcdir)/../include -I$(srcdir)/../argus
++INCLS = -I$(srcdir) @V_INCLS@ -I$(srcdir)/../include -I$(srcdir)/../argus @SASLFLAGS@
+ DEFS = @DEFS@ -DARGUS_SYSLOG=1
+
+ # Standard CFLAGS
diff --git a/net-mgmt/argus3/pkg-descr b/net-mgmt/argus3/pkg-descr
new file mode 100644
index 000000000000..afc582b1d8f7
--- /dev/null
+++ b/net-mgmt/argus3/pkg-descr
@@ -0,0 +1,12 @@
+Argus is a generic IP network transaction auditing tool that has been used
+by thousands of sites to perform a number of powerful network management
+tasks that are currently not possible using commercial network management
+tools.
+
+Argus runs as an application level daemon, promiscuously reading network
+datagrams from a specified interface, and generates network traffic audit
+records for the network activity that it encounters. It is the way that
+Argus categorizes and reports on network activity that makes this tool
+unique and powerful.
+
+WWW: http://www.qosient.com/argus/
diff --git a/net-mgmt/argus3/pkg-plist b/net-mgmt/argus3/pkg-plist
new file mode 100644
index 000000000000..c1a8ac8818f7
--- /dev/null
+++ b/net-mgmt/argus3/pkg-plist
@@ -0,0 +1,18 @@
+sbin/argus
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/HOW-TO
+%%EXAMPLESDIR%%/Archive/argusarchive
+%%EXAMPLESDIR%%/Config/argus.conf
+%%EXAMPLESDIR%%/Deployment/sample
+%%EXAMPLESDIR%%/Startup/argus
+%%EXAMPLESDIR%%/Startup/README
+%%EXAMPLESDIR%%/System/crontab
+%%EXAMPLESDIR%%/System/magic
+%%EXAMPLESDIR%%/README
+@dirrmtry %%EXAMPLESDIR%%/Archive
+@dirrmtry %%EXAMPLESDIR%%/Config
+@dirrmtry %%EXAMPLESDIR%%/Deployment
+@dirrmtry %%EXAMPLESDIR%%/Startup
+@dirrmtry %%EXAMPLESDIR%%/System
+@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%