aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-01-05 07:53:50 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-01-05 07:53:50 +0000
commit7d251bdc51b395a7e647bc14aaab07bf9e97060c (patch)
tree8b6ee47539dde0f988a99e6f1832714f48f91309 /net-mgmt
parentf40e13cbaa2229d9c73bfbb3042839d1b81f560f (diff)
downloadports-7d251bdc51b395a7e647bc14aaab07bf9e97060c.tar.gz
ports-7d251bdc51b395a7e647bc14aaab07bf9e97060c.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/argus3-clients/Makefile83
-rw-r--r--net-mgmt/argus3-clients/distinfo4
-rw-r--r--net-mgmt/argus3-clients/files/patch-clients_Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-common_Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-common_argus_util.c12
-rw-r--r--net-mgmt/argus3-clients/files/patch-radium_Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-radump_Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-ramysql_Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/files/patch-ratop_Makefile.in11
-rw-r--r--net-mgmt/argus3-clients/pkg-descr6
-rw-r--r--net-mgmt/argus3-clients/pkg-plist33
11 files changed, 82 insertions, 122 deletions
diff --git a/net-mgmt/argus3-clients/Makefile b/net-mgmt/argus3-clients/Makefile
index a9396afd6f8a..be51177f2776 100644
--- a/net-mgmt/argus3-clients/Makefile
+++ b/net-mgmt/argus3-clients/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: argus3-clients
-# Date created: 24 March 2004
-# Whom: Stefan Esser <se@FreeBSD.org>
-#
+# Created by: Stefan Esser <se@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= argus-clients
-PORTVERSION= 3.0.4.1
-PORTREVISION= 1
+PORTVERSION= 3.0.6.2
CATEGORIES= net-mgmt security
MASTER_SITES= http://qosient.com/argus/src/ \
ftp://qosient.com/pub/argus/src/
@@ -15,65 +10,73 @@ MASTER_SITES= http://qosient.com/argus/src/ \
MAINTAINER= pauls@utdallas.edu
COMMENT= Client programs for the argus IP network transaction auditing tool
+LICENSE= GPLv3
+
CONFLICTS= argus-clients-2* argus-clients-sasl-2*
-OPTIONS+= SASL "SASL authentication support" on \
- MYSQL "MySQL database support" on \
- GEOIP "GeoIP library support" off
+OPTIONS_DEFINE= GEOIP MANPAGES MYSQL SASL
+OPTIONS_DEFAULT=MANPAGES MYSQL SASL
.include <bsd.port.options.mk>
USE_BISON= build
GNU_CONFIGURE= true
USE_NCURSES= yes
+USE_PERL5= yes
-.if defined(WITH_SASL)
-PKGNAMESUFFIX= -sasl
+.if ${PORT_OPTIONS:MSASL}
+PKGNAMESUFFIX+= -sasl
LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
PLIST_SUB+= MYSQL=""
+MAN1+= rasql.1 rasqlinsert.1 rasqltimeindex.1
.else
PLIST_SUB+= MYSQL="@comment "
.endif
-.if defined(WITH_GEOIP)
+.if ${PORT_OPTIONS:MGEOIP}
LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
-CONFIGURE_ARGS+= --with-GeoIP=${LOCALBASE}
+CONFIGURE_ARGS+= --with-GeoIP=${LOCALBASE}
.endif
-MAN1= ra.1 rabins.1 racluster.1 racount.1 ragraph.1 rahisto.1 \
- ranonymize.1 rasort.1 rasplit.1 rastream.1 rastrip.1
-MAN5= racluster.5 radium.conf.5 rarc.5
+MAN1+= ra.1 rabins.1 racluster.1 raconvert.1 racount.1 radump.1 raevent.1 \
+ rafilteraddr.1 ragraph.1 ragrep.1 rahisto.1 ralabel.1 ranonymize.1 \
+ rapath.1 rapolicy.1 rasort.1 rasplit.1 rastream.1 rastrip.1
+MAN5= racluster.5 radium.conf.5 ralabel.conf.5 ranonymize.5 rarc.5
MAN8= radium.8
-.include <bsd.port.pre.mk>
-
do-install:
-.for i in ra rabins racluster racount radump rafilteraddr \
- rahisto ralabel ranonymize rapath rapolicy \
- raservices rasort rasplit rastream \
- rastrip ratemplate ratimerange ratop ratree rauserdata
+.for i in ra rabins racluster raconvert racount radium radump raevent \
+ rafilteraddr ragrep rahisto ralabel ranonymize rapath rapolicy \
+ rarpwatch raservices rasort rasplit rastream rastrip \
+ ratemplate ratimerange ratop rauserdata
${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
.endfor
-.if defined(WITH_MYSQL)
-.for i in rasql rasqlinsert
+
+.for i in argusclientbug radark ragraph rahosts raips raplot raports
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
+.endfor
+
+.if ${PORT_OPTIONS:MMYSQL}
+.for i in rasql rasqlinsert rasqltimeindex
${INSTALL_PROGRAM} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
.endfor
.endif
.for i in radark ragraph rahosts raports
${INSTALL_SCRIPT} ${WRKSRC}/bin/$i ${PREFIX}/bin/$i
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
-.for i in README COPYING doc/CHANGES doc/FAQ doc/HOW-TO
+.for i in AUTHORS CHANGES CREDITS ChangeLog INSTALL \
+ MANIFEST README VERSION
${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
.endfor
.endif
-.if !defined(NOMAN)
+.if ${PORT_OPTIONS:MMANPAGES}
.for i in ${MAN1}
${INSTALL_DATA} ${WRKSRC}/man/man1/$i ${MANPREFIX}/man/man1
.endfor
@@ -85,9 +88,25 @@ do-install:
.endfor
.endif
${MKDIR} ${EXAMPLESDIR}
-.for i in Config Startup System
+.for i in Config Database Startup System
${MKDIR} ${EXAMPLESDIR}/$i
- ${INSTALL_DATA} ${WRKSRC}/support/$i/* ${EXAMPLESDIR}/$i
.endfor
-.include <bsd.port.post.mk>
+.for i in delegated-ipv4-latest excel.rc iana-address-file \
+ iana-ipv4-address iana-multicast-address iana-port-numbers \
+ racluster.conf radium.conf ragetcountrycodes.sh ralabel.conf \
+ ranonymize.conf rarc rarc.print.all.conf rastream.sh std.sig \
+ wireshark.manuf.txt
+ ${INSTALL_DATA} ${WRKSRC}/support/Config/$i ${EXAMPLESDIR}/Config/$i
+.endfor
+.for i in MySQL.Archive.sh README
+ ${INSTALL_DATA} ${WRKSRC}/support/Database/$i ${EXAMPLESDIR}/Database/$i
+.endfor
+.for i in README com.qosient.radium.plist com.qosient.rasplit.plist \
+ radium radium.service rasplit
+ ${INSTALL_DATA} ${WRKSRC}/support/Startup/$i ${EXAMPLESDIR}/Startup/$i
+.endfor
+.for i in magic
+ ${INSTALL_DATA} ${WRKSRC}/support/System/$i ${EXAMPLESDIR}/System/$i
+.endfor
+.include <bsd.port.mk>
diff --git a/net-mgmt/argus3-clients/distinfo b/net-mgmt/argus3-clients/distinfo
index e846f4309537..ff55b076058c 100644
--- a/net-mgmt/argus3-clients/distinfo
+++ b/net-mgmt/argus3-clients/distinfo
@@ -1,2 +1,2 @@
-SHA256 (argus-clients-3.0.4.1.tar.gz) = c56cb81cc9a898f638cacd9973b43fd01e0dcca3b8c7fcaa8b8c5d0456b8b581
-SIZE (argus-clients-3.0.4.1.tar.gz) = 2116531
+SHA256 (argus-clients-3.0.6.2.tar.gz) = f51d7c8d18fa2236f3fe3726deb3c0b8308c0a6ca767c6089811963da95330fc
+SIZE (argus-clients-3.0.6.2.tar.gz) = 2426454
diff --git a/net-mgmt/argus3-clients/files/patch-clients_Makefile.in b/net-mgmt/argus3-clients/files/patch-clients_Makefile.in
deleted file mode 100644
index c22136b2c923..000000000000
--- a/net-mgmt/argus3-clients/files/patch-clients_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- clients/Makefile.in~ 2008-02-05 04:37:43.000000000 +0100
-+++ clients/Makefile.in 2008-02-07 11:32:41.576020693 +0100
-@@ -45,7 +45,7 @@
-
- CC = @CC@
- CCOPT = @V_CCOPT@
--INCLS = -I. -I../include -I../common @V_INCLS@
-+INCLS = -I. -I../include -I../common @V_INCLS@ @SASLFLAGS@
- DEFS = @DEFS@
- COMPATLIB = @COMPATLIB@ @LIB_SASL@ @LIBS@ @V_THREADS@
-
diff --git a/net-mgmt/argus3-clients/files/patch-common_Makefile.in b/net-mgmt/argus3-clients/files/patch-common_Makefile.in
deleted file mode 100644
index efb48995864d..000000000000
--- a/net-mgmt/argus3-clients/files/patch-common_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- common/Makefile.in~ 2008-02-05 04:37:43.000000000 +0100
-+++ common/Makefile.in 2008-02-07 11:32:41.580020066 +0100
-@@ -40,7 +40,7 @@
-
- CC = @CC@
- CCOPT = @V_CCOPT@
--INCLS = -I. -I../include @V_INCLS@ @MYSQL_INCLS@
-+INCLS = -I. -I../include @V_INCLS@ @MYSQL_INCLS@ @SASLFLAGS@
- DEFS = @DEFS@ -DARGUS_SYSLOG
-
- # Standard CFLAGS
diff --git a/net-mgmt/argus3-clients/files/patch-common_argus_util.c b/net-mgmt/argus3-clients/files/patch-common_argus_util.c
deleted file mode 100644
index c9fe888242e7..000000000000
--- a/net-mgmt/argus3-clients/files/patch-common_argus_util.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- common/argus_util.c~ 2008-02-05 04:37:43.000000000 +0100
-+++ common/argus_util.c 2008-02-07 11:32:41.604018124 +0100
-@@ -100,6 +100,9 @@
- #ifndef AF_INET6
- #define AF_INET6 23
- #endif
-+#if defined(__FreeBSD__) /* should work for NetBSD too */
-+#include <sys/limits.h>
-+#endif
-
-
- #ifndef INET6_ADDRSTRLEN
diff --git a/net-mgmt/argus3-clients/files/patch-radium_Makefile.in b/net-mgmt/argus3-clients/files/patch-radium_Makefile.in
deleted file mode 100644
index b4aff807f68e..000000000000
--- a/net-mgmt/argus3-clients/files/patch-radium_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- radium/Makefile.in~ 2008-02-05 04:37:43.000000000 +0100
-+++ radium/Makefile.in 2008-02-07 11:32:41.610018616 +0100
-@@ -44,7 +44,7 @@
-
- CC = @CC@
- CCOPT = @V_CCOPT@
--INCLS = -I. -I../include -I../common @V_INCLS@
-+INCLS = -I. -I../include -I../common @V_INCLS@ @SASLFLAGS@
- DEFS = @DEFS@
- COMPATLIB = @COMPATLIB@ @LIB_SASL@ @LIBS@ @V_THREADS@
-
diff --git a/net-mgmt/argus3-clients/files/patch-radump_Makefile.in b/net-mgmt/argus3-clients/files/patch-radump_Makefile.in
deleted file mode 100644
index fe94348d5f75..000000000000
--- a/net-mgmt/argus3-clients/files/patch-radump_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- radump/Makefile.in.orig 2010-02-04 17:27:44.000000000 +0300
-+++ radump/Makefile.in 2010-02-04 17:28:00.000000000 +0300
-@@ -50,7 +50,7 @@
-
- CC = @CC@
- CCOPT = @V_CCOPT@
--INCLS = -I. -I../include -I../common @V_INCLS@
-+INCLS = -I. -I../include -I../common @V_INCLS@ @SASLFLAGS@
- DEFS = @DEFS@
- COMPATLIB = @COMPATLIB@ @LIB_SASL@ @LIBS@ @V_THREADS@ @V_GEOIPDEP@
-
diff --git a/net-mgmt/argus3-clients/files/patch-ramysql_Makefile.in b/net-mgmt/argus3-clients/files/patch-ramysql_Makefile.in
deleted file mode 100644
index 54063f569363..000000000000
--- a/net-mgmt/argus3-clients/files/patch-ramysql_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ramysql/Makefile.in.orig 2010-02-04 17:34:38.000000000 +0300
-+++ ramysql/Makefile.in 2010-02-04 17:34:50.000000000 +0300
-@@ -50,7 +50,7 @@
-
- CC = @CC@
- CCOPT = @V_CCOPT@
--INCLS = @INCLS@ -I. -I../include -I../common @V_INCLS@ @MYSQL_INCLS@
-+INCLS = @INCLS@ -I. -I../include -I../common @V_INCLS@ @MYSQL_INCLS@ @SASLFLAGS@
- DEFS = @DEFS@
- COMPATLIB = @COMPATLIB@ @LIB_SASL@ @LIBS@ @V_THREADS@ @V_GEOIPDEP@
-
diff --git a/net-mgmt/argus3-clients/files/patch-ratop_Makefile.in b/net-mgmt/argus3-clients/files/patch-ratop_Makefile.in
deleted file mode 100644
index 0b65b3223685..000000000000
--- a/net-mgmt/argus3-clients/files/patch-ratop_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ratop/Makefile.in~ 2008-02-28 23:00:36.000000000 +0100
-+++ ratop/Makefile.in 2008-04-18 12:03:41.737798597 +0200
-@@ -50,7 +50,7 @@
-
- CC = @CC@
- CCOPT = @V_CCOPT@
--INCLS = @INCLS@ -I. -I../include -I../common @V_INCLS@
-+INCLS = @INCLS@ -I. -I../include -I../common @V_INCLS@ @SASLFLAGS@
- DEFS = @DEFS@
- COMPATLIB = @LIBS@ @COMPATLIB@ @LIB_SASL@ @V_THREADS@
- CURSESLIB = @CURSESLIB@
diff --git a/net-mgmt/argus3-clients/pkg-descr b/net-mgmt/argus3-clients/pkg-descr
index 80e8053dee96..b2cd60f5c8d2 100644
--- a/net-mgmt/argus3-clients/pkg-descr
+++ b/net-mgmt/argus3-clients/pkg-descr
@@ -1,9 +1,9 @@
Client programs that read, parse and process Argus data, and comprise
the client part of the Audit Record Generation and Utilization System.
-Argus is a generic IP network transaction auditing tool that has been used
-by thousands of sites to perform a number of powerful network management
-tasks that are currently not possible using commercial network management
+Argus is a generic IP network transaction auditing tool that has been used
+by thousands of sites to perform a number of powerful network management
+tasks that are currently not possible using commercial network management
tools.
Argus runs as an application level daemon, promiscuously reading network
diff --git a/net-mgmt/argus3-clients/pkg-plist b/net-mgmt/argus3-clients/pkg-plist
index 5cf381c2dab1..c42b408613cd 100644
--- a/net-mgmt/argus3-clients/pkg-plist
+++ b/net-mgmt/argus3-clients/pkg-plist
@@ -1,55 +1,74 @@
+bin/argusclientbug
bin/ra
bin/rabins
bin/racluster
+bin/raconvert
bin/racount
bin/radark
+bin/radium
bin/radump
+bin/raevent
bin/rafilteraddr
bin/ragraph
+bin/ragrep
bin/rahisto
bin/rahosts
+bin/raips
bin/ralabel
bin/ranonymize
bin/rapath
+bin/raplot
bin/rapolicy
bin/raports
+bin/rarpwatch
bin/raservices
bin/rasort
bin/rasplit
%%MYSQL%%bin/rasql
%%MYSQL%%bin/rasqlinsert
+%%MYSQL%%bin/rasqltimeindex
bin/rastream
bin/rastrip
bin/ratemplate
bin/ratimerange
bin/ratop
-bin/ratree
bin/rauserdata
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/HOW-TO
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/MANIFEST
%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/VERSION
%%EXAMPLESDIR%%/Config/delegated-ipv4-latest
%%EXAMPLESDIR%%/Config/excel.rc
%%EXAMPLESDIR%%/Config/iana-address-file
%%EXAMPLESDIR%%/Config/iana-ipv4-address
%%EXAMPLESDIR%%/Config/iana-multicast-address
%%EXAMPLESDIR%%/Config/iana-port-numbers
-%%EXAMPLESDIR%%/Config/ra.print.all.conf
%%EXAMPLESDIR%%/Config/racluster.conf
%%EXAMPLESDIR%%/Config/radium.conf
%%EXAMPLESDIR%%/Config/ragetcountrycodes.sh
%%EXAMPLESDIR%%/Config/ralabel.conf
%%EXAMPLESDIR%%/Config/ranonymize.conf
%%EXAMPLESDIR%%/Config/rarc
+%%EXAMPLESDIR%%/Config/rarc.print.all.conf
%%EXAMPLESDIR%%/Config/rastream.sh
%%EXAMPLESDIR%%/Config/std.sig
+%%EXAMPLESDIR%%/Config/wireshark.manuf.txt
+%%EXAMPLESDIR%%/Database/MySQL.Archive.sh
+%%EXAMPLESDIR%%/Database/README
+%%EXAMPLESDIR%%/Startup/README
+%%EXAMPLESDIR%%/Startup/com.qosient.radium.plist
+%%EXAMPLESDIR%%/Startup/com.qosient.rasplit.plist
%%EXAMPLESDIR%%/Startup/radium
+%%EXAMPLESDIR%%/Startup/radium.service
+%%EXAMPLESDIR%%/Startup/rasplit
%%EXAMPLESDIR%%/System/magic
-%%EXAMPLESDIR%%/System/protocols
@dirrm %%EXAMPLESDIR%%/System
@dirrm %%EXAMPLESDIR%%/Startup
+@dirrm %%EXAMPLESDIR%%/Database
@dirrm %%EXAMPLESDIR%%/Config
@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%