aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-25 21:39:49 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-25 21:39:49 +0000
commit406b4e65f3dcb6e970f30adfc9a57d1e7ec99858 (patch)
tree684c71ff83053ab9b3150470db29e02ed62d540d /net-mgmt
parente87fdaa949286b607fc4f427459fd40395ad31d4 (diff)
downloadports-406b4e65f3dcb6e970f30adfc9a57d1e7ec99858.tar.gz
ports-406b4e65f3dcb6e970f30adfc9a57d1e7ec99858.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/chillispot/Makefile10
-rw-r--r--net-mgmt/chillispot/files/patch-src_chilli.c55
-rw-r--r--net-mgmt/chillispot/files/patch-src_dhcp.c16
-rw-r--r--net-mgmt/chillispot/files/patch-src_redir.c21
-rw-r--r--net-mgmt/chillispot/files/patch-src_syserr.c18
5 files changed, 116 insertions, 4 deletions
diff --git a/net-mgmt/chillispot/Makefile b/net-mgmt/chillispot/Makefile
index 5812122933c3..87afd6d35e13 100644
--- a/net-mgmt/chillispot/Makefile
+++ b/net-mgmt/chillispot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= chillispot
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.chillispot.org/download/ \
http://www.geeklan.co.uk/files/ \
@@ -16,14 +17,15 @@ MAINTAINER= venture37@geeklan.co.uk
COMMENT= Wireless LAN Access Point Controller
GNU_CONFIGURE= yes
+USE_GETOPT_LONG=yes
CONFIGURE_TARGET=-build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS=-sysconfdir=${PREFIX}/etc
-MAN8= chilli.8
+MAN8= chilli.8
OPTIONS= RAW "Latest Release Of Apache & mySQL" Off \
- MATURE "Stable Releases of Apache & mySQL" Off \
- FREE "freeRADIUS" Off \
- OPENR "openradius" Off
+ MATURE "Stable Releases of Apache & mySQL" Off \
+ FREE "freeRADIUS" Off \
+ OPENR "openradius" Off
.include <bsd.port.pre.mk>
diff --git a/net-mgmt/chillispot/files/patch-src_chilli.c b/net-mgmt/chillispot/files/patch-src_chilli.c
new file mode 100644
index 000000000000..73d35189294b
--- /dev/null
+++ b/net-mgmt/chillispot/files/patch-src_chilli.c
@@ -0,0 +1,55 @@
+--- src/chilli.c.orig Mon Dec 26 08:06:46 2005
++++ src/chilli.c Mon Dec 26 08:10:01 2005
+@@ -14,13 +14,14 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+-#include <sys/socket.h>
+ #include <net/if.h>
+ #include <errno.h>
+-#include <sys/types.h>
+
+ #if defined(__linux__)
+ #include <asm/types.h>
+@@ -460,13 +461,13 @@
+ memset(options.uamokmask, 0, sizeof(options.uamokmask));
+ options.uamoknetlen = 0;
+ for (numargs = 0; numargs < args_info.uamallowed_given; ++numargs) {
++ char *p1 = NULL;
++ char *p2 = NULL;
++ char *p3 = malloc(strlen(args_info.uamallowed_arg[numargs])+1);
+ if (options.debug & DEBUG_CONF) {
+ printf ("Uamallowed #%d: %s\n",
+ numargs, args_info.uamallowed_arg[numargs]);
+ }
+- char *p1 = NULL;
+- char *p2 = NULL;
+- char *p3 = malloc(strlen(args_info.uamallowed_arg[numargs])+1);
+ strcpy(p3, args_info.uamallowed_arg[numargs]);
+ p1 = p3;
+ if ((p2 = strchr(p1, ','))) {
+@@ -766,14 +767,14 @@
+ memset(options.macok, 0, sizeof(options.macok));
+ options.macoklen = 0;
+ for (numargs = 0; numargs < args_info.macallowed_given; ++numargs) {
+- if (options.debug & DEBUG_CONF) {
+- printf ("Macallowed #%d: %s\n", numargs,
+- args_info.macallowed_arg[numargs]);
+- }
+ char *p1 = NULL;
+ char *p2 = NULL;
+ char *p3 = malloc(strlen(args_info.macallowed_arg[numargs])+1);
+ int i;
++ if (options.debug & DEBUG_CONF) {
++ printf ("Macallowed #%d: %s\n", numargs,
++ args_info.macallowed_arg[numargs]);
++ }
+ strcpy(p3, args_info.macallowed_arg[numargs]);
+ p1 = p3;
+ if ((p2 = strchr(p1, ','))) {
diff --git a/net-mgmt/chillispot/files/patch-src_dhcp.c b/net-mgmt/chillispot/files/patch-src_dhcp.c
new file mode 100644
index 000000000000..8236ad0e6c18
--- /dev/null
+++ b/net-mgmt/chillispot/files/patch-src_dhcp.c
@@ -0,0 +1,16 @@
+--- src/dhcp.c.orig Mon Dec 26 08:22:52 2005
++++ src/dhcp.c Mon Dec 26 08:29:56 2005
+@@ -37,9 +37,12 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#if __FreeBSD_version > 500000
+ #include <stdint.h> /* ISO C99 types */
+-#include <arpa/inet.h>
++#endif
++#include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+
+ #if defined(__linux__)
+ #include <linux/if.h>
diff --git a/net-mgmt/chillispot/files/patch-src_redir.c b/net-mgmt/chillispot/files/patch-src_redir.c
new file mode 100644
index 000000000000..2be7e7d045fc
--- /dev/null
+++ b/net-mgmt/chillispot/files/patch-src_redir.c
@@ -0,0 +1,21 @@
+--- src/redir.c.orig Mon Dec 26 08:13:05 2005
++++ src/redir.c Mon Dec 26 08:22:35 2005
+@@ -9,15 +9,15 @@
+ *
+ */
+
+-#include <sys/socket.h>
+-#include <netinet/in.h>
+-
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <syslog.h>
+ #include <errno.h>
+ #include <stdarg.h>
+
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <string.h>
+ #include <fcntl.h>
diff --git a/net-mgmt/chillispot/files/patch-src_syserr.c b/net-mgmt/chillispot/files/patch-src_syserr.c
new file mode 100644
index 000000000000..68554a861250
--- /dev/null
+++ b/net-mgmt/chillispot/files/patch-src_syserr.c
@@ -0,0 +1,18 @@
+--- src/syserr.c.orig Mon Dec 26 08:30:20 2005
++++ src/syserr.c Mon Dec 26 08:30:46 2005
+@@ -10,13 +10,13 @@
+ */
+
+ #include <stdarg.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <stdio.h>
+ #include <syslog.h>
+ #include <string.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+
+ #include "syserr.h"
+