aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
commit654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /net-mgmt
parent3dc362ac88ab73d6f0b3635628a59d9597e6da4e (diff)
downloadports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.tar.gz
ports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/dhcp_probe/Makefile20
-rw-r--r--net-mgmt/dhcp_probe/files/patch-Makefile.am9
-rw-r--r--net-mgmt/ettercap/Makefile4
-rw-r--r--net-mgmt/isic/Makefile8
-rw-r--r--net-mgmt/isic/files/patch-isic.h10
-rw-r--r--net-mgmt/packit/Makefile9
-rw-r--r--net-mgmt/pixilate/Makefile7
7 files changed, 15 insertions, 52 deletions
diff --git a/net-mgmt/dhcp_probe/Makefile b/net-mgmt/dhcp_probe/Makefile
index c2038eb435dc..8958f22d2f50 100644
--- a/net-mgmt/dhcp_probe/Makefile
+++ b/net-mgmt/dhcp_probe/Makefile
@@ -3,38 +3,32 @@
PORTNAME= dhcp_probe
PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.net.princeton.edu/software/dhcp_probe/
MAINTAINER= khung@nullaxiom.com
COMMENT= Attempts to discover DHCP and BootP servers on a network
-LICENSE= GPLv2 addl
+LICENSE= GPLv2 LGPL20 addl
LICENSE_COMB= multi
+LICENSE_FILE_GPLv2=${WRKSRC}/COPYING.GPL
+LICENSE_FILE_LGPL20=${WRKSRC}/COPYING.LIB
LICENSE_NAME_addl=Additional legal notices for copyrighted code
LICENSE_FILE_addl=${WRKSRC}/COPYING
LICENSE_PERMS_addl=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
-USE_AUTOTOOLS= aclocal automake
-AUTOMAKE_ARGS= -a
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libnet-include=${LOCALBASE}/include/libnet11/ --with-libnet-lib=${LOCALBASE}/lib/libnet11/
-MANPREFIX= ${PREFIX}
+INSTALL_TARGET= install-strip
USE_RC_SUBR= dhcp_probe
SUB_FILES= pkg-message
-# Put additional licenses in DOCS
-PORTDOCS= COPYING*
-
-# Can't use INSTALL_PROGRAM macro as we need to patch Makefile.am and
-# regenerate Makefile.in
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/dhcp_probe
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/COPYING* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/extras/dhcp_probe.cf.sample \
+ ${STAGEDIR}${PREFIX}/etc
.include <bsd.port.mk>
diff --git a/net-mgmt/dhcp_probe/files/patch-Makefile.am b/net-mgmt/dhcp_probe/files/patch-Makefile.am
deleted file mode 100644
index 6c57481c8088..000000000000
--- a/net-mgmt/dhcp_probe/files/patch-Makefile.am
+++ /dev/null
@@ -1,9 +0,0 @@
---- Makefile.am.orig 2015-01-28 01:27:58.000000000 -0500
-+++ Makefile.am 2015-01-28 01:38:40.000000000 -0500
-@@ -25,3 +25,6 @@
- extras/README
-
- ACLOCAL_AMFLAGS = -I m4
-+
-+## Copy sample configuration file to PREFIX/etc/
-+sysconf_DATA= extras/dhcp_probe.cf.sample
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index 4627297ed288..ba3f0e744452 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -27,11 +27,11 @@ CMAKE_ARGS= -DBUNDLED_LIBS=OFF \
-DHAVE_DLOPEN=ON \
-DHAVE_PCAP=${LIBDIR} \
-DHAVE_RESOLV=${LIBDIR} \
- -DHAVE_LIBNET=${LOCALBASE}/lib/libnet11 \
+ -DHAVE_LIBNET=${LOCALBASE}/lib \
-DINSTALL_SYSCONFDIR=${PREFIX}/etc \
-DMAN_INSTALLDIR=${PREFIX}/man
CMAKE_VERBOSE= yes
-LDFLAGS+= -L${LIBDIR} -L${LOCALBASE}/lib/libnet11 ${ICONV_LIB} -lnet -lpcap
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB} -lnet -lpcap
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
USES= bison cmake:outsource cpe iconv localbase pkgconfig
diff --git a/net-mgmt/isic/Makefile b/net-mgmt/isic/Makefile
index 13363644a647..9aee4030d9db 100644
--- a/net-mgmt/isic/Makefile
+++ b/net-mgmt/isic/Makefile
@@ -17,12 +17,4 @@ LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
USES= tar:tgz
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.mk>
diff --git a/net-mgmt/isic/files/patch-isic.h b/net-mgmt/isic/files/patch-isic.h
index 45c6b4f3b406..93d2d2d7dc68 100644
--- a/net-mgmt/isic/files/patch-isic.h
+++ b/net-mgmt/isic/files/patch-isic.h
@@ -1,10 +1,8 @@
---- isic.h.orig 2006-12-16 01:08:44.000000000 +0100
-+++ isic.h 2014-08-11 16:25:34.551003726 +0200
-@@ -5,11 +5,15 @@
- #endif
+--- isic.h.orig 2006-12-16 00:08:44 UTC
++++ isic.h
+@@ -6,10 +6,13 @@
#include <libnet.h>
-+#include <libnet/libnet-headers.h>
+#include <netinet/ip.h>
#include <netinet/ip_icmp.h>
@@ -16,7 +14,7 @@
#ifndef ETHER_FRAME_SIZE
#define ETHER_FRAME_SIZE 1500
-@@ -21,11 +25,6 @@
+@@ -21,11 +24,6 @@
#define IP6_FRAGH 8
#define ICMP6_H 8
diff --git a/net-mgmt/packit/Makefile b/net-mgmt/packit/Makefile
index 59c364cd464a..fc5df9d877b9 100644
--- a/net-mgmt/packit/Makefile
+++ b/net-mgmt/packit/Makefile
@@ -14,13 +14,12 @@ COMMENT= Network auditing tool
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CPPFLAGS+= `${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= sbin/packit \
man/man8/packit.8.gz
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
.if defined(WITHOUT_CAPTURE)
CONFIGURE_ARGS+= --without-capture
.endif
@@ -28,8 +27,4 @@ CONFIGURE_ARGS+= --without-capture
CONFIGURE_ARGS+= --without-injection
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
.include <bsd.port.mk>
diff --git a/net-mgmt/pixilate/Makefile b/net-mgmt/pixilate/Makefile
index ff18107b999b..e023e9d7d724 100644
--- a/net-mgmt/pixilate/Makefile
+++ b/net-mgmt/pixilate/Makefile
@@ -23,18 +23,11 @@ GNU_CONFIGURE= yes
PORTDOCS= README
PLIST_FILES= bin/pixilate man/man1/pixilate.1.gz
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
OPTIONS_DEFINE= DOCS
post-patch:
@cd ${WRKSRC} && ${RM} -f INSTALL install-sh missing mkinstalldirs
- @${REINPLACE_CMD} -e \
- 's|libnet-config|${LIBNET_CONFIG}|; \
- s|--defines`|& `${LIBNET_CONFIG} --cflags`|' \
- ${WRKSRC}/configure.ac
-
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}