aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-24 20:51:05 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-24 20:51:05 +0000
commite0f3464addd653ff48b6876cbdc1d924567f23b7 (patch)
tree9fcae667f870f306e2e48eb0030f2056d3be72ee /net-mgmt
parent2affcf4fcf15057f185eca229a4b6e202d7c69cc (diff)
downloadports-e0f3464addd653ff48b6876cbdc1d924567f23b7.tar.gz
ports-e0f3464addd653ff48b6876cbdc1d924567f23b7.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp4/Makefile2
-rw-r--r--net-mgmt/net-snmp4/files/patch-hr_storage.c24
2 files changed, 19 insertions, 7 deletions
diff --git a/net-mgmt/net-snmp4/Makefile b/net-mgmt/net-snmp4/Makefile
index 5896669db34b..90e937b4056c 100644
--- a/net-mgmt/net-snmp4/Makefile
+++ b/net-mgmt/net-snmp4/Makefile
@@ -15,7 +15,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.win.ne.jp/pub/network/snmp/ucd-snmp/
MASTER_SITE_SUBDIR= net-snmp
-MAINTAINER= marcus@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= An extendable SNMP implementation
USE_AUTOCONF_VER=213
diff --git a/net-mgmt/net-snmp4/files/patch-hr_storage.c b/net-mgmt/net-snmp4/files/patch-hr_storage.c
index 1dfe804c9c4b..c13901e23fcd 100644
--- a/net-mgmt/net-snmp4/files/patch-hr_storage.c
+++ b/net-mgmt/net-snmp4/files/patch-hr_storage.c
@@ -1,5 +1,5 @@
---- agent/mibgroup/host/hr_storage.c.orig Mon Mar 18 22:39:56 2002
-+++ agent/mibgroup/host/hr_storage.c Sun Nov 17 00:43:32 2002
+--- agent/mibgroup/host/hr_storage.c.orig Thu Jul 4 09:00:11 2002
++++ agent/mibgroup/host/hr_storage.c Thu Jun 24 16:47:34 2004
@@ -32,7 +32,7 @@
#else
#if HAVE_VM_VM_H
@@ -9,7 +9,7 @@
#include <machine/types.h>
#endif
#if HAVE_SYS_VMMETER_H
-@@ -145,7 +145,7 @@
+@@ -148,7 +148,7 @@
#define HRFS_mount mnt_mountp
#define HRFS_statfs statvfs
@@ -18,7 +18,7 @@
extern struct mntent *HRFS_entry;
extern int fscount;
-@@ -520,7 +520,7 @@
+@@ -553,7 +553,7 @@
}
case HRSTORE_UNITS:
if ( store_idx < HRS_TYPE_FS_MAX )
@@ -27,7 +27,7 @@
long_return = stat_buf.f_frsize;
#else
long_return = stat_buf.f_bsize;
-@@ -601,7 +601,15 @@
+@@ -634,7 +634,15 @@
for (i = 0; i < sizeof(mbstat.m_mtypes)/sizeof(mbstat.m_mtypes[0]); i++)
long_return += mbstat.m_mtypes[i];
#elif defined(MBSTAT_SYMBOL)
@@ -43,7 +43,7 @@
#elif defined(NO_DUMMY_VALUES)
return NULL;
#else
-@@ -660,7 +668,15 @@
+@@ -693,7 +701,15 @@
+ (mclpool.pr_nget - mclpool.pr_nput)
* mclpool.pr_size;
#elif defined(MBSTAT_SYMBOL)
@@ -59,3 +59,15 @@
#elif defined(NO_DUMMY_VALUES)
return NULL;
#else
+@@ -723,7 +739,11 @@
+ #if !defined(linux) && !defined(solaris2) && !defined(hpux10) && !defined(hpux11)
+ case HRS_TYPE_MBUF:
+ #if defined(MBSTAT_SYMBOL)
++#if defined(__FreeBSD__) && __FreeBSD_version >= 502113
++ long_return = mbstat.m_mcfail + mbstat.m_mpfail;
++#else
+ long_return = mbstat.m_drops;
++#endif
+ #elif defined(NO_DUMMY_VALUES)
+ return NULL;
+ #else