aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-01-25 21:48:40 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-01-25 21:48:40 +0000
commitf4286e533a2951591bb996fd8feb489328d4a985 (patch)
tree6ba63fab56f1ce2ca8eab95377d1e99e4ab0d261 /net-mgmt
parent1b129408424d2b5f1c68e02a06802373dfa5f25d (diff)
downloadports-f4286e533a2951591bb996fd8feb489328d4a985.tar.gz
ports-f4286e533a2951591bb996fd8feb489328d4a985.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/kismet/Makefile57
-rw-r--r--net-mgmt/kismet/pkg-plist2
2 files changed, 35 insertions, 24 deletions
diff --git a/net-mgmt/kismet/Makefile b/net-mgmt/kismet/Makefile
index df21e8a84aa9..634760854456 100644
--- a/net-mgmt/kismet/Makefile
+++ b/net-mgmt/kismet/Makefile
@@ -16,43 +16,52 @@ COMMENT= 802.11 layer2 wireless network detector, sniffer, and IDS
GNU_CONFIGURE= yes
USE_GMAKE= yes
-
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS+= --enable-syspcap
-.ifdef DISABLE_CURSES
-CONFIGURE_ARGS+= --disable-curses
+OPTIONS= CURSES "libcurses interface" on \
+ PANEL "libpanels interface" on \
+ SETUID "Install kismet with setuid" on \
+ GPSMAP "Build gpsmap utility" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_CURSES)
+CONFIGURE_ARGS+=--disable-curses
.endif
-.ifdef DISABLE_PANEL
-CONFIGURE_ARGS+= --disable-panel
+.if defined(WITHOUT_PANEL)
+CONFIGURE_ARGS+=--disable-panel
.endif
-.ifdef DISABLE_SETUID
-CONFIGURE_ARGS+= --disable-setuid
+.if defined(WITHOUT_SETUID)
+CONFIGURE_ARGS+=--disable-setuid
.endif
-MAN1= kismet.1 kismet_drone.1
-MAN5= kismet.conf.5 kismet_drone.conf.5 kismet_ui.conf.5
+.if defined(WITHOUT_GPSMAP)
+CONFIGURE_ARGS+=--disable-gpsmap
+PLIST_SUB+= GPS="@comment "
+.else
+PLIST_SUB+= GPS=""
+LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4 \
+ expat.5:${PORTSDIR}/textproc/expat2 \
+ Magick++.9:${PORTSDIR}/graphics/ImageMagick
+BUILD_DEPENDS+= wget:${PORTSDIR}/ftp/wget
+RUN_DEPENDS+= wget:${PORTSDIR}/ftp/wget
+.endif
-.include <bsd.port.pre.mk>
+MAN1= kismet.1 kismet_drone.1 gpsmap.1
+MAN5= kismet.conf.5 kismet_drone.conf.5 kismet_ui.conf.5
.if ${OSVERSION} < 502000
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
+CONFIGURE_ARGS+= --disable-pcap
.endif
-pre-fetch:
- @${ECHO_MSG} ""
-.ifndef DISABLE_CURSES
- @${ECHO_MSG} " define DISABLE_CURSES to build without ncurses interface"
-.endif
-.ifndef DISABLE_PANEL
- @${ECHO_MSG} " define DISABLE_PANEL to build without libpanel interface"
-.endif
-.ifndef DISABLE_SETUID
- @${ECHO_MSG} " define DISABLE_SETUID to disable setuid/privdrop ability (not reccomended)"
-.endif
- @${ECHO_MSG} ""
- @${TRUE}
+post-extract:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${WRKSRC}/conf/kismet.conf ${PREFIX}/etc/kismet.conf.sample
diff --git a/net-mgmt/kismet/pkg-plist b/net-mgmt/kismet/pkg-plist
index 42a87d895888..78c1a2bac559 100644
--- a/net-mgmt/kismet/pkg-plist
+++ b/net-mgmt/kismet/pkg-plist
@@ -2,6 +2,8 @@ bin/kismet
bin/kismet_client
bin/kismet_drone
bin/kismet_server
+%%GPS%%bin/gpsmap
+%%GPS%%bin/gpsmap-helper-earthamaps
etc/ap_manuf
etc/client_manuf
@unexec if cmp -s %D/etc/kismet.conf %D/etc/kismet.conf.sample; then rm -f %D/etc/kismet.conf; fi