aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-03-03 16:19:04 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-03-03 16:19:04 +0000
commit5c73f7efd09e0cac8af629d5c288ec95a235c80d (patch)
tree847f9b84d108cc0eeddd46c10865a5055d76aea5 /net-mgmt
parent4716cc38e63a33c64b709d511987d453509f1eb3 (diff)
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-nxapi-plumbing/Makefile27
-rw-r--r--net-mgmt/py-nxapi-plumbing/distinfo3
-rw-r--r--net-mgmt/py-nxapi-plumbing/pkg-descr6
4 files changed, 37 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 540baf140498..5482f9dee222 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -309,6 +309,7 @@
SUBDIR += py-napalm
SUBDIR += py-napalm-logs
SUBDIR += py-ncclient
+ SUBDIR += py-nxapi-plumbing
SUBDIR += py-pdagent
SUBDIR += py-prometheus-client
SUBDIR += py-pyIOSXR
diff --git a/net-mgmt/py-nxapi-plumbing/Makefile b/net-mgmt/py-nxapi-plumbing/Makefile
new file mode 100644
index 000000000000..cbd2e388edc8
--- /dev/null
+++ b/net-mgmt/py-nxapi-plumbing/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= nxapi-plumbing
+DISTVERSION= 0.5.2
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:C/-/_/}-${DISTVERSION}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Manage Cisco devices through NX-API using XML/JSON-RPC
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scp>=0:security/py-scp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.7.0:www/py-requests@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-nxapi-plumbing/distinfo b/net-mgmt/py-nxapi-plumbing/distinfo
new file mode 100644
index 000000000000..720e192151b3
--- /dev/null
+++ b/net-mgmt/py-nxapi-plumbing/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1550785809
+SHA256 (nxapi_plumbing-0.5.2.tar.gz) = 6f54f9983f023bd75b60acd907ff47f559541cc2b98f4fa638b8585ca0de0fb5
+SIZE (nxapi_plumbing-0.5.2.tar.gz) = 11540
diff --git a/net-mgmt/py-nxapi-plumbing/pkg-descr b/net-mgmt/py-nxapi-plumbing/pkg-descr
new file mode 100644
index 000000000000..69ace1224a77
--- /dev/null
+++ b/net-mgmt/py-nxapi-plumbing/pkg-descr
@@ -0,0 +1,6 @@
+Low-level library for managing Cisco devices through NX-API using JSON-RPC and
+XML.
+
+It's the successor of net-mgmt/py-pynxos with a more open license.
+
+WWW: https://github.com/ktbyers/nxapi-plumbing