aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:43:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:43:19 +0000
commit635a8597ada076f1cb83f8079dc920803369dbd2 (patch)
treed78da119f3b4c68274caf15b8d9cfb94a15a2a8c /net-mgmt
parent66332bd6ad90456b55b21441983c21690ae0646e (diff)
downloadports-635a8597ada076f1cb83f8079dc920803369dbd2.tar.gz
ports-635a8597ada076f1cb83f8079dc920803369dbd2.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagiosgraph/Makefile51
-rw-r--r--net-mgmt/nagiosgraph/distinfo6
-rw-r--r--net-mgmt/nagiosgraph/files/patch-etc-nagiosgraph.conf.in54
-rw-r--r--net-mgmt/nagiosgraph/pkg-plist52
4 files changed, 119 insertions, 44 deletions
diff --git a/net-mgmt/nagiosgraph/Makefile b/net-mgmt/nagiosgraph/Makefile
index 97c7f91e4259..d3c01a94f5ef 100644
--- a/net-mgmt/nagiosgraph/Makefile
+++ b/net-mgmt/nagiosgraph/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nagiosgraph
-PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTVERSION= 1.4.1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -21,50 +20,62 @@ USE_PERL5_RUN= yes
NO_BUILD= yes
PORTDOCS= AUTHORS CHANGELOG INSTALL README README.map TODO
-
-PLIST_SUB= NAGIOSWWWDIR=${NAGIOSWWWDIR}
-
NAGIOSWWWDIR?= www/nagios
+CGIFILES= show.cgi showgraph.cgi showhost.cgi showservice.cgi testcolor.cgi showgroup.cgi
+LIBFILES= insert.pl
+CFGFILES= nagiosgraph.conf servdb.conf groupdb.conf hostdb.conf map
+
+PLIST_SUB= NAGIOSWWWDIR=${NAGIOSWWWDIR} PORTNAME=${PORTNAME}
post-patch:
-.for i in lib/insert.pl cgi/show.cgi cgi/showgraph.cgi cgi/showhost.cgi cgi/showservice.cgi cgi/testcolor.cgi
+ ${REINPLACE_CMD} -e 's!%%PREFIX%%!${PREFIX}!' ${WRKSRC}/etc/nagiosgraph.conf
+.for i in ${CGIFILES}
${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' -e 's!/usr/local!${PREFIX}!g' \
- -e 's!/etc/nagios/!/usr/local/etc/nagios/!g' ${WRKSRC}/$i
+ -e 's!/opt/nagiosgraph/etc!${PREFIX}/etc/nagios/nagiosgraph!g' ${WRKSRC}/cgi/$i
.endfor
-do-install:
- ${MKDIR} ${PREFIX}/etc/nagios/nagiosgraph
+.for i in ${LIBFILES}
+ ${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' -e 's!/usr/local!${PREFIX}!g' \
+ -e 's!/opt/nagiosgraph/etc!${PREFIX}/etc/nagios/nagiosgraph!g' ${WRKSRC}/lib/$i
+.endfor
- ${INSTALL_DATA} ${WRKSRC}/etc/ngshared.pm ${PREFIX}/etc/nagios/nagiosgraph/ngshared.pm
+do-install:
+ ${MKDIR} ${PREFIX}/etc/nagios/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/etc/ngshared.pm ${PREFIX}/etc/nagios/${PORTNAME}/ngshared.pm
-.for i in hostdb.conf map nagiosgraph.conf servdb.conf
- ${INSTALL_DATA} ${WRKSRC}/etc/$i ${PREFIX}/etc/nagios/nagiosgraph/${i}.example
+.for i in ${CFGFILES}
+ ${INSTALL_DATA} ${WRKSRC}/etc/$i ${PREFIX}/etc/nagios/${PORTNAME}/${i}.sample
+ [ -f ${PREFIX}/etc/nagios/${PORTNAME}/${i} ] || ${CP} -p ${PREFIX}/etc/nagios/${PORTNAME}/${i}.sample ${PREFIX}/etc/nagios/${PORTNAME}/${i}
.endfor
${MKDIR} ${PREFIX}/libexec/${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKSRC}/lib/insert.pl ${PREFIX}/libexec/${PORTNAME}
+.for i in ${LIBFILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/lib/${i} ${PREFIX}/libexec/${PORTNAME}
+.endfor
- ${MKDIR} ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/nagiosgraph
-.for i in cgi/show.cgi cgi/showgraph.cgi cgi/showhost.cgi cgi/showservice.cgi cgi/testcolor.cgi
- ${INSTALL_SCRIPT} ${WRKSRC}/$i ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/nagiosgraph
+ ${MKDIR} ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/${PORTNAME}
+.for i in ${CGIFILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/cgi/$i ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/${PORTNAME}/
.endfor
- ${MKDIR} ${PREFIX}/${NAGIOSWWWDIR}/stylesheets
-.for i in share/action.gif share/nagiosgraph.css share/nagiosgraph.js
+.for i in share/nagiosgraph.css share/nagiosgraph.js
${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/${NAGIOSWWWDIR}/stylesheets
.endfor
+ ${MV} ${PREFIX}/${NAGIOSWWWDIR}/images/action.gif ${PREFIX}/${NAGIOSWWWDIR}/images/action.gif.bak
+ ${INSTALL_DATA} ${WRKSRC}/share/action.gif ${PREFIX}/${NAGIOSWWWDIR}/images/action.gif
+
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
.for i in utils/authz.pl utils/testentry.pl utils/upgrade.pl
- ${INSTALL_SCRIPT} ${WRKSRC}/$i ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/$i ${EXAMPLESDIR}/
.endfor
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
. for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
. endfor
.endif
diff --git a/net-mgmt/nagiosgraph/distinfo b/net-mgmt/nagiosgraph/distinfo
index ba0560db9505..a4e5a202b10c 100644
--- a/net-mgmt/nagiosgraph/distinfo
+++ b/net-mgmt/nagiosgraph/distinfo
@@ -1,3 +1,3 @@
-MD5 (nagiosgraph-1.4.0.tar.gz) = d7bece0637df1ab2e94463d2c575b3e3
-SHA256 (nagiosgraph-1.4.0.tar.gz) = 1cb8b77d269201f271d18e4739ea12d927d8e5bf63449ace71c17e07a23f5fb6
-SIZE (nagiosgraph-1.4.0.tar.gz) = 61820
+MD5 (nagiosgraph-1.4.1.tar.gz) = 4b9d7d81d1e6f3c1cabc2a76c6d8fd3e
+SHA256 (nagiosgraph-1.4.1.tar.gz) = 078ec882758e3a56fb2705494e72f38ca9232658d1e7c3d7c3c7afd1f66c6b49
+SIZE (nagiosgraph-1.4.1.tar.gz) = 79340
diff --git a/net-mgmt/nagiosgraph/files/patch-etc-nagiosgraph.conf.in b/net-mgmt/nagiosgraph/files/patch-etc-nagiosgraph.conf.in
new file mode 100644
index 000000000000..50008528084e
--- /dev/null
+++ b/net-mgmt/nagiosgraph/files/patch-etc-nagiosgraph.conf.in
@@ -0,0 +1,54 @@
+--- etc/nagiosgraph.conf.orig 2010-03-05 10:24:25.000000000 +0000
++++ etc/nagiosgraph.conf 2010-03-05 10:44:53.000000000 +0000
+@@ -8,41 +8,41 @@
+ # Author: (c) 2010 Matthew Wall
+
+ # Location of nagiosgraph log file. Debug output ends up here.
+-logfile = /var/log/nagiosgraph.log
++logfile = /var/spool/nagios/nagiosgraph.log
+
+ # Location of nagios performance data log file. Comment out if not used.
+-perflog = /var/nagios/perfdata.log
++perflog = /var/spool/nagios/perfdata.log
+
+ # Directory to store rrd database files
+-rrddir = /var/nagiosgraph/rrd
++rrddir = /var/spool/nagios/rrd
+
+ # File containing regular expressions to identify service and perf data
+-mapfile = /etc/nagiosgraph/map
++mapfile = %%PREFIX%%/etc/nagios/nagiosgraph/map
+
+ # Location of showhost control file
+-hostdb = /etc/nagiosgraph/hostdb.conf
++hostdb = %%PREFIX%%/etc/nagios/nagiosgraph/hostdb.conf
+
+ # Location of showservice control file
+-servdb = /etc/nagiosgraph/servdb.conf
++servdb = %%PREFIX%%/etc/nagios/nagiosgraph/servdb.conf
+
+ # Location of showgroup control file
+-groupdb = /etc/nagiosgraph/groupdb.conf
++groupdb = %%PREFIX%%/etc/nagios/nagiosgraph/groupdb.conf
+
+ # File containing data sets that should be selected in service queries.
+ #datasetdb = /opt/nagiosgraph/etc/datasetdb.conf
+
+ # Nagiosgraph CGI URL.
+-nagiosgraphcgiurl = /nagiosgraph/cgi-bin
++nagiosgraphcgiurl = /nagios/cgi-bin/nagiosgraph
+
+ # Nagios CGI URL. If the Nagiosgraph CGI scripts are in a directory other
+ # than the Nagios CGI directory, then specify the Nagios CGI URL here.
+ #nagioscgiurl = /nagios/cgi-bin
+
+ # JavaScript: URL to the nagiosgraph javascript file.
+-javascript = /nagiosgraph/nagiosgraph.js
++javascript = /nagios/stylesheets/nagiosgraph.js
+
+ # Stylesheet: URL to the nagiosgraph stylesheet. Comment out if not used.
+-stylesheet = /nagiosgraph/nagiosgraph.css
++stylesheet = /nagios/stylesheets/nagiosgraph.css
+
+
+ # Debug can be enabled for a specific CGI script and/or specific hosts or
diff --git a/net-mgmt/nagiosgraph/pkg-plist b/net-mgmt/nagiosgraph/pkg-plist
index 9027c4a5eec2..b31a7405a070 100644
--- a/net-mgmt/nagiosgraph/pkg-plist
+++ b/net-mgmt/nagiosgraph/pkg-plist
@@ -1,25 +1,35 @@
-etc/nagios/nagiosgraph/hostdb.conf.example
-etc/nagios/nagiosgraph/map.example
-etc/nagios/nagiosgraph/nagiosgraph.conf.example
-etc/nagios/nagiosgraph/ngshared.pm
-etc/nagios/nagiosgraph/servdb.conf.example
-libexec/nagiosgraph/insert.pl
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/groupdb.conf.sample %D/etc/nagios/%%PORTNAME%%/groupdb.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/groupdb.conf; fi
+etc/nagios/%%PORTNAME%%/groupdb.conf.sample
+@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/groupdb.conf ] ; then cp -p %D/%F %B/groupdb.conf; fi
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/hostdb.conf.sample %D/etc/nagios/%%PORTNAME%%/hostdb.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/hostdb.conf; fi
+etc/nagios/%%PORTNAME%%/hostdb.conf.sample
+@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/hostdb.conf ] ; then cp -p %D/%F %B/hostdb.conf; fi
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/map.sample %D/etc/nagios/%%PORTNAME%%/map; then rm -f %D/etc/nagios/%%PORTNAME%%/map; fi
+etc/nagios/%%PORTNAME%%/map.sample
+@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/map ] ; then cp -p %D/%F %B/map; fi
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/nagiosgraph.conf.sample %D/etc/nagios/%%PORTNAME%%/nagiosgraph.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph.conf; fi
+etc/nagios/%%PORTNAME%%/nagiosgraph.conf.sample
+@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph.conf ] ; then cp -p %D/%F %B/nagiosgraph.conf; fi
+etc/nagios/%%PORTNAME%%/ngshared.pm
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/servdb.conf.sample %D/etc/nagios/%%PORTNAME%%/servdb.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/servdb.conf; fi
+etc/nagios/%%PORTNAME%%/servdb.conf.sample
+@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/servdb.conf ] ; then cp -p %D/%F %B/servdb.conf; fi
+libexec/%%PORTNAME%%/insert.pl
+%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/show.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/showgraph.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/showgroup.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/showhost.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/showservice.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/testcolor.cgi
+@exec mv %D/%%NAGIOSWWWDIR%%%/images/action.gif %D/%%NAGIOSWWWDIR%%/images/action.gif.bak
+%%NAGIOSWWWDIR%%/images/action.gif
+@unexec mv %D/%%NAGIOSWWWDIR%%%/images/action.gif.bak %D/%%NAGIOSWWWDIR%%/images/action.gif
+%%NAGIOSWWWDIR%%/stylesheets/%%PORTNAME%%.css
+%%NAGIOSWWWDIR%%/stylesheets/%%PORTNAME%%.js
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/authz.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testentry.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upgrade.pl
-%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/show.cgi
-%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/showgraph.cgi
-%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/showhost.cgi
-%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/showservice.cgi
-%%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph/testcolor.cgi
-%%NAGIOSWWWDIR%%/stylesheets/action.gif
-%%NAGIOSWWWDIR%%/stylesheets/nagiosgraph.css
-%%NAGIOSWWWDIR%%/stylesheets/nagiosgraph.js
-@dirrmtry %%NAGIOSWWWDIR%%/stylesheets
-@dirrm %%NAGIOSWWWDIR%%/cgi-bin/nagiosgraph
-@dirrmtry %%NAGIOSWWWDIR%%/cgi-bin
-@dirrmtry %%NAGIOSWWWDIR%%
-@dirrm libexec/nagiosgraph
-@dirrm etc/nagios/nagiosgraph
-@dirrmtry etc/nagios
+@dirrm libexec/%%PORTNAME%%
+@dirrmtry %%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%
+@dirrmtry etc/nagios/%%PORTNAME%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%