aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2018-04-01 13:21:57 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2018-04-01 13:21:57 +0000
commit69ae9ca17c7750f2123380448270e5f5a9adb761 (patch)
treef93e4fc26c5f0e7af9a82858ac88a810c225fef1 /net-mgmt
parent0f6c1869f12e0d62e28981bf3ce7606bf0022a1b (diff)
downloadports-69ae9ca17c7750f2123380448270e5f5a9adb761.tar.gz
ports-69ae9ca17c7750f2123380448270e5f5a9adb761.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ng_ipacct/Makefile9
-rw-r--r--net-mgmt/ng_ipacct/distinfo5
-rw-r--r--net-mgmt/ng_ipacct/files/patch-ipacctctl_Makefile15
-rw-r--r--net-mgmt/ng_ipacct/files/patch-ng_ipacct.c25
4 files changed, 10 insertions, 44 deletions
diff --git a/net-mgmt/ng_ipacct/Makefile b/net-mgmt/ng_ipacct/Makefile
index 53062f70a293..9333ae301eec 100644
--- a/net-mgmt/ng_ipacct/Makefile
+++ b/net-mgmt/ng_ipacct/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ng_ipacct
-PORTVERSION= 20150304
+PORTVERSION= 20180401
CATEGORIES= net-mgmt
MAINTAINER= vsevolod@FreeBSD.org
@@ -19,7 +19,8 @@ USES= kmod uidfix
GH_ACCOUNT= vstakhov
-MAKE_ENV= BINDIR="${PREFIX}/sbin"
+MAKE_ARGS+= OSVERSION=${OSVERSION}
+MAKE_ENV+= BINDIR="${PREFIX}/sbin"
USE_RC_SUBR= ng_ipacct
SUB_FILES= pkg-message
@@ -34,4 +35,8 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/ng_ipacct.conf \
${STAGEDIR}${PREFIX}/etc/ng_ipacct.conf.sample
+OPTIONS_DEFINE= VIMAGE
+VIMAGE_DESC= VIMAGE virtual networking support
+VIMAGE_CFLAGS= -DVIMAGE
+
.include <bsd.port.mk>
diff --git a/net-mgmt/ng_ipacct/distinfo b/net-mgmt/ng_ipacct/distinfo
index 531d97226f4c..31e4b7c7468d 100644
--- a/net-mgmt/ng_ipacct/distinfo
+++ b/net-mgmt/ng_ipacct/distinfo
@@ -1,2 +1,3 @@
-SHA256 (vstakhov-ng_ipacct-20150304_GH0.tar.gz) = 4ad4412656d415d0841d5ba30dfa367179fc4e7f70f002990540fafdee3bc784
-SIZE (vstakhov-ng_ipacct-20150304_GH0.tar.gz) = 24567
+TIMESTAMP = 1522588704
+SHA256 (vstakhov-ng_ipacct-20180401_GH0.tar.gz) = 5f873006e68a7a1a74a00eac48e940115d2e8e0b6e2628f57f782d7ee73b91fe
+SIZE (vstakhov-ng_ipacct-20180401_GH0.tar.gz) = 24653
diff --git a/net-mgmt/ng_ipacct/files/patch-ipacctctl_Makefile b/net-mgmt/ng_ipacct/files/patch-ipacctctl_Makefile
deleted file mode 100644
index 0327b751ca4c..000000000000
--- a/net-mgmt/ng_ipacct/files/patch-ipacctctl_Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- ipacctctl/Makefile.orig 2013-12-20 18:19:33.000000000 +0000
-+++ ipacctctl/Makefile 2013-12-20 18:19:52.000000000 +0000
-@@ -5,12 +5,7 @@
- BINDIR?= /usr/local/sbin
-
- PROG= ipacctctl
--.if !exists(/usr/share/mk/bsd.compat.mk)
--# Pre NOFOO -> NO_FOO system
--NOMAN= YES
--.else
- NO_MAN= YES
--.endif
-
- COPTS+= -g -Wall -Wformat
- LDADD+= -lnetgraph
diff --git a/net-mgmt/ng_ipacct/files/patch-ng_ipacct.c b/net-mgmt/ng_ipacct/files/patch-ng_ipacct.c
deleted file mode 100644
index 73540f28cc45..000000000000
--- a/net-mgmt/ng_ipacct/files/patch-ng_ipacct.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- ng_ipacct/ng_ipacct.c.orig 2015-03-16 13:38:23.000000000 +0700
-+++ ng_ipacct/ng_ipacct.c 2015-03-16 13:46:21.000000000 +0700
-@@ -965,7 +965,11 @@ pcb_get_cred(struct ip_acct_stream *r, s
- int i;
- uid_t res;
-
-+#if __FreeBSD_version < 900039
-+ INP_INFO_RLOCK(pcbinfo);
-+#else
- INP_HASH_RLOCK(pcbinfo);
-+#endif
- for (i = 0, ina = r->r_dst, port = r->r_dport; i < 2; i++) {
- #if __FreeBSD_version >= 700110
- pcb = in_pcblookup_local(pcbinfo, ina, port, 1, NOCRED);
-@@ -984,6 +988,10 @@ pcb_get_cred(struct ip_acct_stream *r, s
- (pcb->inp_socket != NULL) && (pcb->inp_socket->so_cred != NULL)) {
- res = pcb->inp_socket->so_cred->cr_uid;
- }
-+#if __FreeBSD_version < 900039
-+ INP_INFO_RUNLOCK(pcbinfo);
-+#else
- INP_HASH_RUNLOCK(pcbinfo);
-+#endif
- return res;
- }