aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-10-30 12:53:24 +0000
committerClement Laforet <clement@FreeBSD.org>2005-10-30 12:53:24 +0000
commit7a9aac6df72a45ef5993d580533d5f05750fce56 (patch)
tree5d5f642fd0fd60ddcf5b15dd9f84575f1ab39bb9 /net-mgmt
parent1a47b39e29f511490f2b912be3cd32635d400b27 (diff)
downloadports-7a9aac6df72a45ef5993d580533d5f05750fce56.tar.gz
ports-7a9aac6df72a45ef5993d580533d5f05750fce56.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cacti-spine/Makefile6
-rw-r--r--net-mgmt/cacti-spine/distinfo4
-rw-r--r--net-mgmt/cacti-spine/files/patch-cactid.h20
-rw-r--r--net-mgmt/cacti-spine/files/patch-php.c30
4 files changed, 15 insertions, 45 deletions
diff --git a/net-mgmt/cacti-spine/Makefile b/net-mgmt/cacti-spine/Makefile
index 3267e3ed492a..1cbda3d470ce 100644
--- a/net-mgmt/cacti-spine/Makefile
+++ b/net-mgmt/cacti-spine/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= cactid
-PORTVERSION= 0.8.6.e
+PORTVERSION= 0.8.6.f
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.cacti.net/downloads/cactid/
-DISTNAME= cacti-${PORTNAME}-0.8.6e
+DISTNAME= cacti-${PORTNAME}-0.8.6f-${PORTREVISION}
MAINTAINER= clement@FreeBSD.org
COMMENT= A multithreaded poller for Cacti written in C
@@ -17,6 +18,7 @@ COMMENT= A multithreaded poller for Cacti written in C
LIB_DEPENDS= netsnmp.7:${PORTSDIR}/net-mgmt/net-snmp
GNU_CONFIGURE= YES
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} --with-snmp=${LOCALBASE}
USE_MYSQL= YES
USE_OPENSSL= YES
USE_REINPLACE= YES
diff --git a/net-mgmt/cacti-spine/distinfo b/net-mgmt/cacti-spine/distinfo
index 2e4c1518e681..316273fd4101 100644
--- a/net-mgmt/cacti-spine/distinfo
+++ b/net-mgmt/cacti-spine/distinfo
@@ -1,2 +1,2 @@
-MD5 (cacti-cactid-0.8.6e.tar.gz) = c63baf6be89ea3591e8aac0e44792cd2
-SIZE (cacti-cactid-0.8.6e.tar.gz) = 132059
+MD5 (cacti-cactid-0.8.6f-1.tar.gz) = 95fe2d67c630dca9fe64a27c6ab2aff1
+SIZE (cacti-cactid-0.8.6f-1.tar.gz) = 136217
diff --git a/net-mgmt/cacti-spine/files/patch-cactid.h b/net-mgmt/cacti-spine/files/patch-cactid.h
index 4d63e0ec5b73..d0c0743ebc19 100644
--- a/net-mgmt/cacti-spine/files/patch-cactid.h
+++ b/net-mgmt/cacti-spine/files/patch-cactid.h
@@ -1,13 +1,11 @@
---- cactid.h.orig Sat Feb 26 21:46:10 2005
-+++ cactid.h Sat Feb 26 21:46:34 2005
-@@ -45,8 +45,8 @@
-
+--- cactid.h.orig Tue Oct 11 23:13:48 2005
++++ cactid.h Sun Oct 30 14:15:22 2005
+@@ -55,7 +55,7 @@
/* locations to search for the config file */
- #define CONFIG_PATHS 5
--#define CONFIG_PATH_1 ""
+ #define CONFIG_PATHS 2
+ #define CONFIG_PATH_1 ""
-#define CONFIG_PATH_2 "/etc/"
-+#define CONFIG_PATH_1 "%%PREFIX%%/etc/"
-+#define CONFIG_PATH_2 ""
- #define CONFIG_PATH_3 "/cygdrive/c/wwwroot/cacti"
- #define CONFIG_PATH_4 "/cygdrive/c/webroot/cacti"
- #define CONFIG_PATH_5 "/cygdrive/c/inetpub/wwwroot/cacti"
++#define CONFIG_PATH_2 "%%PREFIX%%/etc/"
+
+ /* config file defaults */
+ #define DEFAULT_CONF_FILE "cactid.conf"
diff --git a/net-mgmt/cacti-spine/files/patch-php.c b/net-mgmt/cacti-spine/files/patch-php.c
deleted file mode 100644
index fdbae348c836..000000000000
--- a/net-mgmt/cacti-spine/files/patch-php.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- php.c.orig Tue Jul 19 10:58:48 2005
-+++ php.c Tue Jul 19 10:59:01 2005
-@@ -149,27 +149,9 @@
- int cancel_state;
- char *result_string;
-
-- /* variable to set/get environment limitations */
-- struct rlimit ResourceLimits;
-- struct rusage Usage;
--
- /* initialize the php process id */
- set.php_sspid = 0;
-
-- if (getrlimit(RLIMIT_STACK,&ResourceLimits) == 0) {
-- if (set.verbose == POLLER_VERBOSITY_DEBUG) {
-- printf("DEBUG: Current Max Memory Allocation is '%i' bytes\n", ResourceLimits.rlim_cur);
-- printf("DEBUG: Maximum Max Memory Allocation is '%i' bytes\n", ResourceLimits.rlim_max);
-- }
-- }
--
-- if (getrlimit(RLIMIT_AS,&ResourceLimits) == 0) {
-- if (set.verbose == POLLER_VERBOSITY_DEBUG) {
-- printf("DEBUG: Current Address Space Allocation is '%i' bytes\n", ResourceLimits.rlim_cur);
-- printf("DEBUG: Maximum Address Space Allocation is '%i' bytes\n", ResourceLimits.rlim_max);
-- }
-- }
--
- if (set.verbose == POLLER_VERBOSITY_DEBUG) {
- snprintf(logmessage, LOGSIZE-1, "DEBUG: PHP Script Server Routine Starting\n");
- cacti_log(logmessage);