aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-03-10 15:13:43 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-03-10 15:13:43 +0000
commit9d2163b2bb3bac57fa471c73e790093222fd871f (patch)
tree1512defe742b84c409d213dfb4f536a6d41528b6 /net-mgmt
parent55a60b1c5f4585bd19d827aa4d6b5bc9fa893a71 (diff)
downloadports-9d2163b2bb3bac57fa471c73e790093222fd871f.tar.gz
ports-9d2163b2bb3bac57fa471c73e790093222fd871f.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/p5-NetApp/Makefile45
-rw-r--r--net-mgmt/p5-NetApp/distinfo3
-rw-r--r--net-mgmt/p5-NetApp/pkg-descr21
-rw-r--r--net-mgmt/p5-NetApp/pkg-plist40
5 files changed, 110 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 78b68278664d..4634cd829c52 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -186,6 +186,7 @@
SUBDIR += p5-Net-Telnet-Cisco-IOS
SUBDIR += p5-NetAddr-IP
SUBDIR += p5-NetAddr-IP-Lite
+ SUBDIR += p5-NetApp
SUBDIR += p5-POE-Component-SNMP
SUBDIR += p5-SNMP
SUBDIR += p5-SNMP-Info
diff --git a/net-mgmt/p5-NetApp/Makefile b/net-mgmt/p5-NetApp/Makefile
new file mode 100644
index 000000000000..9c76518ebdcc
--- /dev/null
+++ b/net-mgmt/p5-NetApp/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: p5-NetApp
+# Date created: 2009-01-31
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= NetApp
+PORTVERSION= 1.1.2
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= NetApp
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= Perl interface to manage NetApp NAS devices
+
+RUN_DEPENDS= p5-IPC-Cmd>=0:${PORTSDIR}/devel/p5-IPC-Cmd \
+ p5-Class-Std>=0:${PORTSDIR}/devel/p5-Class-Std \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize \
+ p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= 5.8.0+
+
+MAN3= NetApp::Aggregate.3 \
+ NetApp::Aggregate::Plex.3 \
+ NetApp::Aggregate::RAIDGroup.3 \
+ NetApp::Filer.3 \
+ NetApp::Filer::Export.3 \
+ NetApp::Filer::License.3 \
+ NetApp::Filer::Option.3 \
+ NetApp::Filer::Version.3 \
+ NetApp::Qtree.3 \
+ NetApp::Snapmirror.3 \
+ NetApp::Snapshot.3 \
+ NetApp::Snapshot::Delta.3 \
+ NetApp::Snapshot::Schedule.3 \
+ NetApp::Volume.3
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-NetApp/distinfo b/net-mgmt/p5-NetApp/distinfo
new file mode 100644
index 000000000000..1c688d2b0f81
--- /dev/null
+++ b/net-mgmt/p5-NetApp/distinfo
@@ -0,0 +1,3 @@
+MD5 (NetApp-1.1.2.tgz) = ec8426dba42b8dfa1dc092bd97c21528
+SHA256 (NetApp-1.1.2.tgz) = d87c7873b6b5d7c7fe5ad23dc4ecc131f4c87ceeb7ec356f9336d1d9f70fcdf1
+SIZE (NetApp-1.1.2.tgz) = 43407
diff --git a/net-mgmt/p5-NetApp/pkg-descr b/net-mgmt/p5-NetApp/pkg-descr
new file mode 100644
index 000000000000..d0adc1a61999
--- /dev/null
+++ b/net-mgmt/p5-NetApp/pkg-descr
@@ -0,0 +1,21 @@
+This package provides a suite of modules for managing NetApp's NAS
+devices, commonly referred to as "filers".
+
+This is the first public release of my NetApp Perl API, and although I
+consider the code to be very stable, the API should be considered
+experimental. The convention I will be following regarding
+non-compatible API changes is as follows. I'm using a
+major.minor.subminor release naming convention, and I will promise to
+NOT make non-backwards compatible changes between subminor releases.
+
+However, in order to allow the API to evolve, it is entirely possible
+that non-backwards compatible changes will be made between minor
+releases. IOW, the major.minor release numbers can be considered an
+API version. Any changes to 1.1.0, 1.1.2, etc. must be backwards
+compatible with the previous 1.1.* releases.
+
+There is no guarantee that 1.2.0 will be 100% backwards compatible,
+although such changes will be made only when justified. The author
+does not believe in infinite backwards compatibility.
+
+WWW: http://search.cpan.org/dist/NetApp/
diff --git a/net-mgmt/p5-NetApp/pkg-plist b/net-mgmt/p5-NetApp/pkg-plist
new file mode 100644
index 000000000000..ee5d35ed2431
--- /dev/null
+++ b/net-mgmt/p5-NetApp/pkg-plist
@@ -0,0 +1,40 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/NetApp.pm
+%%SITE_PERL%%/NetApp/Aggregate.pm
+%%SITE_PERL%%/NetApp/Aggregate.pod
+%%SITE_PERL%%/NetApp/Aggregate/Plex.pm
+%%SITE_PERL%%/NetApp/Aggregate/Plex.pod
+%%SITE_PERL%%/NetApp/Aggregate/RAIDGroup.pm
+%%SITE_PERL%%/NetApp/Aggregate/RAIDGroup.pod
+%%SITE_PERL%%/NetApp/Filer.pm
+%%SITE_PERL%%/NetApp/Filer.pod
+%%SITE_PERL%%/NetApp/Filer/Export.pm
+%%SITE_PERL%%/NetApp/Filer/Export.pod
+%%SITE_PERL%%/NetApp/Filer/License.pm
+%%SITE_PERL%%/NetApp/Filer/License.pod
+%%SITE_PERL%%/NetApp/Filer/Option.pm
+%%SITE_PERL%%/NetApp/Filer/Option.pod
+%%SITE_PERL%%/NetApp/Filer/TimeoutCache.pm
+%%SITE_PERL%%/NetApp/Filer/Version.pm
+%%SITE_PERL%%/NetApp/Filer/Version.pod
+%%SITE_PERL%%/NetApp/Qtree.pm
+%%SITE_PERL%%/NetApp/Qtree.pod
+%%SITE_PERL%%/NetApp/Snapmirror.pm
+%%SITE_PERL%%/NetApp/Snapmirror.pod
+%%SITE_PERL%%/NetApp/Snapmirror/Destination.pm
+%%SITE_PERL%%/NetApp/Snapmirror/Source.pm
+%%SITE_PERL%%/NetApp/Snapshot.pm
+%%SITE_PERL%%/NetApp/Snapshot.pod
+%%SITE_PERL%%/NetApp/Snapshot/Delta.pm
+%%SITE_PERL%%/NetApp/Snapshot/Delta.pod
+%%SITE_PERL%%/NetApp/Snapshot/Schedule.pm
+%%SITE_PERL%%/NetApp/Snapshot/Schedule.pod
+%%SITE_PERL%%/NetApp/Volume.pm
+%%SITE_PERL%%/NetApp/Volume.pod
+%%SITE_PERL%%/NetApp/Volume/Source.pm
+@dirrmtry %%SITE_PERL%%/NetApp/Volume
+@dirrmtry %%SITE_PERL%%/NetApp/Snapshot
+@dirrmtry %%SITE_PERL%%/NetApp/Snapmirror
+@dirrmtry %%SITE_PERL%%/NetApp/Filer
+@dirrmtry %%SITE_PERL%%/NetApp/Aggregate
+@dirrmtry %%SITE_PERL%%/NetApp