aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-05-01 01:38:48 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-05-01 01:38:48 +0000
commit27cad6a640f6c83d5a43d272f03de85de185f79a (patch)
tree5222fdb5c3d6adb742b3de483f3e853a11420de6 /net-mgmt
parent1e0655ed9d8ecf5aedfc2df037a96225ba3d3385 (diff)
downloadports-27cad6a640f6c83d5a43d272f03de85de185f79a.tar.gz
ports-27cad6a640f6c83d5a43d272f03de85de185f79a.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent_mibgroup_host_hr_storage.c21
2 files changed, 22 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index fd292b88597f..e5635215e1c9 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.4.2.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent_mibgroup_host_hr_storage.c b/net-mgmt/net-snmp/files/patch-agent_mibgroup_host_hr_storage.c
new file mode 100644
index 000000000000..72ba4a164333
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent_mibgroup_host_hr_storage.c
@@ -0,0 +1,21 @@
+--- agent/mibgroup/host/hr_storage.c.orig 2008-06-05 18:11:53.000000000 -0300
++++ agent/mibgroup/host/hr_storage.c 2010-04-30 21:39:50.000000000 -0300
+@@ -523,12 +523,12 @@
+ return NULL;
+
+ store_idx = name[ HRSTORE_ENTRY_NAME_LENGTH ];
+- if (HRFS_entry &&
+- netsnmp_ds_get_boolean(NETSNMP_DS_APPLICATION_ID,
+- NETSNMP_DS_AGENT_SKIPNFSINHOSTRESOURCES) &&
+- Check_HR_FileSys_NFS())
+- return NULL;
+- if (store_idx > NETSNMP_MEM_TYPE_MAX ) {
++ if (store_idx > NETSNMP_MEM_TYPE_MAX ) {
++ if (netsnmp_ds_get_boolean(NETSNMP_DS_APPLICATION_ID,
++ NETSNMP_DS_AGENT_SKIPNFSINHOSTRESOURCES) &&
++ Check_HR_FileSys_NFS())
++ return NULL;
++
+ if (HRFS_statfs(HRFS_entry->HRFS_mount, &stat_buf) < 0) {
+ snmp_log_perror(HRFS_entry->HRFS_mount);
+ goto try_next;