aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-28 17:57:15 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-28 17:57:15 +0000
commit5099ad3bf30c6c55ed59e30ef03f8ae73f9a8b8e (patch)
treef320091a02c0d5e3b18a0c09f04aea61e47a816e /net-mgmt
parentabd5cba34ac53f7ce64f444f0afca55411b58e0c (diff)
downloadports-5099ad3bf30c6c55ed59e30ef03f8ae73f9a8b8e.tar.gz
ports-5099ad3bf30c6c55ed59e30ef03f8ae73f9a8b8e.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/super_mediator/Makefile48
-rw-r--r--net-mgmt/super_mediator/distinfo6
-rw-r--r--net-mgmt/super_mediator/pkg-descr8
-rw-r--r--net-mgmt/super_mediator/pkg-plist6
5 files changed, 69 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index a78c41b1bf78..2526bda515d1 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -311,6 +311,7 @@
SUBDIR += statsd
SUBDIR += statsite
SUBDIR += subcalc
+ SUBDIR += super_mediator
SUBDIR += sx
SUBDIR += sysmon
SUBDIR += tcpreplay
diff --git a/net-mgmt/super_mediator/Makefile b/net-mgmt/super_mediator/Makefile
new file mode 100644
index 000000000000..9ac8ffd0bfe0
--- /dev/null
+++ b/net-mgmt/super_mediator/Makefile
@@ -0,0 +1,48 @@
+# Created by: Inacio <nacho319+freebsdZilla@gmail.com>
+# $FreeBSD$
+
+PORTNAME= super_mediator
+PORTVERSION= 1.2.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://tools.netsa.cert.org/releases/
+
+MAINTAINER= nacho319+freebsdZilla@gmail.com
+COMMENT= SuperMediator is an IPFIX mediator by CMU CERT generally used with YAF
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfixbuf.so:${PORTSDIR}/net/libfixbuf \
+ libltdl.so:${PORTSDIR}/devel/libltdl
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool pathfix perl5 pkgconfig
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+OPTIONS_DEFINE= SPREAD MYSQL SKIPSET
+OPTIONS_DEFAULT= MYSQL SKIPSET
+
+SPREAD_DESC= Enable Spread libary as a pub/sub distribution capability
+MYSQL_DESC= Enable SuperMediator to directly write into MySQL
+SKIPSET_DESC= Enable SiLK IPSET files for filtering
+
+SKIPSET_LIB_DEPENDS= libsilk.so:${PORTSDIR}/security/silktools
+SPREAD_LIB_DEPENDS= libspread.so:${PORTSDIR}/net/spread4
+MYSQL_LIB_DEPENDS= libmysqlclient.so:${PORTSDIR}/${_MYSQL_CLIENT}
+
+MYSQL_USE= mysql=yes
+
+MYSQL_CONFIGURE_WITH= mysql
+SKIPSET_CONFIGURE_WITH= skipset
+SPREAD_CONFIGURE_WITH= spread
+
+post-install:
+.for f in super_mediator.conf
+ ${MV} ${STAGEDIR}${PREFIX}/etc/$f ${STAGEDIR}${PREFIX}/etc/$f.sample
+.endfor
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/super_mediator/distinfo b/net-mgmt/super_mediator/distinfo
new file mode 100644
index 000000000000..a5af3bd3e5c0
--- /dev/null
+++ b/net-mgmt/super_mediator/distinfo
@@ -0,0 +1,6 @@
+SHA256 (super_mediator-1.2.2.tar.gz) = 13c8680d322a2aeb2c4142ffad260ffe24033767c5a7423aff77a0111bbf780c
+SIZE (super_mediator-1.2.2.tar.gz) = 677300
+SHA256 (super_mediator-1.2.0.tar.gz) = b38f9d7bca53ac03a49ea82750cc7788bb44605472b192afbcfad000976fa64f
+SIZE (super_mediator-1.2.0.tar.gz) = 675848
+SHA256 (super_mediator-1.1.1.tar.gz) = a23afd76b1517b21b6226b6aee0736d7d0ae60c2c0e8aa4a27241392794ab9b2
+SIZE (super_mediator-1.1.1.tar.gz) = 637677
diff --git a/net-mgmt/super_mediator/pkg-descr b/net-mgmt/super_mediator/pkg-descr
new file mode 100644
index 000000000000..b547a7651053
--- /dev/null
+++ b/net-mgmt/super_mediator/pkg-descr
@@ -0,0 +1,8 @@
+super_mediator is an IPFIX mediator designed to split IPFIX sensing flows
+and distribute the network telemetry information to multiple sources. It
+can export the network telemetry data gathered into formats designed for
+bulk loading into databases (e.g. MySQL) or as JSON outputs, as well as
+directly loading MySQL tables. super_mediator is primarily designed to get
+network telemetry data from YAF.
+
+WWW: http://tools.netsa.cert.org/super_mediator/
diff --git a/net-mgmt/super_mediator/pkg-plist b/net-mgmt/super_mediator/pkg-plist
new file mode 100644
index 000000000000..60b3836e02db
--- /dev/null
+++ b/net-mgmt/super_mediator/pkg-plist
@@ -0,0 +1,6 @@
+man/man1/super_mediator.conf.1.gz
+man/man1/super_table_creator.1.gz
+man/man1/super_mediator.1.gz
+bin/super_table_creator
+bin/super_mediator
+@sample etc/super_mediator.conf.sample