aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-01-09 21:13:48 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-01-09 21:13:48 +0000
commit599c5158127d7a43469160a077439d4ef66e87af (patch)
tree6107eb90262f140a0cc3fd0f8ab575a126055b88 /net-mgmt
parent5e11c41b5a9311034c0a96b8348d79fad7d7de59 (diff)
downloadports-599c5158127d7a43469160a077439d4ef66e87af.tar.gz
ports-599c5158127d7a43469160a077439d4ef66e87af.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile7
-rw-r--r--net-mgmt/collectd/files/patch-configure20
-rw-r--r--net-mgmt/collectd/files/patch-configure.in18
-rw-r--r--net-mgmt/collectd/files/patch-src__Makefile.am16
-rw-r--r--net-mgmt/collectd5/Makefile7
-rw-r--r--net-mgmt/collectd5/files/patch-configure20
-rw-r--r--net-mgmt/collectd5/files/patch-configure.in16
-rw-r--r--net-mgmt/collectd5/files/patch-src__Makefile.am16
8 files changed, 63 insertions, 57 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 23edb4066080..331fabb58e7d 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -16,7 +16,7 @@ COMMENT= Systems & network statistics collection daemon
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libltdl
+USE_AUTOTOOLS= autoconf autoheader automake libltdl
WANT_GNOME= yes
OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
@@ -384,9 +384,6 @@ post-patch:
-e 's;@prefix@/var/;/var/;' \
-e 's;/var/lib/;/var/db/;' \
${WRKSRC}/src/collectd.conf.in
- @${REINPLACE_CMD} \
- -e 's;$$[(]DESTDIR)$$[(]sysconfdir)/collectd\.conf;&.sample;' \
- ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e '/$$[(]mkinstalldirs)/d' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} \
-e 's;/etc/collection\.conf;${WWWDIR}/collection.conf;' \
@@ -397,7 +394,7 @@ post-patch:
${WRKSRC}/contrib/collection.conf
@${REINPLACE_CMD} \
-e 's;{libdir}/pkgconfig;{prefix}/libdata/pkgconfig;' \
- ${WRKSRC}/configure
+ ${WRKSRC}/configure.in
post-install:
${MKDIR} /var/db/collectd
diff --git a/net-mgmt/collectd/files/patch-configure b/net-mgmt/collectd/files/patch-configure
deleted file mode 100644
index d5347180adc1..000000000000
--- a/net-mgmt/collectd/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig 2011-10-14 22:54:07.000000000 +0200
-+++ configure 2011-12-19 23:25:58.000000000 +0100
-@@ -21745,7 +21745,7 @@
- then
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python LIBS" >&5
- $as_echo_n "checking for Python LIBS... " >&6; }
-- python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0))" | "$with_python_prog" 2>&1`
-+ python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"LIBDIR\").__getitem__(0)+\"/\"+distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0))" | "$with_python_prog" 2>&1`
- python_config_status=$?
-
- if test "$python_config_status" -ne 0 || test "x$python_library_flags" = "x"
-@@ -21762,7 +21762,7 @@
- if test "x$with_python" = "xyes"
- then
- LDFLAGS="-L$python_library_path $LDFLAGS"
-- LIBS="$python_library_flags $LIBS"
-+ LIBS="$python_library_flags $LIBS -lm -lpthread -lutil"
-
- ac_fn_c_check_func "$LINENO" "PyObject_CallFunction" "ac_cv_func_PyObject_CallFunction"
- if test "x$ac_cv_func_PyObject_CallFunction" = x""yes; then :
diff --git a/net-mgmt/collectd/files/patch-configure.in b/net-mgmt/collectd/files/patch-configure.in
index 30f150d17cc7..186744f29871 100644
--- a/net-mgmt/collectd/files/patch-configure.in
+++ b/net-mgmt/collectd/files/patch-configure.in
@@ -1,6 +1,16 @@
---- configure.in.orig 2011-10-14 22:49:49.000000000 +0200
-+++ configure.in 2011-12-19 23:07:31.000000000 +0100
-@@ -3165,7 +3165,7 @@
+--- configure.in.orig 2011-10-14 22:46:13.000000000 +0200
++++ configure.in 2012-01-08 13:56:06.000000000 +0100
+@@ -1541,9 +1541,6 @@
+ [with_libgcrypt="yes"],
+ [with_libgcrypt="no (symbol gcry_md_hash_buffer not found)"])
+
+- if test "$with_libgcrypt" != "no"; then
+- AM_PATH_LIBGCRYPT(1:1.2.0,,with_libgcrypt="no (version 1.2.0+ required)")
+- fi
+ fi
+
+ CPPFLAGS="$SAVE_CPPFLAGS"
+@@ -2960,7 +2957,7 @@
if test "x$with_python" = "xyes"
then
AC_MSG_CHECKING([for Python LIBS])
@@ -9,7 +19,7 @@
python_config_status=$?
if test "$python_config_status" -ne 0 || test "x$python_library_flags" = "x"
-@@ -3180,7 +3180,7 @@
+@@ -2975,7 +2972,7 @@
if test "x$with_python" = "xyes"
then
LDFLAGS="-L$python_library_path $LDFLAGS"
diff --git a/net-mgmt/collectd/files/patch-src__Makefile.am b/net-mgmt/collectd/files/patch-src__Makefile.am
new file mode 100644
index 000000000000..32c9e3e47896
--- /dev/null
+++ b/net-mgmt/collectd/files/patch-src__Makefile.am
@@ -0,0 +1,16 @@
+--- src/Makefile.am.orig 2012-01-06 18:51:47.000000000 +0100
++++ src/Makefile.am 2012-01-06 18:52:09.000000000 +0100
+@@ -1254,12 +1254,7 @@
+
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+- if test -e $(DESTDIR)$(sysconfdir)/collectd.conf; \
+- then \
+- $(INSTALL) -m 0640 collectd.conf $(DESTDIR)$(sysconfdir)/collectd.conf.pkg-orig; \
+- else \
+- $(INSTALL) -m 0640 collectd.conf $(DESTDIR)$(sysconfdir)/collectd.conf; \
+- fi; \
++ $(INSTALL) -m 0640 collectd.conf $(DESTDIR)$(sysconfdir)/collectd.conf.sample
+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)
+ $(INSTALL) -m 0644 $(srcdir)/types.db $(DESTDIR)$(pkgdatadir)/types.db;
+ $(INSTALL) -m 0644 $(srcdir)/postgresql_default.conf \
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index ab2e3c7f74c6..a649f6c496c5 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -16,7 +16,7 @@ COMMENT= Systems & network statistics collection daemon
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libltdl
+USE_AUTOTOOLS= autoconf autoheader automake libltdl
WANT_GNOME= yes
LATEST_LINK= collectd5
@@ -391,9 +391,6 @@ post-patch:
-e 's;@prefix@/var/;/var/;' \
-e 's;/var/lib/;/var/db/;' \
${WRKSRC}/src/collectd.conf.in
- @${REINPLACE_CMD} \
- -e 's;$$[(]DESTDIR)$$[(]sysconfdir)/collectd\.conf;&.sample;' \
- ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e '/$$[(]mkinstalldirs)/d' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} \
-e 's;/etc/collection\.conf;${WWWDIR}/collection.conf;' \
@@ -404,7 +401,7 @@ post-patch:
${WRKSRC}/contrib/collection.conf
@${REINPLACE_CMD} \
-e 's;{libdir}/pkgconfig;{prefix}/libdata/pkgconfig;' \
- ${WRKSRC}/configure
+ ${WRKSRC}/configure.in
post-install:
${MKDIR} /var/db/collectd
diff --git a/net-mgmt/collectd5/files/patch-configure b/net-mgmt/collectd5/files/patch-configure
deleted file mode 100644
index d5347180adc1..000000000000
--- a/net-mgmt/collectd5/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig 2011-10-14 22:54:07.000000000 +0200
-+++ configure 2011-12-19 23:25:58.000000000 +0100
-@@ -21745,7 +21745,7 @@
- then
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python LIBS" >&5
- $as_echo_n "checking for Python LIBS... " >&6; }
-- python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0))" | "$with_python_prog" 2>&1`
-+ python_library_flags=`echo "import distutils.sysconfig;import sys;sys.stdout.write(distutils.sysconfig.get_config_vars(\"LIBDIR\").__getitem__(0)+\"/\"+distutils.sysconfig.get_config_vars(\"BLDLIBRARY\").__getitem__(0))" | "$with_python_prog" 2>&1`
- python_config_status=$?
-
- if test "$python_config_status" -ne 0 || test "x$python_library_flags" = "x"
-@@ -21762,7 +21762,7 @@
- if test "x$with_python" = "xyes"
- then
- LDFLAGS="-L$python_library_path $LDFLAGS"
-- LIBS="$python_library_flags $LIBS"
-+ LIBS="$python_library_flags $LIBS -lm -lpthread -lutil"
-
- ac_fn_c_check_func "$LINENO" "PyObject_CallFunction" "ac_cv_func_PyObject_CallFunction"
- if test "x$ac_cv_func_PyObject_CallFunction" = x""yes; then :
diff --git a/net-mgmt/collectd5/files/patch-configure.in b/net-mgmt/collectd5/files/patch-configure.in
index 30f150d17cc7..cd8b589a8ac3 100644
--- a/net-mgmt/collectd5/files/patch-configure.in
+++ b/net-mgmt/collectd5/files/patch-configure.in
@@ -1,6 +1,16 @@
--- configure.in.orig 2011-10-14 22:49:49.000000000 +0200
-+++ configure.in 2011-12-19 23:07:31.000000000 +0100
-@@ -3165,7 +3165,7 @@
++++ configure.in 2012-01-08 16:04:13.000000000 +0100
+@@ -1745,9 +1745,6 @@
+ [with_libgcrypt="yes"],
+ [with_libgcrypt="no (symbol gcry_md_hash_buffer not found)"])
+
+- if test "$with_libgcrypt" != "no"; then
+- AM_PATH_LIBGCRYPT(1:1.2.0,,with_libgcrypt="no (version 1.2.0+ required)")
+- fi
+ fi
+
+ CPPFLAGS="$SAVE_CPPFLAGS"
+@@ -3165,7 +3162,7 @@
if test "x$with_python" = "xyes"
then
AC_MSG_CHECKING([for Python LIBS])
@@ -9,7 +19,7 @@
python_config_status=$?
if test "$python_config_status" -ne 0 || test "x$python_library_flags" = "x"
-@@ -3180,7 +3180,7 @@
+@@ -3180,7 +3177,7 @@
if test "x$with_python" = "xyes"
then
LDFLAGS="-L$python_library_path $LDFLAGS"
diff --git a/net-mgmt/collectd5/files/patch-src__Makefile.am b/net-mgmt/collectd5/files/patch-src__Makefile.am
new file mode 100644
index 000000000000..22dab2457e6a
--- /dev/null
+++ b/net-mgmt/collectd5/files/patch-src__Makefile.am
@@ -0,0 +1,16 @@
+--- src/Makefile.am.orig 2012-01-08 16:05:12.000000000 +0100
++++ src/Makefile.am 2012-01-08 16:05:53.000000000 +0100
+@@ -1337,12 +1337,7 @@
+
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
+- if test -e $(DESTDIR)$(sysconfdir)/collectd.conf; \
+- then \
+- $(INSTALL) -m 0640 collectd.conf $(DESTDIR)$(sysconfdir)/collectd.conf.pkg-orig; \
+- else \
+- $(INSTALL) -m 0640 collectd.conf $(DESTDIR)$(sysconfdir)/collectd.conf; \
+- fi; \
++ $(INSTALL) -m 0640 collectd.conf $(DESTDIR)$(sysconfdir)/collectd.conf.sample
+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)
+ $(INSTALL) -m 0644 $(srcdir)/types.db $(DESTDIR)$(pkgdatadir)/types.db;
+ $(INSTALL) -m 0644 $(srcdir)/postgresql_default.conf \