aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-31 09:14:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-31 09:14:29 +0000
commit5e3e25feb8319ad2a01634ca8152256676f05724 (patch)
tree8d3c1e734e6bd1ee9a858ddd467a97dfa98a6854 /net-mgmt
parent75c190b0601cd33a97122809d8cd84785c3dae91 (diff)
downloadports-5e3e25feb8319ad2a01634ca8152256676f05724.tar.gz
ports-5e3e25feb8319ad2a01634ca8152256676f05724.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cacti/Makefile2
-rw-r--r--net-mgmt/cacti/pkg-install6
2 files changed, 4 insertions, 4 deletions
diff --git a/net-mgmt/cacti/Makefile b/net-mgmt/cacti/Makefile
index d7cb132cce5f..01e39ad43f1d 100644
--- a/net-mgmt/cacti/Makefile
+++ b/net-mgmt/cacti/Makefile
@@ -17,8 +17,6 @@ RUN_DEPENDS= php:${PORTSDIR}/lang/php4 \
rrdtool:${PORTSDIR}/net/rrdtool \
net-snmp-config:${PORTSDIR}/net-mgmt/net-snmp
-IGNORE= uses an unregistered uid/gid.
-
USE_MYSQL= yes
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/net-mgmt/cacti/pkg-install b/net-mgmt/cacti/pkg-install
index df78f670ea23..9c6d7bb893ae 100644
--- a/net-mgmt/cacti/pkg-install
+++ b/net-mgmt/cacti/pkg-install
@@ -1,6 +1,8 @@
#!/bin/sh
PW=/usr/sbin/pw
+UID=107
+GID=${UID}
case $2 in
@@ -9,7 +11,7 @@ PRE-INSTALL)
if ${PW} group show "${CACTIGROUP}" 2>/dev/null; then
echo "You already have a group \"${CACTIGROUP}\", so I will use it."
else
- if ${PW} groupadd ${CACTIGROUP}; then
+ if ${PW} groupadd ${CACTIGROUP} -g ${GID}; then
echo "Added group \"${CACTIGROUP}\"."
else
echo "Adding group \"${CACTIGROUP}\" failed..."
@@ -20,7 +22,7 @@ PRE-INSTALL)
if ${PW} user show "${CACTIUSER}" 2>/dev/null; then
echo "You already have a user \"${CACTIUSER}\", so I will use it."
else
- if ${PW} useradd ${CACTIUSER} -g ${CACTIGROUP} -h - \
+ if ${PW} useradd ${CACTIUSER} -u ${UID} -g ${CACTIGROUP} -h - \
-d "/nonexistent" -s /sbin/nologin -c "Cacti Sandbox"
then
echo "Added user \"${CACTIUSER}\"."