aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 06:49:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-17 06:49:35 +0000
commitfb1f0fb885f0f836964ba8a3eaab19253dfb5521 (patch)
treecaab00238a35cc1a28bb4d0b8a7daf522ca18f1a /net-mgmt
parente7f6d9c0ae9399af670ee074a9fd5e39cd2451d9 (diff)
downloadports-fb1f0fb885f0f836964ba8a3eaab19253dfb5521.tar.gz
ports-fb1f0fb885f0f836964ba8a3eaab19253dfb5521.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/pnp/Makefile89
-rw-r--r--net-mgmt/pnp/distinfo3
-rw-r--r--net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php150
-rw-r--r--net-mgmt/pnp/files/npcd.sh.in37
-rw-r--r--net-mgmt/pnp/files/patch-sample-config::Makefile.in28
-rw-r--r--net-mgmt/pnp/files/patch-scripts::Makefile.in10
-rw-r--r--net-mgmt/pnp/files/pkg-deinstall.in35
-rw-r--r--net-mgmt/pnp/files/pkg-install.in35
-rw-r--r--net-mgmt/pnp/files/pkg-message.in55
-rw-r--r--net-mgmt/pnp/pkg-descr9
-rw-r--r--net-mgmt/pnp/pkg-plist138
12 files changed, 590 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 9f8a64373b87..0763b4429db4 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -203,6 +203,7 @@
SUBDIR += pixilate
SUBDIR += pktstat
SUBDIR += pmacct
+ SUBDIR += pnp
SUBDIR += portmon
SUBDIR += py-flowtools
SUBDIR += py-ipy
diff --git a/net-mgmt/pnp/Makefile b/net-mgmt/pnp/Makefile
new file mode 100644
index 000000000000..1c8f0a5b4626
--- /dev/null
+++ b/net-mgmt/pnp/Makefile
@@ -0,0 +1,89 @@
+# New ports collection makefile for: pnp
+# Date created: unknown
+# Whom: rea-fbsd@codelabs.ru
+#
+# $FreeBSD$
+#
+
+PORTNAME= pnp
+PORTVERSION= 0.4.10
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pnp4nagios
+
+MAINTAINER= rea-fbsd@codelabs.ru
+COMMENT= Nagios performance data collector and grapher
+
+RUN_DEPENDS= ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool \
+ nagios:${PORTSDIR}/net-mgmt/nagios
+
+OPTIONS= PDF "Use built-in fpdf library to produce PDF views" ON
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+USE_RC_SUBR= npcd.sh
+
+NAGIOSDIR?= /var/spool/nagios
+NAGIOSHTMURL?= /nagios
+NAGIOSUSER?= nagios
+NAGIOSGROUP?= nagios
+PNP_STATE= ${NAGIOSDIR}/pnp
+PNP_RRDS= ${PNP_STATE}/rrd
+PNP_SPOOL= ${PNP_STATE}/perfspool
+FPDF_DIR?= share/fpdf
+
+.if defined(WITH_PDF)
+USE_PHP= zlib
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-share::pnp::include::function.inc.php
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= \
+ --prefix=${LOCALBASE} \
+ --datadir=${WWWDIR} \
+ --localstatedir=/var/log \
+ --with-rrdtool=${LOCALBASE}/bin/rrdtool \
+ --with-perfdata-dir=${PNP_RRDS} \
+ --with-perfdata-spool-dir=${PNP_SPOOL} \
+ --with-nagios-user=${NAGIOSUSER} \
+ --with-nagios-group=${NAGIOSGROUP}
+# Get rid of INSTALL_OPTS that are set by configure --
+# we want the things to be installed with root:wheel and
+# NAGIOSUSER:NAGIOSGROUP are going to the configuration files.
+MAKE_ARGS= INSTALL_OPTS=
+INSTALL_TARGET= install install-config
+
+SUB_FILES= pkg-install \
+ pkg-deinstall \
+ pkg-message
+SUB_LIST= PNP_STATE=${PNP_STATE} \
+ PNP_RRDS=${PNP_RRDS} \
+ PNP_SPOOL=${PNP_SPOOL} \
+ NAGIOSUSER=${NAGIOSUSER} \
+ NAGIOSGROUP=${NAGIOSGROUP}
+
+# All files in share/pnp/include/ are installed, so if we patched something
+# in that directory, we must clean the '.orig' files -- they shouldn't be
+# installed.
+PNP_CLEAN_PATCHED= share/pnp/include/function.inc.php.orig
+
+.if defined(WITH_PDF)
+PNP_USE_FPDF= 1
+.else
+PNP_USE_FPDF= 0
+.endif
+post-patch:
+ @${REINPLACE_CMD} \
+ -e's|^\$$conf\['\''use_fpdf'\''\] = [[:digit:]];|$$conf['\''use_fpdf'\''] = ${PNP_USE_FPDF};|' \
+ -e's|^\$$conf\['\''nagios_base'\''\] = "/nagios/cgi-bin";|$$conf\['\''nagios_base'\''\] = "${NAGIOSHTMURL}/cgi-bin";|' \
+ "${WRKSRC}/sample-config/pnp/config.php.in"
+.for pch in ${PNP_CLEAN_PATCHED}
+ @${RM} -f "${WRKSRC}/${pch}"
+.endfor
+
+post-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/pnp/distinfo b/net-mgmt/pnp/distinfo
new file mode 100644
index 000000000000..1487e8a6f420
--- /dev/null
+++ b/net-mgmt/pnp/distinfo
@@ -0,0 +1,3 @@
+SIZE (pnp-0.4.10.tar.gz) = 301021
+MD5 (pnp-0.4.10.tar.gz) = 5e57d50e2d895878b626497fd7b217b7
+SHA256 (pnp-0.4.10.tar.gz) = 35392c83fc9468eba38187e17b773090dff923f7b74c86c3c11e2574b99c214d
diff --git a/net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php b/net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php
new file mode 100644
index 000000000000..7fe0021b2b1b
--- /dev/null
+++ b/net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php
@@ -0,0 +1,150 @@
+--- share/pnp/include/function.inc.php.orig 2008-06-18 12:02:41.000000000 +0400
++++ share/pnp/include/function.inc.php 2008-08-16 23:35:30.000000000 +0400
+@@ -819,114 +819,15 @@
+ }
+
+ function doPDF($display,$data) {
+- require ('fpdi.php');
+- global $NAGIOS;
+- global $conf;
+- if(file_exists($conf['background_pdf'])){
+- $use_bg=1;
+- }
+- class PDF extends FPDI {
+- //Page header
+- function Header() {
+- //Arial bold 10
+- $this->SetFont('Arial', 'B', 10);
+- //Move to the right
+- $this->Cell(80);
+- //Title
+- $this->Cell(30, 10, _PDFTITLE, 0, 1, 'C');
+- //Line break
+- #$this->Ln(20);
+- }
+-
+- //Page footer
+- function Footer() {
+- //Position at 1.5 cm from bottom
+- $this->SetY(-20);
+- //Arial italic 8
+- $this->SetFont('Arial', 'I', 8);
+- //Page number
+- $this->Cell(0, 10, _PDFPAGE . $this->PageNo() . '/{nb}', 0, 0, 'C');
+- }
+- }
+-
+- $pdf =& new PDF('P', 'mm', 'A4');
+- $pdf->AliasNbPages();
+- $pdf->SetAutoPageBreak('off');
+- $pdf->SetMargins(12.5,25,10);
+- $pdf->AddPage();
+- if($use_bg){
+- $pdf->setSourceFile($conf['background_pdf']);
+- $tplIdx = $pdf->importPage(1,'/MediaBox');
+- $pdf->useTemplate($tplIdx);
+- }
+- $pdf->SetCreator('Created with PNP');
+- $pdf->SetAuthor($_PHP['REMOTE_USER']);
+- $pdf->SetFont('Arial', '', 10);
+- $pdf->Cell(120, 4, '', 0, 1, 'L');
+- if($display == "service"){
+- foreach($data as $d) {
+- if ($pdf->GetY() > 220) {
+- $pdf->AddPage();
+- if($use_bg){$pdf->useTemplate($tplIdx);}
+- }
+-
+- $pdf->SetFont('Arial', '', 10);
+- $pdf->CELL(120, 5, $d["n_hostname"]." / ".$d["n_servicedesc"] , 0, 1);
+- $pdf->SetFont('Arial', '', 8);
+- $pdf->CELL(120, 5, $d["view_title"]. " (" . $d["f_start"]." - ".$d["f_end"].")", 0, 1);
+-
+- $img = saveImage($d['rrd_opts']);
+- $Y = $pdf->GetY();
+- $cell_height = ($img['height'] * 0.23);
+- $cell_width = ($img['width'] * 0.23);
+- $pdf->Image($img['name'], 12.5, $Y, $cell_width, $cell_height, 'PNG');
+- $pdf->CELL(120, $cell_height, '', 0, 1);
+- unlink($img['name']);
+- }
+- }
+- if($display == "page"){
+- foreach($data as $d) {
+- if ($pdf->GetY() > 220) {
+- $pdf->AddPage();
+- if($use_bg){$pdf->useTemplate($tplIdx);}
+- }
+-
+- $pdf->SetFont('Arial', '', 10);
+- $pdf->CELL(120, 5, $d["hostname"]." / ".$d["servicedesc"] , 0, 1);
+- $pdf->SetFont('Arial', '', 8);
+- $pdf->CELL(120, 5, $d["f_start"]." - ".$d["f_end"], 0, 1);
+-
+- $img = saveImage($d['rrd_opts']);
+- $Y = $pdf->GetY();
+- $cell_height = ($img['height'] * 0.23);
+- $cell_width = ($img['width'] * 0.23);
+- $pdf->Image($img['name'], 12.5, $Y, $cell_width, $cell_height, 'PNG');
+- $pdf->CELL(120, $cell_height, '', 0, 1);
+- unlink($img['name']);
+- }
+- }
+- if($display == "host_list"){
+- foreach($data as $d) {
+- if ($pdf->GetY() > 220) {
+- $pdf->AddPage();
+- if($use_bg){$pdf->useTemplate($tplIdx);}
+- }
+- $pdf->SetFont('Arial', '', 10);
+- $pdf->CELL(120, 7, $d["hostname"]." / ".$d["servicedesc"] , 0, 1);
+- $pdf->SetFont('Arial', '', 8);
+- $pdf->CELL(120, 5, $d["f_start"]." - ".$d["f_end"], 0, 1);
+-
+- $img = saveImage($d['rrd_opts']);
+- $Y = $pdf->GetY();
+- $cell_height = ($img['height'] * 0.23);
+- $cell_width = ($img['width'] * 0.23);
+- $pdf->Image($img['name'], 12.5, $Y, $cell_width, $cell_height, 'PNG');
+- $pdf->CELL(120, $cell_height, '', 0, 1);
+- unlink($img['name']);
+- }
+- }
+-
+- $pdf->Output();
++ print "<html>\n";
++ print "<head>\n";
++ print "<title>Failed</title>\n";
++ print "</head>\n";
++ print "<body>\n";
++ print "<h1>Failed</h1>\n";
++ print "</body>\n";
++ print "<html>\n";
++ exit(0);
+ }
+
+ function doStrip($string) {
+@@ -1173,23 +1074,6 @@
+ }
+
+ function doPDFIcon($type){
+- global $hostname;
+- global $servicedesc;
+- global $start;
+- global $end;
+- global $source;
+- global $view;
+- global $display;
+- global $page;
+-
+- switch($type){
+- case "PAGE":
+- print "<a href=\"index.php?page=$page&display=$display&view=$view&do=pdf\"><img src=\"images/pdf.png\" HEIGHT=\"32px\" WIDTH=\"32px\" title=\"Display PDF\" ></a>\n";
+- break;
+- default:
+- print "<a href=\"index.php?host=$hostname&srv=$servicedesc&display=$display&view=$view&source=$source&end=$end&start=$start&do=pdf\"><img src=\"images/pdf.png\" HEIGHT=\"32px\" WIDTH=\"32px\" title=\"Display PDF\" ></a>\n";
+- break;
+- }
+ }
+
+ function doXMLIcon(){
diff --git a/net-mgmt/pnp/files/npcd.sh.in b/net-mgmt/pnp/files/npcd.sh.in
new file mode 100644
index 000000000000..94369f3b572f
--- /dev/null
+++ b/net-mgmt/pnp/files/npcd.sh.in
@@ -0,0 +1,37 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: npcd
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable/tune npcd:
+# npcd_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable npcd.
+# npcd_flags (str): Set to "" by default.
+# npcd_configfile (str): Set to "%%PREFIX%%/etc/pnp/npcd.cfg" by default.
+#
+
+. %%RC_SUBR%%
+
+name="npcd"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/bin/npcd"
+command_args="-d"
+pidfile=/var/run/${name}.pid
+
+: ${npcd_enable="NO"}
+: ${npcd_flags=""}
+: ${npcd_configfile:="%%PREFIX%%/etc/pnp/npcd.cfg"}
+
+load_rc_config "${name}"
+
+required_files="${npcd_configfile}"
+command_args="${command_args} -f ${npcd_configfile}"
+
+run_rc_command "$1"
diff --git a/net-mgmt/pnp/files/patch-sample-config::Makefile.in b/net-mgmt/pnp/files/patch-sample-config::Makefile.in
new file mode 100644
index 000000000000..74b8179e80b8
--- /dev/null
+++ b/net-mgmt/pnp/files/patch-sample-config::Makefile.in
@@ -0,0 +1,28 @@
+--- sample-config/Makefile.in.orig 2008-08-16 23:03:08.000000000 +0400
++++ sample-config/Makefile.in 2008-08-16 23:04:53.000000000 +0400
+@@ -28,22 +28,18 @@
+ devclean: distclean
+
+ install:
+- -rm -f $(HTMLDIR)/conf/config.php
+-
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/check_commands
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/pages
+- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(CFGDIR)
+- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/background.pdf $(DESTDIR)$(CFGDIR)
++ $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(CFGDIR)/config.php-sample
++ $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/background.pdf $(DESTDIR)$(CFGDIR)/background.pdf-sample
+
+ install-config:
+- -rm -f $(DESTDIR)$(HTMLDIR)/conf/config.php
+-
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/check_commands
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/pages
+
+- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(CFGDIR)
++ $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(CFGDIR)/config.php-sample
+ $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/process_perfdata.cfg-sample $(DESTDIR)$(CFGDIR)
+ $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/rra.cfg-sample $(DESTDIR)$(CFGDIR)
+ $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/check_commands/check_nwstat.cfg-sample $(DESTDIR)$(CFGDIR)/check_commands
diff --git a/net-mgmt/pnp/files/patch-scripts::Makefile.in b/net-mgmt/pnp/files/patch-scripts::Makefile.in
new file mode 100644
index 000000000000..2add42254768
--- /dev/null
+++ b/net-mgmt/pnp/files/patch-scripts::Makefile.in
@@ -0,0 +1,10 @@
+--- scripts/Makefile.in.orig 2008-08-17 00:52:43.000000000 +0400
++++ scripts/Makefile.in 2008-08-17 00:52:47.000000000 +0400
+@@ -37,7 +37,6 @@
+ $(INSTALL) -m 774 $(INSTALL_OPTS) net2pnp.pl $(DESTDIR)$(BINDIR)
+
+ install:
+- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(PERFDATADIR)
+ $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBEXECDIR)
+ $(MAKE) install-processperfdata
+
diff --git a/net-mgmt/pnp/files/pkg-deinstall.in b/net-mgmt/pnp/files/pkg-deinstall.in
new file mode 100644
index 000000000000..631082094eda
--- /dev/null
+++ b/net-mgmt/pnp/files/pkg-deinstall.in
@@ -0,0 +1,35 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PNP_RRDS=%%PNP_RRDS%%
+PNP_SPOOL=%%PNP_SPOOL%%
+PNP_STATE=%%PNP_STATE%%
+NAGIOSUSER=%%NAGIOSUSER%%
+NAGIOSGROUP=%%NAGIOSGROUP%%
+
+dirs () {
+ local notempty
+
+ for i in "$PNP_RRDS" "$PNP_SPOOL" "$PNP_STATE"; do
+ if ! rmdir "$i" > /dev/null 2>&1; then
+ notempty="$notempty $i"
+ fi
+ done
+
+ if [ -n "$notempty" ]; then
+ echo
+ echo "The following directories were not removed:"
+ for i in $notempty; do
+ echo " $i"
+ done
+ echo
+ echo "Unless you're upgrading, remove them manually."
+ echo
+ fi
+}
+
+if [ "x$2" = "xPOST-DEINSTALL" ]; then
+ dirs
+fi
diff --git a/net-mgmt/pnp/files/pkg-install.in b/net-mgmt/pnp/files/pkg-install.in
new file mode 100644
index 000000000000..ca442c1db99d
--- /dev/null
+++ b/net-mgmt/pnp/files/pkg-install.in
@@ -0,0 +1,35 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PNP_RRDS=%%PNP_RRDS%%
+PNP_SPOOL=%%PNP_SPOOL%%
+NAGIOSUSER=%%NAGIOSUSER%%
+NAGIOSGROUP=%%NAGIOSGROUP%%
+
+dirs () {
+ for i in "$PNP_RRDS" "$PNP_SPOOL"; do
+ if ! [ -d "$i" ]; then
+ mkdir -p "$i"
+ chmod 750 "$i"
+ chown "$NAGIOSUSER":"$NAGIOSGROUP" "$i"
+ fi
+ done
+}
+
+check_sanity () {
+ if ! pw group show "$NAGIOSGROUP" 2>&1 > /dev/null; then
+ echo "No group '$NAGIOSGROUP'. Create it and try again."
+ exit 1
+ fi
+ if ! pw user show "$NAGIOSUSER" 2>&1 > /dev/null; then
+ echo "No user '$NAGIOSUSER'. Create it and try again."
+ exit 1
+ fi
+}
+
+if [ "x$2" = "xPOST-INSTALL" ]; then
+ check_sanity
+ dirs
+fi
diff --git a/net-mgmt/pnp/files/pkg-message.in b/net-mgmt/pnp/files/pkg-message.in
new file mode 100644
index 000000000000..7b89f0a92f42
--- /dev/null
+++ b/net-mgmt/pnp/files/pkg-message.in
@@ -0,0 +1,55 @@
+========================================================================
+
+You just installed/upgraded PNP graphing tool for Nagios.
+
+For tool configuration tasks read
+ http://www.pnp4nagios.org/pnp/config
+
+For Web-frontend configuration tasks read
+ http://www.pnp4nagios.org/pnp/webfe
+
+We recommend to start with the following restrictive Apache
+configuration for the PNP area:
+
+<Directory "%%WWWDIR%%/">
+ Order deny,allow
+ Allow from all
+ Deny from all
+ DirectoryIndex index.php
+ AddHandler application/x-httpd-php .php
+</Directory>
+
+<Directory "%%WWWDIR%%/include/">
+ Options None
+ Order allow,deny
+ Deny from all
+ <FilesMatch ".css$">
+ Order deny,allow
+ Allow from all
+ Deny from all
+ </FilesMatch>
+</Directory>
+
+<Directory "%%WWWDIR%%/include/js/">
+ Order deny,allow
+ Allow from all
+ Deny from all
+</Directory>
+<Directory "%%WWWDIR%%/lang/">
+ Order allow,deny
+ Deny from all
+</Directory>
+<Directory "%%WWWDIR%%/templates/">
+ Order allow,deny
+ Deny from all
+</Directory>
+<Directory "%%WWWDIR%%/templates.dist/">
+ Order allow,deny
+ Deny from all
+</Directory>
+
+
+Remember to restart NPCD service after upgrade if you're using
+'bulk' mode with NPCD.
+
+========================================================================
diff --git a/net-mgmt/pnp/pkg-descr b/net-mgmt/pnp/pkg-descr
new file mode 100644
index 000000000000..89faec2f3e18
--- /dev/null
+++ b/net-mgmt/pnp/pkg-descr
@@ -0,0 +1,9 @@
+PNP is an addon to nagios which analyzes performance data provided
+by plugins and stores them automatically into RRD-databases (Round
+Robin Databases, see RRD Tool).
+
+During development of PNP we set value on easy installation and
+little maintenance while running it. An administrator should do
+other things than configure graphing tools.
+
+WWW: http://www.pnp4nagios.org/pnp/start
diff --git a/net-mgmt/pnp/pkg-plist b/net-mgmt/pnp/pkg-plist
new file mode 100644
index 000000000000..0e3cc8956a26
--- /dev/null
+++ b/net-mgmt/pnp/pkg-plist
@@ -0,0 +1,138 @@
+bin/npcd
+etc/pnp/config.php-sample
+etc/pnp/background.pdf-sample
+etc/pnp/check_commands/check_nwstat.cfg-sample
+etc/pnp/pages/web_traffic.cfg-sample
+etc/pnp/process_perfdata.cfg-sample
+etc/pnp/rra.cfg-sample
+etc/pnp/npcd.cfg-sample
+libexec/process_perfdata.pl
+%%WWWDIR%%/images/ack.png
+%%WWWDIR%%/images/calendar.png
+%%WWWDIR%%/images/critical.png
+%%WWWDIR%%/images/eps.png
+%%WWWDIR%%/images/int.gif
+%%WWWDIR%%/images/int2.gif
+%%WWWDIR%%/images/link.png
+%%WWWDIR%%/images/noack.png
+%%WWWDIR%%/images/notify.gif
+%%WWWDIR%%/images/ok.png
+%%WWWDIR%%/images/pages.png
+%%WWWDIR%%/images/pdf.png
+%%WWWDIR%%/images/pnp.png
+%%WWWDIR%%/images/recovery.png
+%%WWWDIR%%/images/rrdtool.png
+%%WWWDIR%%/images/svg.png
+%%WWWDIR%%/images/trends.gif
+%%WWWDIR%%/images/warning.png
+%%WWWDIR%%/images/xml.png
+%%WWWDIR%%/images/zoom.png
+%%WWWDIR%%/include/font/makefont/cp1250.map
+%%WWWDIR%%/include/font/makefont/cp1251.map
+%%WWWDIR%%/include/font/makefont/cp1252.map
+%%WWWDIR%%/include/font/makefont/cp1253.map
+%%WWWDIR%%/include/font/makefont/cp1254.map
+%%WWWDIR%%/include/font/makefont/cp1255.map
+%%WWWDIR%%/include/font/makefont/cp1257.map
+%%WWWDIR%%/include/font/makefont/cp1258.map
+%%WWWDIR%%/include/font/makefont/cp874.map
+%%WWWDIR%%/include/font/makefont/iso-8859-1.map
+%%WWWDIR%%/include/font/makefont/iso-8859-11.map
+%%WWWDIR%%/include/font/makefont/iso-8859-15.map
+%%WWWDIR%%/include/font/makefont/iso-8859-16.map
+%%WWWDIR%%/include/font/makefont/iso-8859-2.map
+%%WWWDIR%%/include/font/makefont/iso-8859-4.map
+%%WWWDIR%%/include/font/makefont/iso-8859-5.map
+%%WWWDIR%%/include/font/makefont/iso-8859-7.map
+%%WWWDIR%%/include/font/makefont/iso-8859-9.map
+%%WWWDIR%%/include/font/makefont/koi8-r.map
+%%WWWDIR%%/include/font/makefont/koi8-u.map
+%%WWWDIR%%/include/font/makefont/makefont.php
+%%WWWDIR%%/include/font/courier.php
+%%WWWDIR%%/include/font/helvetica.php
+%%WWWDIR%%/include/font/helveticab.php
+%%WWWDIR%%/include/font/helveticabi.php
+%%WWWDIR%%/include/font/helveticai.php
+%%WWWDIR%%/include/font/symbol.php
+%%WWWDIR%%/include/font/times.php
+%%WWWDIR%%/include/font/timesb.php
+%%WWWDIR%%/include/font/timesbi.php
+%%WWWDIR%%/include/font/timesi.php
+%%WWWDIR%%/include/font/zapfdingbats.php
+%%WWWDIR%%/include/js/builder.js
+%%WWWDIR%%/include/js/calendar-blue.css
+%%WWWDIR%%/include/js/calendar-de.js
+%%WWWDIR%%/include/js/calendar-en.js
+%%WWWDIR%%/include/js/calendar-setup.js
+%%WWWDIR%%/include/js/calendar.js
+%%WWWDIR%%/include/js/controls.js
+%%WWWDIR%%/include/js/dragdrop.js
+%%WWWDIR%%/include/js/effects.js
+%%WWWDIR%%/include/js/menuarrow.gif
+%%WWWDIR%%/include/js/overlib.js
+%%WWWDIR%%/include/js/overlib_shadow.js
+%%WWWDIR%%/include/js/prototype.js
+%%WWWDIR%%/include/js/scriptaculous.js
+%%WWWDIR%%/include/js/slider.js
+%%WWWDIR%%/include/js/unittest.js
+%%WWWDIR%%/include/js/zoom.js
+%%WWWDIR%%/include/debug.php
+%%WWWDIR%%/include/fpdf.php
+%%WWWDIR%%/include/fpdf_tpl.php
+%%WWWDIR%%/include/fpdi.php
+%%WWWDIR%%/include/fpdi_pdf_parser.php
+%%WWWDIR%%/include/function.inc.php
+%%WWWDIR%%/include/pdf_context.php
+%%WWWDIR%%/include/pdf_parser.php
+%%WWWDIR%%/include/site.php
+%%WWWDIR%%/include/style.css
+%%WWWDIR%%/include/wrapper_functions.php
+%%WWWDIR%%/lang/lang_de.php
+%%WWWDIR%%/lang/lang_en.php
+%%WWWDIR%%/lang/lang_fr.php
+%%WWWDIR%%/lang/lang_nl.php
+%%WWWDIR%%/lang/lang_se.php
+%%WWWDIR%%/templates.dist/check-host-alive.php
+%%WWWDIR%%/templates.dist/check_disk.php
+%%WWWDIR%%/templates.dist/check_dns.php
+%%WWWDIR%%/templates.dist/check_http.php
+%%WWWDIR%%/templates.dist/check_http_url.php
+%%WWWDIR%%/templates.dist/check_iftraffic_counter.php
+%%WWWDIR%%/templates.dist/check_iftraffic_pct.php
+%%WWWDIR%%/templates.dist/check_load.php
+%%WWWDIR%%/templates.dist/check_messpc_temp.php
+%%WWWDIR%%/templates.dist/check_multi.php
+%%WWWDIR%%/templates.dist/check_nt_cpu.php
+%%WWWDIR%%/templates.dist/check_nt_disk.php
+%%WWWDIR%%/templates.dist/check_nt_mem.php
+%%WWWDIR%%/templates.dist/check_nwstat_CONNS.php
+%%WWWDIR%%/templates.dist/check_nwstat_LOAD.php
+%%WWWDIR%%/templates.dist/check_nwstat_LOAD1.php
+%%WWWDIR%%/templates.dist/check_ping.php
+%%WWWDIR%%/templates.dist/check_nwstat_LOAD15.php
+%%WWWDIR%%/templates.dist/check_nwstat_LOAD5.php
+%%WWWDIR%%/templates.dist/check_nwstat_ofiles.php
+%%WWWDIR%%/templates.dist/check_smtp.php
+%%WWWDIR%%/templates.dist/check_snmp_int-bits.php
+%%WWWDIR%%/templates.dist/check_snmp_int.php
+%%WWWDIR%%/templates.dist/check_swap.php
+%%WWWDIR%%/templates.dist/check_tcp.php
+%%WWWDIR%%/templates.dist/check_users.php
+%%WWWDIR%%/templates.dist/default.php
+%%WWWDIR%%/templates.dist/response.php
+%%WWWDIR%%/ajax.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/zoom.php
+
+@dirrmtry %%WWWDIR%%/templates.dist
+@dirrmtry %%WWWDIR%%/templates
+@dirrmtry %%WWWDIR%%/lang
+@dirrmtry %%WWWDIR%%/include/js
+@dirrmtry %%WWWDIR%%/include/font/makefont
+@dirrmtry %%WWWDIR%%/include/font
+@dirrmtry %%WWWDIR%%/include
+@dirrmtry %%WWWDIR%%/images
+@dirrmtry %%WWWDIR%%
+@dirrmtry etc/pnp/pages
+@dirrmtry etc/pnp/check_commands
+@dirrmtry etc/pnp