aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-15 16:41:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-15 16:41:49 +0000
commit74b552997486b6c956c4db46c768f1fdf336d01a (patch)
treeb8a29dc7b74e801ded995db9dc362d2523b1af71 /net-mgmt
parent3a4ddcc5fc69b4ba1d0f513a9ac418b63f95f29c (diff)
downloadports-74b552997486b6c956c4db46c768f1fdf336d01a.tar.gz
ports-74b552997486b6c956c4db46c768f1fdf336d01a.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-flowtools/Makefile24
-rw-r--r--net-mgmt/py-flowtools/distinfo2
-rw-r--r--net-mgmt/py-flowtools/pkg-descr10
-rw-r--r--net-mgmt/py-flowtools/pkg-plist1
5 files changed, 38 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index c3d7a2b506d3..19bc4d866f4d 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -126,6 +126,7 @@
SUBDIR += pixilate
SUBDIR += pmacct
SUBDIR += portmon
+ SUBDIR += py-flowtools
SUBDIR += py-ipy
SUBDIR += py-snmp
SUBDIR += rancid
diff --git a/net-mgmt/py-flowtools/Makefile b/net-mgmt/py-flowtools/Makefile
new file mode 100644
index 000000000000..a064bc604f97
--- /dev/null
+++ b/net-mgmt/py-flowtools/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: py-flowtools
+# Date created: 16 Sep 2004
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flowtools
+PORTVERSION= 0.3
+CATEGORIES= net-mgmt python
+MASTER_SITES= http://mail.net.informatik.tu-muenchen.de/~robin/flowtools/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyflowtools-${PORTVERSION}
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= Python extension module for reading flow-tools' data
+
+BUILD_DEPENDS= ${LOCALBASE}/include/ftlib.h:${PORTSDIR}/net-mgmt/flow-tools
+
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-flowtools/distinfo b/net-mgmt/py-flowtools/distinfo
new file mode 100644
index 000000000000..3516f88b3c61
--- /dev/null
+++ b/net-mgmt/py-flowtools/distinfo
@@ -0,0 +1,2 @@
+MD5 (pyflowtools-0.3.tar.gz) = a9268d59812aeb5f34c1d41a6535ef95
+SIZE (pyflowtools-0.3.tar.gz) = 12510
diff --git a/net-mgmt/py-flowtools/pkg-descr b/net-mgmt/py-flowtools/pkg-descr
new file mode 100644
index 000000000000..54f31698bf9b
--- /dev/null
+++ b/net-mgmt/py-flowtools/pkg-descr
@@ -0,0 +1,10 @@
+py-flowtools extension module gives you a simple python interface
+to NetFlow data as stored by Mark Fullmer's flow-tools package.
+
+It contains a class FlowSet which reads the data from a given file
+(or from standard input). A FlowSet provides an iterator interface
+to access the individual flow records as instances of a second
+class called Flow. A Flow provides access to its data through
+attribute references.
+
+WWW: http://mail.net.informatik.tu-muenchen.de/~robin/flowtools/
diff --git a/net-mgmt/py-flowtools/pkg-plist b/net-mgmt/py-flowtools/pkg-plist
new file mode 100644
index 000000000000..2b03d065a65a
--- /dev/null
+++ b/net-mgmt/py-flowtools/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/flowtools.so