aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-09-05 16:29:17 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-09-05 16:29:17 +0000
commit77857ce9e7a5cdf46c81eb36caed0dc84074cd1e (patch)
treef9bb06cad1a78dadc15053b56419d9345b99f4fd /net-mgmt
parent0beb901505303d90cb0e09272a08511e88e5dbb7 (diff)
downloadports-77857ce9e7a5cdf46c81eb36caed0dc84074cd1e.tar.gz
ports-77857ce9e7a5cdf46c81eb36caed0dc84074cd1e.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ehnt/Makefile2
-rw-r--r--net-mgmt/ehnt/files/patch-ehnt__client.c18
2 files changed, 15 insertions, 5 deletions
diff --git a/net-mgmt/ehnt/Makefile b/net-mgmt/ehnt/Makefile
index 94a6f8da3b62..56f58fbb33db 100644
--- a/net-mgmt/ehnt/Makefile
+++ b/net-mgmt/ehnt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ehnt
PORTVERSION= 0.3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-mgmt/ehnt/files/patch-ehnt__client.c b/net-mgmt/ehnt/files/patch-ehnt__client.c
index 1ff62cb29cf1..d170c3dbe9a6 100644
--- a/net-mgmt/ehnt/files/patch-ehnt__client.c
+++ b/net-mgmt/ehnt/files/patch-ehnt__client.c
@@ -2,8 +2,18 @@
$FreeBSD$
--- ehnt_client.c.orig Thu Oct 4 22:18:29 2001
-+++ ehnt_client.c Mon May 24 11:59:17 2004
-@@ -69,7 +69,8 @@
++++ ehnt_client.c Mon Aug 9 23:49:05 2004
+@@ -27,6 +27,9 @@
+ static void sig_int (int);
+ char getkey();
+
++
++ssize_t read_n(int fd, void *vptr, size_t n);
++
+ int ehnt_client(char * servername, int serverport, struct ehnt_struct *my_ehnt_struct ) {
+ char ips[100];
+ int c;
+@@ -69,7 +72,8 @@
printf("Warning: can't catch interrupt signal\n");
}
fflush(stdout);
@@ -13,7 +23,7 @@ $FreeBSD$
setbuf(stdout,NULL);
for ( ; ; ) {
-@@ -78,7 +79,8 @@
+@@ -78,7 +82,8 @@
int maxfd=sockfd;
FD_ZERO(&read_fds);
@@ -23,7 +33,7 @@ $FreeBSD$
FD_SET(sockfd,&read_fds);
fflush(stdout);
-@@ -89,7 +91,7 @@
+@@ -89,7 +94,7 @@
if (FD_ISSET(sockfd,&read_fds)) {
ehnt_client_processmessage(sockfd,routeraddr,my_ehnt_struct);
}