aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-04-06 10:00:52 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-04-06 10:00:52 +0000
commitae4197390caa9eb77ec7925b269078c95bb8c1a6 (patch)
treebd43950ccc2ee8c113e33a6bec8dd33766d80555 /net-mgmt
parent86d6a827d0887080f6aed5107d6ac480057d87d6 (diff)
downloadports-ae4197390caa9eb77ec7925b269078c95bb8c1a6.tar.gz
ports-ae4197390caa9eb77ec7925b269078c95bb8c1a6.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios12/Makefile48
-rw-r--r--net-mgmt/nagios12/distinfo4
-rw-r--r--net-mgmt/nagios12/pkg-plist35
3 files changed, 61 insertions, 26 deletions
diff --git a/net-mgmt/nagios12/Makefile b/net-mgmt/nagios12/Makefile
index e4f68de1cdeb..64dba94019cb 100644
--- a/net-mgmt/nagios12/Makefile
+++ b/net-mgmt/nagios12/Makefile
@@ -6,13 +6,14 @@
#
PORTNAME= nagios
-PORTVERSION= 2.0.b3
+PORTVERSION= 1.2
+PORTREVISION= 2
+PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=nagios
-DISTNAME= nagios-2.0b3
-MAINTAINER= blaz@si.FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Extremely powerful network monitoring system
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
@@ -20,7 +21,6 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagio
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
-USE_AUTOCONF_VER= 259
USE_RC_SUBR= yes
USE_PERL5_BUILD=yes
@@ -32,17 +32,24 @@ NAGIOSUSER?= nagios
NAGIOSGROUP?= nagios
NAGIOSDIR?= /var/spool/nagios
+OPTIONS= MYSQL "MySQL suport" off \
+ PGSQL "PostgreSQL suport" off \
+ FILE_PERFDATA "Save performance data to files" off
+
+CONFLICTS= nagios-2*
+
.include <bsd.port.pre.mk>
-CPPFLAGS= -I${LOCALBASE}/include -fPIC
+CPPFLAGS= -I${LOCALBASE}/include
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CFLAGS="${CPPFLAGS} ${CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -lgd"
CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
- --with-command-group=www \
+ --with-command-grp=www \
--with-nagios-user=${NAGIOSUSER} \
- --with-nagios-group=${NAGIOSGROUP} \
+ --with-nagios-grp=${NAGIOSGROUP} \
+ --with-template-objects \
--sbindir=${PREFIX}/share/nagios/cgi-bin \
--libexecdir=${PREFIX}/libexec/nagios \
--datadir=${PREFIX}/share/nagios \
@@ -50,6 +57,26 @@ CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
--localstatedir=${NAGIOSDIR} \
--prefix=${PREFIX}
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-inc=${LOCALBASE}/include/mysql \
+ --with-mysql-xdata
+.else
+CONFIGURE_ARGS+= --with-template-extinfo
+.endif
+
+.if defined(WITH_FILE_PERFDATA)
+CONFIGURE_ARGS+=--with-file-perfdata
+.endif
+
+.if defined(WITH_PGSQL)
+LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
+CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
+ --with-pgsql-inc=${LOCALBASE}/pgsql \
+ --with-pgsql-xdata
+.endif
+
SED_SCRIPT= -e 's,%%NAGIOSUSER%%,${NAGIOSUSER},g' \
-e 's,%%NAGIOSGROUP%%,${NAGIOSGROUP},g' \
-e 's,%%NAGIOSDIR%%,${NAGIOSDIR},g' \
@@ -59,8 +86,8 @@ SED_SCRIPT= -e 's,%%NAGIOSUSER%%,${NAGIOSUSER},g' \
INSTALL_TARGET= all install config install-config install-commandmode
pre-build:
- for myfile in nagios.sh INSTALL DEINSTALL MESSAGE; do \
- ${SED} ${SED_SCRIPT} < ${FILESDIR}/$${myfile}.tmpl >${WRKDIR}/$${myfile}; \
+ for file in nagios.sh INSTALL DEINSTALL MESSAGE; do \
+ ${SED} ${SED_SCRIPT} < ${FILESDIR}/$${file}.tmpl >${WRKDIR}/$${file}; \
done
pre-install:
@@ -68,9 +95,6 @@ pre-install:
post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/nagios.sh ${PREFIX}/etc/rc.d/
- @${CHMOD} 775 ${NAGIOSDIR} ${NAGIOSDIR}/archives ${NAGIOSDIR}/rw
- @${CHOWN} ${NAGIOSUSER}:${NAGIOSGROUP} ${NAGIOSDIR} ${NAGIOSDIR}/archives
- @${CHOWN} ${NAGIOSUSER}:www ${NAGIOSDIR}/rw
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/net-mgmt/nagios12/distinfo b/net-mgmt/nagios12/distinfo
index 3a3a21c439d0..80d6959ba4ac 100644
--- a/net-mgmt/nagios12/distinfo
+++ b/net-mgmt/nagios12/distinfo
@@ -1,2 +1,2 @@
-MD5 (nagios-2.0b3.tar.gz) = 051760458d961b6ee015b5932a8437c4
-SIZE (nagios-2.0b3.tar.gz) = 1704070
+MD5 (nagios-1.2.tar.gz) = 414d70e5269d5b8d7c21bf3ee129309f
+SIZE (nagios-1.2.tar.gz) = 1625322
diff --git a/net-mgmt/nagios12/pkg-plist b/net-mgmt/nagios12/pkg-plist
index d4cb7ed6cf13..0da4352e5755 100644
--- a/net-mgmt/nagios12/pkg-plist
+++ b/net-mgmt/nagios12/pkg-plist
@@ -3,16 +3,23 @@
@exec mkdir -p /var/spool/nagios/rw
@exec chmod 775 /var/spool/nagios /var/spool/nagios/archives /var/spool/nagios/rw
@exec chown nagios:nagios /var/spool/nagios /var/spool/nagios/archives
-@exec chown nagios:www /var/spool/nagios/rw
+@exec chown nagios:nogroup /var/spool/nagios/rw
bin/nagios
-bin/nagiostats
-etc/nagios/bigger.cfg-sample
etc/nagios/cgi.cfg-sample
etc/nagios/checkcommands.cfg-sample
-etc/nagios/minimal.cfg-sample
+etc/nagios/contactgroups.cfg-sample
+etc/nagios/contacts.cfg-sample
+etc/nagios/dependencies.cfg-sample
+etc/nagios/escalations.cfg-sample
+etc/nagios/hostextinfo.cfg-sample
+etc/nagios/hostgroups.cfg-sample
+etc/nagios/hosts.cfg-sample
etc/nagios/misccommands.cfg-sample
etc/nagios/nagios.cfg-sample
etc/nagios/resource.cfg-sample
+etc/nagios/serviceextinfo.cfg-sample
+etc/nagios/services.cfg-sample
+etc/nagios/timeperiods.cfg-sample
etc/rc.d/nagios.sh
share/nagios/cgi-bin/avail.cgi
share/nagios/cgi-bin/cmd.cgi
@@ -64,7 +71,6 @@ share/nagios/contexthelp/I5.html
share/nagios/contexthelp/I6.html
share/nagios/contexthelp/I7.html
share/nagios/contexthelp/I8.html
-share/nagios/contexthelp/I9.html
share/nagios/contexthelp/J1.html
share/nagios/contexthelp/K1.html
share/nagios/contexthelp/L1.html
@@ -127,7 +133,6 @@ share/nagios/docs/images/interleaved1.png
share/nagios/docs/images/interleaved2.png
share/nagios/docs/images/interleaved3.png
share/nagios/docs/images/logofullsize.png
-share/nagios/docs/images/mrtgstats.png
share/nagios/docs/images/network-heirarchy.png
share/nagios/docs/images/network-outage1.png
share/nagios/docs/images/network-outage2.png
@@ -142,7 +147,6 @@ share/nagios/docs/images/statetransitions.png
share/nagios/docs/images/statetransitions2.png
share/nagios/docs/about.html
share/nagios/docs/addons.html
-share/nagios/docs/adaptive.html
share/nagios/docs/beginners.html
share/nagios/docs/cgiauth.html
share/nagios/docs/cgiincludes.html
@@ -162,6 +166,7 @@ share/nagios/docs/embeddedperl.html
share/nagios/docs/escalations.html
share/nagios/docs/eventhandlers.html
share/nagios/docs/extcommands.html
+share/nagios/docs/faqs.html
share/nagios/docs/flapping.html
share/nagios/docs/freshness.html
share/nagios/docs/funstuff.html
@@ -169,10 +174,10 @@ share/nagios/docs/index.html
share/nagios/docs/indirectchecks.html
share/nagios/docs/installing.html
share/nagios/docs/installweb.html
+share/nagios/docs/int-portsentry.html
share/nagios/docs/int-snmptrap.html
share/nagios/docs/int-tcpwrappers.html
share/nagios/docs/macros.html
-share/nagios/docs/nagiostats.html
share/nagios/docs/networkoutages.html
share/nagios/docs/networkreachability.html
share/nagios/docs/notifications.html
@@ -196,9 +201,14 @@ share/nagios/docs/tuning.html
share/nagios/docs/verifyconfig.html
share/nagios/docs/volatileservices.html
share/nagios/docs/whatsnew.html
+share/nagios/docs/xdata-db.html
+share/nagios/docs/xeddefault.html
+share/nagios/docs/xedtemplate.html
+share/nagios/docs/xoddefault.html
share/nagios/docs/xodtemplate.html
+share/nagios/docs/xpddefault.html
+share/nagios/docs/xpdfile.html
share/nagios/images/ack.gif
-share/nagios/images/action.gif
share/nagios/images/command.png
share/nagios/images/comment.gif
share/nagios/images/contexthelp1.gif
@@ -206,7 +216,6 @@ share/nagios/images/contexthelp2.gif
share/nagios/images/critical.png
share/nagios/images/delay.gif
share/nagios/images/delete.gif
-share/nagios/images/detail.gif
share/nagios/images/disabled.gif
share/nagios/images/down.gif
share/nagios/images/downtime.gif
@@ -238,7 +247,11 @@ share/nagios/images/redudancy.png
share/nagios/images/redundancy.png
share/nagios/images/restart.gif
share/nagios/images/right.gif
+share/nagios/images/sbconfig.png
+share/nagios/images/sbgeneral.png
share/nagios/images/sblogo.jpg
+share/nagios/images/sbmonitor.png
+share/nagios/images/sbreport.png
share/nagios/images/serviceevent.gif
share/nagios/images/start.gif
share/nagios/images/status.gif
@@ -272,7 +285,6 @@ share/nagios/side.html
share/nagios/stylesheets/avail.css
share/nagios/stylesheets/checksanity.css
share/nagios/stylesheets/cmd.css
-share/nagios/stylesheets/common.css
share/nagios/stylesheets/config.css
share/nagios/stylesheets/extinfo.css
share/nagios/stylesheets/histogram.css
@@ -296,7 +308,6 @@ share/nagios/stylesheets/trends.css
@dirrm share/nagios/media
@dirrm share/nagios/ssi
@dirrm share/nagios/stylesheets
-@unexec rmdir %D/share/nagios 2>/dev/null || true
@unexec rmdir /var/spool/nagios/archives 2>/dev/null || true
@unexec rmdir /var/spool/nagios/rw 2>/dev/null || true
@unexec rmdir /var/spool/nagios 2>/dev/null || true