aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/amule/Makefile
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2009-05-21 15:23:12 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2009-05-21 15:23:12 +0000
commit06c6a5fe93afdeb750b46735b1d1723e8969f7bf (patch)
treeee2a488425f70b5c0c36b363a62c99ff94353cfc /net-p2p/amule/Makefile
parent427ffe7abdb70dc563b19a61a131b7a9246dc371 (diff)
downloadports-06c6a5fe93afdeb750b46735b1d1723e8969f7bf.tar.gz
ports-06c6a5fe93afdeb750b46735b1d1723e8969f7bf.zip
Notes
Diffstat (limited to 'net-p2p/amule/Makefile')
-rw-r--r--net-p2p/amule/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index 5483e61e039e..2a838e0ad993 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aMule
PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p
MASTER_SITES= SF/amule
@@ -45,7 +45,8 @@ OPTIONS= OPTIMIZE "Build with optimization" on \
ALC "Compile aMule Link Creator (+GUI)" on \
AMULEDAEMON "Compile aMule daemon version - EXPERIMENTAL" off \
WXUNICODE "Enable Unicode support" on \
- GEOIP "Enable GeoIP IP2Country support" off
+ GEOIP "Enable GeoIP IP2Country support" off \
+ UPNP "Enable Universal Plug and Play support" off
DOCSDIR= ${PREFIX}/share/doc/aMule-${PORTVERSION}
PORTDOCS= ABOUT-NLS Changelog EC_Protocol.txt \
@@ -123,6 +124,13 @@ LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+= --disable-geoip
.endif
+.if defined(WITH_UPNP)
+CONFIGURE_ARGS+= --with-libupnp-prefix=${LOCALBASE}
+LIB_DEPENDS+= upnp.3:${PORTSDIR}/devel/upnp
+.else
+CONFIGURE_ARGS+= --disable-upnp
+.endif
+
.if !defined(WITHOUT_WXUNICODE)
WX_UNICODE=yes
.endif