aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/apollon/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-04-25 08:45:55 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-04-25 08:45:55 +0000
commitec4ba5e446982acb9f5fe1f7cd49bd3773d05604 (patch)
tree3c9ad3660aed1140631cf79f09aa13a9786b6aee /net-p2p/apollon/Makefile
parentcaa1fcfca9bc92f9602170584c4d4e88470c0739 (diff)
downloadports-ec4ba5e446982acb9f5fe1f7cd49bd3773d05604.tar.gz
ports-ec4ba5e446982acb9f5fe1f7cd49bd3773d05604.zip
Notes
Diffstat (limited to 'net-p2p/apollon/Makefile')
-rw-r--r--net-p2p/apollon/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-p2p/apollon/Makefile b/net-p2p/apollon/Makefile
new file mode 100644
index 000000000000..b858e7cf3fe8
--- /dev/null
+++ b/net-p2p/apollon/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: apollon
+# Date Created: 29 Dec 2004
+# Whom: Alex Varju <freebsd-ports@varju.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apollon
+PORTVERSION= 1.0.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= apollon
+
+MAINTAINER= freebsd-ports@varju.ca
+COMMENT= KDE client for giFT daemon
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+
+post-patch:
+.ifdef(NOPORTDOCS)
+ @${REINPLACE_CMD} -E -e 's/^(all:)[[:space:]]+docs-am/\1/; s/^(SUBDIRS.+)doc/\1/' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>