aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-10-21 02:24:30 +0000
committerSteve Wills <swills@FreeBSD.org>2012-10-21 02:24:30 +0000
commit5a9a7e80ccb610593e909ba797cb6cb268ed4afd (patch)
tree45fdf27bd970757e343e22a24e22842f726c7016 /net-p2p/bitcoin
parent56a21e03103752c439538ac3b8e7ab91629b1c9d (diff)
downloadports-5a9a7e80ccb610593e909ba797cb6cb268ed4afd.tar.gz
ports-5a9a7e80ccb610593e909ba797cb6cb268ed4afd.zip
Notes
Diffstat (limited to 'net-p2p/bitcoin')
-rw-r--r--net-p2p/bitcoin/Makefile37
-rw-r--r--net-p2p/bitcoin/distinfo4
2 files changed, 21 insertions, 20 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 7e97f5e30b2e..559d7f6a64c5 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bitcoin
-PORTVERSION= 0.7.0
+PORTVERSION= 0.7.1
CATEGORIES= net-p2p finance
MAINTAINER= robbak@robbak.com
@@ -14,20 +14,23 @@ COMMENT= Virtual Peer-to-Peer Currency Client
LIB_DEPENDS= boost_date_time:${PORTSDIR}/devel/boost-libs
-OPTIONS= GUI "Build with QT3 GUI" on \
- UPNP "Build with UPNP support" off \
- QRCODES "Build with QR code display" on
+OPTIONS_DEFINE= GUI UPNP QRCODES
+OPTIONS_DEFAULT= GUI QRCODES
-USE_GITHUB= yes
-GH_ACCOUNT= bitcoin
+GUI_DESC= Build as a QT3 GUI
+UPNP_DESC= Build with UPNP support
+QRCODES_DESC= Build with QR code display
+
+USE_GITHUB= yes
+GH_ACCOUNT= bitcoin
GH_PROJECT= bitcoin
-GH_COMMIT= a76c22e
+GH_COMMIT= d082365
GH_TAGNAME= v${PORTVERSION}
USE_GMAKE= yes
USE_OPENSSL= yes
USE_BDB= yes
-WANT_BDB_VER= 47
+WANT_BDB_VER= 48
CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
CXXFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
@@ -35,7 +38,7 @@ CXXFLAGS+= -Wno-invalid-offsetof
.include <bsd.port.options.mk>
-.if defined(WITH_GUI) && !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
USE_QT_VER= 4
USE_QT4= corelib gui qmake_build linguist uic moc rcc
BINARY= bitcoin-qt
@@ -45,7 +48,7 @@ ALL_TARGET= ${BINARY}
MAKE_ARGS+= -C ${WRKSRC}/src
.endif
-.if defined(WITH_QRCODES)
+.if ${PORT_OPTIONS:MQRCODES}
LIB_DEPENDS+= qrencode:${PORTSDIR}/graphics/libqrencode
QMAKE_USE_QRCODE=1
.else
@@ -54,7 +57,7 @@ QMAKE_USE_QRCODE=0
PLIST_FILES= bin/${BINARY}
-.if defined(WITH_UPNP)
+.if ${PORT_OPTIONS:MUPNP}
LIB_DEPENDS+= miniupnpc:${PORTSDIR}/net/miniupnpc
QMAKE_USE_UPNP= 1
.else
@@ -67,19 +70,17 @@ post-patch:
@${CP} ${WRKSRC}/src/protocol.h ${WRKSRC}/src/protocol.h.orig
@${AWK} 'BEGIN { f = 0 } { if ( $$0 ~ /^#include/ && f == 0 ) { f = 1; print "#include <sys/socket.h>"; print "#include <netinet/in.h>" }; print }' \
${WRKSRC}/src/protocol.h.orig > ${WRKSRC}/src/protocol.h
-
+.if !${PORT_OPTIONS:MGUI} || defined(WITHOUT_X11)
@cd ${WRKSRC}/src && ${CP} -p makefile.unix Makefile
@${REINPLACE_CMD} \
- -e 's|wx-config|${WX_CONFIG}|g' \
- -e 's|^CXXFLAGS=.*$$|CXXFLAGS += $$(DEFS)|' \
- -e 's|^USE_UPNP.*$$||' \
+ -e 's|^USE_UPNP.*$$|USE_UPNP=${QMAKE_USE_UPNP}|' \
-e 's|-l pthread|${PTHREAD_LIBS}|g' \
- -e 's:-O3::' -e 's:-\(march=[A-Za-z0-9]*\)::g' \
-e 's:-l dl::' \
${WRKSRC}/src/Makefile
+.endif
do-configure:
-.if defined(WITH_GUI) && !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} USE_UPNP=${QMAKE_USE_UPNP} USE_QRCODE=${QMAKE_USE_QRCODE} \
QMAKE_LRELEASE=lrelease-qt4 PREFIX=${PREFIX} INCLUDEPATH=${BDB_INCLUDE_DIR} \
@@ -88,7 +89,7 @@ do-configure:
do-install:
@${MKDIR} ${PREFIX}/bin
-.if defined(WITH_GUI) && !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
${INSTALL_PROGRAM} ${WRKSRC}/${BINARY} ${PREFIX}/bin/
.else
${INSTALL_PROGRAM} ${WRKSRC}/src/${BINARY} ${PREFIX}/bin/
diff --git a/net-p2p/bitcoin/distinfo b/net-p2p/bitcoin/distinfo
index 4ad4558828b7..0ff7a1e4145e 100644
--- a/net-p2p/bitcoin/distinfo
+++ b/net-p2p/bitcoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bitcoin-0.7.0.tar.gz) = d0b5ca34c61e8fbd6dca53f2730fa3d8e3df1f7bb40d5e42f8ea4cd3bf32a221
-SIZE (bitcoin-0.7.0.tar.gz) = 1603153
+SHA256 (bitcoin-0.7.1.tar.gz) = eb1c4bb59a6a6557e59dec5d90ab7c45b660898f535fafaeaed051aeb347b94d
+SIZE (bitcoin-0.7.1.tar.gz) = 1623510