aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2011-05-24 23:21:23 +0000
committerShaun Amott <shaun@FreeBSD.org>2011-05-24 23:21:23 +0000
commit64d57260db79ad65f501e78a3ab8247fe7e55e71 (patch)
tree283aabd30f8703712dd7e467f409213377f5cdc2 /net-p2p/bitcoin
parent0e2fc8f4c32f384d1f9f08233055c08a751a6352 (diff)
downloadports-64d57260db79ad65f501e78a3ab8247fe7e55e71.tar.gz
ports-64d57260db79ad65f501e78a3ab8247fe7e55e71.zip
Notes
Diffstat (limited to 'net-p2p/bitcoin')
-rw-r--r--net-p2p/bitcoin/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index ffe8d0c15628..e0619612d7f5 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -41,10 +41,12 @@ USE_GNOME= gtk20
BUILD_DEPENDS+= ${LOCALBASE}/include/wx-2.9/wx/aboutdlg.h:${PORTSDIR}/x11-toolkits/wxgtk29
WX_CONFIG= ${LOCALBASE}/bin/wxgtk2u-2.9-config
-PLIST_FILES= bitcoin
+BINARY= bitcoin
+PLIST_FILES= bin/${BINARY}
.else
-ALL_TARGET= bitcoind
-PLIST_FILES= bitcoind
+BINARY= bitcoind
+ALL_TARGET= ${BINARY}
+PLIST_FILES= bin/${BINARY}
.endif
.if defined(WITH_UPNP)
@@ -76,6 +78,6 @@ post-patch:
do-install:
@${MKDIR} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/${PLIST_FILES} ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${BINARY} ${PREFIX}/bin/
.include <bsd.port.post.mk>