aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2017-11-08 08:18:27 +0000
committerVasil Dimov <vd@FreeBSD.org>2017-11-08 08:18:27 +0000
commitca843c7c49bb73af85eba70127b3b09e3642a20f (patch)
tree253012512d463561385b46079164295985d33741 /net-p2p/bitcoin
parentd689e22190ebe8cf2a476f04bcd0596b1007e96d (diff)
downloadports-ca843c7c49bb73af85eba70127b3b09e3642a20f.tar.gz
ports-ca843c7c49bb73af85eba70127b3b09e3642a20f.zip
Notes
Diffstat (limited to 'net-p2p/bitcoin')
-rw-r--r--net-p2p/bitcoin/Makefile1
-rw-r--r--net-p2p/bitcoin/files/bitcoind.in6
2 files changed, 5 insertions, 2 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 822c7898e308..934907dfcbe7 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -4,6 +4,7 @@
PORTNAME= bitcoin
PORTVERSION= 0.15.0.1
DISTVERSIONPREFIX= v
+PORTREVISION?= 1
CATEGORIES= net-p2p finance
MAINTAINER= robbak@robbak.com
diff --git a/net-p2p/bitcoin/files/bitcoind.in b/net-p2p/bitcoin/files/bitcoind.in
index e620d9dcc4fb..4df6ec8f6bc1 100644
--- a/net-p2p/bitcoin/files/bitcoind.in
+++ b/net-p2p/bitcoin/files/bitcoind.in
@@ -12,7 +12,7 @@
# bitcoind_user (str) Set to "bitcoin" by default.
# bitcoind_group (str) Set to "bitcoin" by default.
# bitcoind_conf (str) Set to "%%PREFIX%%/etc/bitcoind.conf" by default.
-# bitcoind_data (str) Set to "/var/lib/bitcoin" by default.
+# bitcoind_data_dir (str) Set to "/var/db/bitcoin" by default.
# bitcoindlimits_enable (bool) Set to "NO" by default.
# Set it to "YES" to enable bitcoindlimits
# bitcoindlimits_args Set to "-e -U ${bitcoind_user}" by default
@@ -121,7 +121,9 @@ bitcoind_start()
${daemon_command} -u "${bitcoind_user}" -p "${pidfile}" \
${command} \
-conf="${bitcoind_config_file}" \
- -datadir="${bitcoind_data_dir}" 2> /tmp/bitcoind.stderr > /tmp/bitcoind.stdout
+ -datadir="${bitcoind_data_dir}" \
+ 2> "${bitcoind_data_dir}/bitcoind.stderr" \
+ > "${bitcoind_data_dir}/bitcoind.stdout"
}
bitcoind_stop()