aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/bnbt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-01 14:26:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-01 14:26:54 +0000
commit2c84fe226a75d70ad63456809693cf4332683954 (patch)
tree785f339734496ce26c30a8353b7810f13f2b17ab /net-p2p/bnbt
parentc9afbd9bd849497e06ba8491b8952cff184fd587 (diff)
downloadports-2c84fe226a75d70ad63456809693cf4332683954.tar.gz
ports-2c84fe226a75d70ad63456809693cf4332683954.zip
Notes
Diffstat (limited to 'net-p2p/bnbt')
-rw-r--r--net-p2p/bnbt/Makefile40
-rw-r--r--net-p2p/bnbt/distinfo1
-rw-r--r--net-p2p/bnbt/pkg-descr10
-rw-r--r--net-p2p/bnbt/pkg-plist10
4 files changed, 61 insertions, 0 deletions
diff --git a/net-p2p/bnbt/Makefile b/net-p2p/bnbt/Makefile
new file mode 100644
index 000000000000..df9a71dd2232
--- /dev/null
+++ b/net-p2p/bnbt/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: bnbt
+# Date created: Jan 31 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bnbt
+PORTVERSION= 7.3b
+CATEGORIES= net
+MASTER_SITES= http://bnbt.go-dedicated.com/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
+
+MAINTAINER= flz@xbsd.org
+COMMENT= A C++ BitTorrent Tracker
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2 -w|${CFLAGS}| ; \
+ s|LFLAGS = -pthread|LFLAGS = ${PTHREAD_LIBS}| ; \
+ s|CFLAGS = -pthread|CFLAGS = ${PTHREAD_CFLAGS}|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bnbt ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/bnbt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/footer.html ${PREFIX}/share/bnbt
+ ${INSTALL_DATA} ${WRKSRC}/formats.txt ${PREFIX}/share/bnbt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/header.html ${PREFIX}/share/bnbt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/lesser.txt ${PREFIX}/share/bnbt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/link.txt ${PREFIX}/share/bnbt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/readme.txt ${PREFIX}/share/bnbt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/stealers.txt ${PREFIX}/share/bnbt
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/users.txt ${PREFIX}/share/bnbt
+
+.include <bsd.port.mk>
diff --git a/net-p2p/bnbt/distinfo b/net-p2p/bnbt/distinfo
new file mode 100644
index 000000000000..ae2fdd9e616f
--- /dev/null
+++ b/net-p2p/bnbt/distinfo
@@ -0,0 +1 @@
+MD5 (bnbt73b.zip) = 8881f42353ebb896e6aeb53e085cb1e6
diff --git a/net-p2p/bnbt/pkg-descr b/net-p2p/bnbt/pkg-descr
new file mode 100644
index 000000000000..d60672e40fe8
--- /dev/null
+++ b/net-p2p/bnbt/pkg-descr
@@ -0,0 +1,10 @@
+BNBT was written by Trevor Hogan. BNBT is a complete port of the
+original Python BitTorrent tracker to C++ using the STL for data storage
+and basic network sockets for network communication. BNBT is fast,
+efficient, customizable, easy to use, powerful, and portable. BNBT is
+covered under the GNU Lesser General Public License (LGPL).
+
+WWW: http://bnbt.go-dedicated.com/
+
+- Florent Thoumie
+flz@xbsd.org
diff --git a/net-p2p/bnbt/pkg-plist b/net-p2p/bnbt/pkg-plist
new file mode 100644
index 000000000000..e9651fd1bc60
--- /dev/null
+++ b/net-p2p/bnbt/pkg-plist
@@ -0,0 +1,10 @@
+bin/bnbt
+share/bnbt/footer.html
+share/bnbt/formats.txt
+share/bnbt/header.html
+share/bnbt/lesser.txt
+share/bnbt/link.txt
+share/bnbt/readme.txt
+share/bnbt/stealers.txt
+share/bnbt/users.txt
+@dirrm share/bnbt