aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/btpd/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:38:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:38:38 +0000
commit3f339aeb0ac1dee633ce21a3f6ac60c9472e847d (patch)
treef7743e58f6b5aa41f4239b4f90456c409881dd8d /net-p2p/btpd/Makefile
parente44760de7c9dd0e26a62e23701e472178d8417ad (diff)
downloadports-3f339aeb0ac1dee633ce21a3f6ac60c9472e847d.tar.gz
ports-3f339aeb0ac1dee633ce21a3f6ac60c9472e847d.zip
Notes
Diffstat (limited to 'net-p2p/btpd/Makefile')
-rw-r--r--net-p2p/btpd/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-p2p/btpd/Makefile b/net-p2p/btpd/Makefile
new file mode 100644
index 000000000000..73f325a30f22
--- /dev/null
+++ b/net-p2p/btpd/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: btpd
+# Date created: 2008-11-14
+# Whom: bapt <baptiste.daroussin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= btpd
+PORTVERSION= 0.13
+CATEGORIES= net-p2p
+MASTER_SITES= http://www.murmeldjur.se/btpd/
+
+MAINTAINER= baptiste.daroussin@gmail.com
+COMMENT= Bittorrent client consisting of a daemon and client commands
+
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/btcli \
+ bin/btinfo \
+ bin/btpd
+
+PORTDOCS= README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>