aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/btpeer
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-09-25 22:29:20 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-09-25 22:29:20 +0000
commitbbc2ad8e01b7c69161d3cdda6497e4b371e0c0de (patch)
treeaad872d35ac51ed7ceffa028592507ae8937ff8e /net-p2p/btpeer
parent254a63deeb131ef4f4cac428a82d808788cd7306 (diff)
downloadports-bbc2ad8e01b7c69161d3cdda6497e4b371e0c0de.tar.gz
ports-bbc2ad8e01b7c69161d3cdda6497e4b371e0c0de.zip
Notes
Diffstat (limited to 'net-p2p/btpeer')
-rw-r--r--net-p2p/btpeer/Makefile58
-rw-r--r--net-p2p/btpeer/distinfo2
-rw-r--r--net-p2p/btpeer/files/patch-Makefile17
-rw-r--r--net-p2p/btpeer/pkg-descr13
4 files changed, 90 insertions, 0 deletions
diff --git a/net-p2p/btpeer/Makefile b/net-p2p/btpeer/Makefile
new file mode 100644
index 000000000000..033ffd95661e
--- /dev/null
+++ b/net-p2p/btpeer/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: btpeer
+# Date created: Sun Sep 25 13:54:22 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= btpeer
+PORTVERSION= 0.2.1
+CATEGORIES= net
+MASTER_SITES= http://www.alhem.net/project/btpeer/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Client functionality of bittorrent protocol, network only environment
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libSockets-devel.a:${PORTSDIR}/net/Sockets-devel
+
+USE_GMAKE= yes
+USE_OPENSSL= yes
+WITH_OPENSSL_BASE= yes
+MAKE_ENV= CXX="${CXX}"
+USE_REINPLACE= yes
+
+# ssl support
+CFLAGS+= ${PTHREAD_CFLAGS} -DHAVE_OPENSSL
+
+PROGRAM_FILES= \
+ inject \
+ newpeer
+
+post-patch:
+# CXX safeness
+# CXXFLAGS safeness
+# SSL include safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|-O2||' \
+ -e 's|g\+\+|${CXX}|' \
+ -e 's|^INCLUDE.+$$|INCLUDE=-I${OPENSSLINC} -I${LOCALBASE}/include/Sockets-devel|' \
+ -e 's|^LIBS.+$$|LIBS=-L${OPENSSLLIB} ${PTHREAD_LIBS} -L${LOCALBASE}/lib \\|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+
+do-install:
+.for file in ${PROGRAM_FILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin/${PORTNAME}-${file}
+.endfor
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= FreeBSD prior to 500000 does not support uuid(3) required\
+ for building
+.endif
+
+.for file in ${PROGRAM_FILES}
+PLIST_FILES+= bin/${PORTNAME}-${file}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/btpeer/distinfo b/net-p2p/btpeer/distinfo
new file mode 100644
index 000000000000..65e46a19ce08
--- /dev/null
+++ b/net-p2p/btpeer/distinfo
@@ -0,0 +1,2 @@
+MD5 (btpeer-0.2.1.tar.gz) = a38bbdcf36c55bdb18169ad5fc81d039
+SIZE (btpeer-0.2.1.tar.gz) = 42193
diff --git a/net-p2p/btpeer/files/patch-Makefile b/net-p2p/btpeer/files/patch-Makefile
new file mode 100644
index 000000000000..ba3d5f073f6c
--- /dev/null
+++ b/net-p2p/btpeer/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Sun Sep 11 04:27:32 2005
++++ Makefile Sun Sep 25 17:54:42 2005
+@@ -1,11 +1,11 @@
+ VERSION = 0.2.1
+
+ INCLUDE = -I/usr/local/include/Sockets
+-CFLAGS = -Wall -g -O2 $(INCLUDE) -MD `Sockets-config`
++CFLAGS = -Wall -g -O2 $(INCLUDE) -MD `Sockets-devel-config`
+ CPPFLAGS = $(CFLAGS)
+
+-LIBS = -L/usr/local/lib -lSockets \
+- -lssl -lcrypto -luuid -lSocketsEx -lpthread
++LIBS = -L/usr/local/lib -lSockets-devel \
++ -lssl -lcrypto -lSockets-devel -lSocketsEx-devel
+
+ PROGS = newpeer inject
+ # bstr
diff --git a/net-p2p/btpeer/pkg-descr b/net-p2p/btpeer/pkg-descr
new file mode 100644
index 000000000000..cadf1bf3de2c
--- /dev/null
+++ b/net-p2p/btpeer/pkg-descr
@@ -0,0 +1,13 @@
+[ excerpt from developer's web site ]
+
+This is a collection of classes implementing the core client
+functionality of the bittorrent protocol, in a network only
+environment. 'Network only' means that all interaction with the
+client core is done via network connections. Loading of metainfo
+files are done using a small program for file transfer into the
+client core ("inject"), status of the client is shown using a small
+internal web page server.
+
+WWW: http://www.alhem.net/project/btpeer/index.html
+
+-- lioux@FreeBSD.org