aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/btqueue/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-05 12:54:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-05 12:54:40 +0000
commit2c0f69dba8bc90f69f40ab8772a7aa17ba0e6c9b (patch)
tree718cb274b81904f31f4020e6aa3790965a6a291a /net-p2p/btqueue/Makefile
parent0af890b46b3298d64d430f7d4207da2740ef2200 (diff)
downloadports-2c0f69dba8bc90f69f40ab8772a7aa17ba0e6c9b.tar.gz
ports-2c0f69dba8bc90f69f40ab8772a7aa17ba0e6c9b.zip
Notes
Diffstat (limited to 'net-p2p/btqueue/Makefile')
-rw-r--r--net-p2p/btqueue/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-p2p/btqueue/Makefile b/net-p2p/btqueue/Makefile
new file mode 100644
index 000000000000..1f25bbfe6adb
--- /dev/null
+++ b/net-p2p/btqueue/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: BTQueue
+# Date created: 04 Jun 2004
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= btqueue
+PORTVERSION= 0.0.8
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= BTQueue-${PORTVERSION}
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= Alternative BitTorrent client with queuing functionality
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
+
+CONFLICTS= py??-*[Bb]it[Tt]ornado* py??-*[Bb]it[Tt]orrent*
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>