aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/c-lightning
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-21 10:48:58 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-21 10:48:58 +0000
commit749702a3ec4222d052a27d901f7297fc249e1b9c (patch)
tree4b24e1979067d597dc7b366ad58c5f7e1d00385f /net-p2p/c-lightning
parent94c99ad3d1fb65182de2ce28c78f80b6de926cc3 (diff)
downloadports-749702a3ec4222d052a27d901f7297fc249e1b9c.tar.gz
ports-749702a3ec4222d052a27d901f7297fc249e1b9c.zip
net-p2p/c-lightning: fix build on GCC architectures
Needs C11 compiler: cc1: error: unrecognized command line option "-std=gnu11" Needs include sys/types.h in fdpass.c: ccan/ccan/fdpass/fdpass.c: In function 'fdpass_send': ccan/ccan/fdpass/fdpass.c:16:12: error: 'register_t' undeclared (first use in this function) 16 | char buf[CMSG_SPACE(sizeof(fd))]; | ^~~~~~~~~~ PR: 243481 Approved by: vd (maintainer) MFH: 2020Q1 (fix build blanket)
Notes
Notes: svn path=/head/; revision=523712
Diffstat (limited to 'net-p2p/c-lightning')
-rw-r--r--net-p2p/c-lightning/Makefile3
-rw-r--r--net-p2p/c-lightning/files/patch-ccan_ccan_fdpass_fdpass.c10
2 files changed, 12 insertions, 1 deletions
diff --git a/net-p2p/c-lightning/Makefile b/net-p2p/c-lightning/Makefile
index f8ad438aabb1..84590bbbf127 100644
--- a/net-p2p/c-lightning/Makefile
+++ b/net-p2p/c-lightning/Makefile
@@ -22,7 +22,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libsqlite3.so:databases/sqlite3
RUN_DEPENDS= bitcoin-cli:net-p2p/bitcoin-utils
-USES= autoreconf:build gettext gmake libtool python:3.5+,build
+USES= autoreconf:build compiler:c11 gettext gmake libtool \
+ python:3.5+,build
BINARY_ALIAS= python=${PYTHON_CMD} python3=${PYTHON_CMD}
ALL_TARGET= default
diff --git a/net-p2p/c-lightning/files/patch-ccan_ccan_fdpass_fdpass.c b/net-p2p/c-lightning/files/patch-ccan_ccan_fdpass_fdpass.c
new file mode 100644
index 000000000000..d126ff426ce3
--- /dev/null
+++ b/net-p2p/c-lightning/files/patch-ccan_ccan_fdpass_fdpass.c
@@ -0,0 +1,10 @@
+--- ccan/ccan/fdpass/fdpass.c.orig 2020-01-20 22:03:36 UTC
++++ ccan/ccan/fdpass/fdpass.c
+@@ -1,6 +1,7 @@
+ /* CC0 license (public domain) - see LICENSE file for details */
+ #include <ccan/fdpass/fdpass.h>
+ #include <sys/socket.h>
++#include <sys/types.h>
+ #include <errno.h>
+ #include <string.h>
+