aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/dclib/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-06-02 12:03:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-06-02 12:03:12 +0000
commit98b78d20b049e6a3ae2295f360c104429321f565 (patch)
treebd0b70884aa66c0e702c17fd1dbca3a37e17385a /net-p2p/dclib/Makefile
parentd0383e1ee9c467eabbec8748eb8ffcf6ce951086 (diff)
downloadports-98b78d20b049e6a3ae2295f360c104429321f565.tar.gz
ports-98b78d20b049e6a3ae2295f360c104429321f565.zip
Notes
Diffstat (limited to 'net-p2p/dclib/Makefile')
-rw-r--r--net-p2p/dclib/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/net-p2p/dclib/Makefile b/net-p2p/dclib/Makefile
index 04977af940c6..7d9c487a89fe 100644
--- a/net-p2p/dclib/Makefile
+++ b/net-p2p/dclib/Makefile
@@ -1,3 +1,4 @@
+# ex: ts=8
# New ports collection makefile for: dclib
# Date created: Wed 10 Jul 2002
# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
@@ -7,10 +8,11 @@
#
PORTNAME= dclib
-PORTVERSION= 0.3.13
+PORTVERSION= 0.3.14
CATEGORIES= net-p2p
MASTER_SITES= SF
MASTER_SITE_SUBDIR= wxdcgui
+DISTNAME= ${PORTNAME}-${PORTVERSION}a
MAINTAINER= gahr@FreeBSD.org
COMMENT= Direct connect interface library for valknut
@@ -18,6 +20,8 @@ COMMENT= Direct connect interface library for valknut
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
xml2.5:${PORTSDIR}/textproc/libxml2
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -25,10 +29,15 @@ USE_OPENSSL= yes
USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+post-extract:
+ ${CHMOD} 0755 ${WRKSRC}/admin/install-sh
+
post-patch:
- @${REINPLACE_CMD} -e 's/-O2//g; s/-pedantic //g' \
+ ${REINPLACE_CMD} -e 's/-O2//g; s/-pedantic //g' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.in
+ ${FIND} ${WRKSRC} -name "Makefile.*" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|dclib-0.3/||g'
.include <bsd.port.mk>